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Finding Documentation
To access complete and up-to-date product information, go to Citrix eDocs located at
http://support.citrix.com/proddocs/index.jsp and expand the topics for your product.
Licensing Documentation
To access licensing documentation, go to
http://support.citrix.com/proddocs/topic/licensing/lic-library-node-wrapper.html.

Getting Support
Citrix provides technical support primarily through Citrix Solutions Advisor. Contact your
supplier for first-line support or use Citrix Online Technical Support to find the nearest
Citrix Solutions Advisor.
Citrix offers online technical support services on the Citrix Support Web site. The Support
page includes links to downloads, the Citrix Knowledge Center, Citrix Consulting Services,
and other useful support pages.

Known Issues
•
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Users cannot launch sessions from Safari after upgrading from Version 10.0 to Version
11.2 of the plug-in if Safari is left open during the upgrade process. To avoid this issue,

Readme for Citrix Online Plug-in for Macintosh 11.2
either close and re-open Safari after the upgrade is complete or ensure Safari is closed
during the upgrade process. [#237992]
•

Users may experience issues with keyboard input if the current keyboard layout for the
virtual desktop (for XenDesktop sessions) or server (for XenApp sessions) to which they
connect differs from the original default keyboard layout for that virtual desktop or
server. As a workaround, for XenDesktop sessions only, users can change the current
keyboard layout on the virtual desktop to match the original default keyboard layout.
There is no workaround for XenApp sessions. [#238285], [#224018], [#223499]

•

The Desktop Connecting dialog box fails to close when launching desktops hosted by
XenApp 6.0. As a workaround, users should close the Desktop Connecting dialog box
after connecting to their desktop. [#239727]

•

Users cannot subscribe to applications and virtual desktops using Dazzle if logged on to
the client device with a normal user account. Dazzle requires the user to be logged on
as an administrator. If this is not possible in your environment, the following
workarounds allow a user logged on with a normal account to subscribe to applications:
•

Drag applications and virtual desktops to the desktop or to a folder other than the
Applications folder, rather than clicking the Add button in Dazzle.

•

Log on as an administrator, create a Dazzle folder in Applications, and set the
permissions for that folder to Read and Write for all users.

Ask a system administrator to log on, run Dazzle, and modify the permissions for
the Dazzle folder to Read and Write for all users. [#212763, 219444 ]
Minimized applications may re-appear in the foreground of your screen when launching
new applications using the plug-in. Note that this issue is seen only with applications to
which you have subscribed using Dazzle. It is not seen with applications accessed
through Web Interface. [#222517]
•

•

http://www.citrix.com
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Citrix Online Plug-in for Macintosh 11.2
Release Note
This release note summarizes the new features and enhancements in Citrix Online Plug-in
for Macintosh, Version 11.2 and describes how to install or upgrade to this version.

What's New
The Online Plug-in for Macintosh, Version 11.2 provides the following new features and
enhancements, which are all described in more detail in subsequent sections of this release
note:
•

Server-client content redirection

•

Desktop resize support

•

Desktop toolbar support

•

Direct application launch using Dazzle

•

Extended client drive mapping support

•

Extended multi-monitor support

Server-client Content Redirection
Server-client content redirection enables administrators to specify that URLs in a published
application are opened using a local application. For example, opening a link to a Web page
while using Microsoft Outlook in an ICA session opens the required file using the browser on
the client device. Server-client content redirection enables administrators to allocate Citrix
resources more efficiently, thereby providing users with better performance.
The following types of URL can be redirected:
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•

HTTP (Hypertext Transfer Protocol)

•

HTTPS (Secure Hypertext Transfer Protocol)

•

RTSP (Real Player)

•

RTSPU (Real Player)

•

PNM (Older Real Players)

•

MMS (Microsoft Media Server)

Citrix Online Plug-in for Macintosh 11.2 Release Note
Server-client content redirection is configured on the server.

Desktop Resize Support
Desktop resize support enables users to resize their desktop when connected to desktop
sessions, using the resize control, zoom button, or by selecting Full screen or Windowed
from the View menu on the toolbar. Note that these options are available only when
connected to non-seamless sessions.

Desktop Toolbar Support
The new Desktop Toolbar enables users to perform the following tasks when connected to
full screen desktop sessions:
•

Switch between the desktop session and the local desktop

•

Switch between full screen and windowed view for the desktop session

•

Send CTRL+ALT+DEL to the desktop session to lock or log off from the remote desktop

•

Disconnect from the remote desktop

•

Change Online Plug-in for Macintosh preferences

For more information, see Configuring Desktop Toolbar Support, below.

Direct Application Launch Using Dazzle
Users can now launch applications and desktops direct from Dazzle, by double-clicking on
an application or desktop icon after subscribing to that application or desktop.

Extended Client Drive Mapping Support
Extended client drive mapping support enables users to select to always allow or deny
access to local drives from remote applications and desktops. Users can also select to allow
read-only access to local drives, if required.

Extended Multi-monitor Support
Improved multi-monitor support enables users to launch full screen desktop sessions from
XenDesktop across multiple monitors. Users can also resize existing session windows, by
dragging the session window to cover multiple monitors and selecting Full screen from the
View menu.
For more information, see Configuring Extended Multi-monitor Support, below.
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How to Use Plug-in for Macintosh Documentation
Known issues in this version are described in Readme for Online Plug-in for Macintosh 11.2.

Installing and Upgrading
Upgrading to the Online Plug-in for Macintosh, Version 11.2 is supported from either version
11.0 or version 11.1 of the plug-in.
Important: Before upgrading to the latest version of the plug-in, you must remove all
applications and desktops to which you have subscribed using an earlier version.

Configuring Desktop Toolbar Support
Administrators can configure Desktop Toolbar support on both the server and the client
device. If Desktop Toolbar support is not configured on the server, it can still be configured
on the client device. If Desktop Toolbar support is explicitly disabled on the server,
however, this overrides any configuration on the client device.
To configure Desktop Toolbar support on the server
1. Open the default.ica file, typically located in
C:\inetpub\wwwroot\Citrix\SiteName\conf\.
2. Add ConnectionBar=1 to the Applications section.
3. Save the file and restart the server.
To configure Desktop Toolbar support on the client device
1. Open the Config file, located in a user's home folder at
Username/Library/Preferences/CitrixICAClient/
2. Add ConnectionBar=1 to the Thinwire 3.0 section.
3. Save the file.
Changes take effect the next time a user connects to a desktop session from the client
device.

Configuring Extended Multi-monitor Support
Administrators can configure extended multi-monitor support for users either on a
per-server or per-client device basis.
To configure extended multi-monitor support on the server
1. Open the default.ica file, typically located in
C:\inetpub\wwwroot\Citrix\SiteName\conf\.
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2. Add the following parameters to the Applications section:
•

DesiredHRES= Width of session, between 120 and 8000 pixels

•

DesiredVRES= Height of session, between 80 and 6000 pixels

•

DesiredHPos= Horizontal position of the top-left corner of the desktop session

•

DesiredVPos= Vertical position of the top-left corner of the desktop session

DesiredWinType=16
3. Save the file and restart the server.
•

To configure extended multi-monitor support on the client device
1. Open the Config file, located in a user's home folder at
Username/Library/Preferences/CitrixICAClient/
2. Add the following parameters to the Thinwire 3.0 section:
•

DesiredHRES= Width of session, between 120 and 8000 pixels

•

DesiredVRES= Height of session, between 80 and 6000 pixels

•

DesiredHPos= Horizontal position of the top-left corner of the desktop session

•

DesiredVPos= Vertical position of the top-left corner of the desktop session

DesiredWinType=16
3. Save the file.
•

Changes take effect the next time a user connects to a desktop session from the client
device.
Important: Remember the following when configuring extended multi-monitor support:
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•

The numbers of pixels specified for the DesiredHRES and DesiredVRES parameters must
add up to the total resolution of monitors in a user's setup. For example, if users have 2
monitors, each with a resolution of 1024x768, specify 2048 for DesiredHRES and 768 for
DesiredVRES.

•

By default, both the DesiredHPos and DesiredVPos parameters are set to 0, where "0,0"
are the coordinates assigned to the top left-hand corner of the top left-hand monitor in
a user's setup and specify a desktop sessions' top left-hand position on screen. To
position a desktop sessions' top left-hand corner elsewhere on-screen, specify other
coordinates for these parameters.

•

The DesiredWinType parameter must be set to 16.

About the Plug-in for Macintosh
The Citrix online plug-in for Macintosh (the plug-in) provides users with access to resources
published on XenApp or XenDesktop servers. The plug-in combines ease of deployment and
use, and offers quick, secure access to applications and virtual desktops.
After subscribing to published resources, users can access those resources from a familiar
Macintosh desktop environment. Users work with published resources the same way they
work with local applications and files. Published resources are represented on the local
desktop, by icons that behave just like local icons, on the Dock, or in the Dazzle folder
available from the Finder.
Users can also access published resources from within a familiar browser environment, by
clicking links on a Web page you publish on your corporate intranet or the Internet.
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Deploying the Plug-in for Macintosh
Installation files for the plug-in are available for download from the Citrix Web site.
This section contains information about system requirements, installation packages, and
installing the plug-in in your environment.
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System Requirements
Ensure your system meets the following hardware and software requirements before
installing the plug-in.

Hardware Requirements
The computer on which you intend to install the plug-in must meet the following minimum
requirements:
•

At least 256 MB of RAM

•

29 MB of free disk space

•

A working network or Internet connection to connect to servers

Software Requirements
You can install the plug-in manually or through Citrix Receiver. Supported operating
systems for each install type are as follows:

13

Operating System

Install manually?

Install through Receiver?

Mac OS X Version 10.4
(Intel-based) 32-bit and
64-bit

Yes

No

Mac OS X Version 10.4
(PowerPC-based) 32-bit and
64-bit

Yes

No

Mac OS X Version 10.5
(Intel-based) 32-bit and
64-bit

Yes

Yes

Mac OS X Version 10.5
(PowerPC-based) 32-bit and
64-bit

Yes

No

Mac OS X Version 10.6
(Intel-based) 32-bit and
64-bit

Yes

Yes

Overview of Plug-in Installation Packages
This release contains two installation packages and offers several options for installing the
plug-in. You can install the two plug-in installer packages with almost no user interaction.
•

Citrix_online_plugin.dmg - Complete package

•

Citrix_online_plugin_web.dmg - Smaller, more limited package that you can deploy
from a Web page.
Note: The Citrix online web plug-in package does not include Dazzle.

Note: Upgrades are supported only from versions 10.x and 11.0 of the plug-in. Remove
any earlier versions before installing the online plug-in.
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Using the Merchandising Server and
Citrix Receiver to Deploy the Plug-in
Citrix recommends using the Merchandising Server and Citrix Receiver for Macintosh to
deploy and update the plug-in to a user device.
Citrix Merchandising Server administrator console. With the administrator console, you
can upload the plug-in installation and metadata files, create reuseable rules to define the
delivery recipients, and create deliveries.
Citrix Receiver client (Receiver for Macintosh). After users install Receiver for Macintosh
on their user devices, Receiver installs, updates, and starts the plug-in with minimal user
interaction.
Users can change their plug-in settings using the Application Delivery pane in Citrix
Receiver preferences.

Upgrading the Plug-in with Receiver
Updates are, by default, automatically installed on the user device. When an update is
available, the Receiver downloads and installs the updated plug-in.

Uninstalling the Plug-in with Receiver
Receiver upgrades the plug-in when a newer plug-in is available. When users remove the
Receiver manually, the plug-in is also removed. Additionally, the administrator can remove
the Receiver and all of its managed plug-ins through the Merchandising Server Administrator
Console.
For more information, see the Merchandising Server documentation.
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Installing the Plug-in
You can download the Citrix online plug-in for Macintosh from the Citrix Web site, at
http://www.citrix.com.

To install the plug-in
1. Log on as an administrator.
2. Download the .dmg file for the version of the plug-in you want to install from the Citrix
Web site and open it. This runs the Disk Utility program, which mounts the file as a disk
image accessible from your Macintosh desktop.
3. On the Introduction page, click Continue.
4. On the License page, click Continue.
5. Click Agree to accept the terms of the License Agreement.
6. On the Destination Select page, select the volume where you want to install the
plug-in and click Continue.
7. On the Installation Type page, click Install.
8. Enter the administrator account details for the device on which you are installing the
plug-in and click OK.
9. To subscribe to applications and desktops immediately, click Open Dazzle now when
prompted.
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Upgrading the Plug-in
You can upgrade to the latest version of the plug-in from the following previous versions:
•

Citrix Presentation Server Client for Macintosh, Version 10.0

•

Citrix Online Plug-in for Macintosh, Version 11.0 (Full)

•

Citrix Online Plug-in for Macintosh, Version 11.0 (Web)

Before upgrading to version 11.1 of the Citrix online plug-in, be aware of the following:
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•

You must remove all applications and desktops to which you have previously subscribed
before upgrading to the latest version of the plug-in.

•

Any existing custom connection files are preserved and can be used to connect to
remote applications and desktops. The creation of new custom connection files,
however, is no longer supported.

Uninstalling the Plug-in
Uninstall instructions for the plug-in differ, depending on whether you installed it manually
or through Citrix Receiver. If you installed the plug-in manually, you can uninstall it using
this procedure. If you installed the plug-in through Citrix Receiver, refer to the Receiver for
Macintosh documentation for complete uninstall instructions.

To uninstall the plug-in
1. Open the Uninstall Citrix online plug-in application located in /Library/Application
Support/Citrix/.
2. Click Continue.
3. Enter the administrator account details for the device from which you are uninstalling
the plug-in and click OK.
4. Click Finish.
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Using Dazzle
Dazzle provides users with self-service access to the applications and desktops they need to
work productively. Icons for those applications and desktops can be presented on the local
desktop, on the Dock, or in the Dazzle folder available from the Finder.
The new, easy-to-use interface allows users to subscribe to applications and desktops
hosted on XenApp and XenDesktop servers with a single click, replacing the need for
individual connection files used by earlier versions of the plug-in.
For more information about connection files, see Custom Connection Files and the ICA
Client Editor.

Opening Dazzle
The way you open Dazzle depends on whether you installed the plug-in manually or through
Citrix Receiver, as follows:
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•

If you installed the plug-in manually, open Dazzle from the Citrix folder in the
Applications folder.

•

If you installed the plug-in through Citrix Receiver, choose Dazzle... from the Citrix
Receiver menu.

Choosing Your Applications and Desktops
At the end of the plug-in install you are prompted to launch Dazzle. After launching Dazzle,
you can select the applications and desktops you want to subscribe to and begin working
with those applications and desktops immediately.
You can also launch Dazzle separately, when you want to subscribe to other applications or
desktops; for example, when new applications or desktops are added to those already
hosted by a store or when a new store is added to the list.

To subscribe to applications or desktops when
installation completes
1. Select the checkbox labeled Open Dazzle now when prompted at the end of the plug-in
installation process, and then click Continue.
2. Do one of the following:
•

If a No Stores Configured message appears, click OK to open Preferences and then
select the Dazzle Stores pane. Click the Plus button. Enter the name and address
for the store to which you want to connect and click OK. Close Preferences and go
to Step 4.

If stores have already been configured, select the store hosting your applications
and desktops from the list of available stores.
3. If requested, enter the user name and password for the store hosting your applications
or desktops and click OK.
•

Note: If you want to add these details to your keychain, select Remember this
password in my keychain.
4. Select the applications and desktops you want to subscribe to and click Add. This adds
the applications and desktops to your Dazzle folder. Alternatively, you can drag the
applications or desktops to your local desktop or any folder of your choice. If you do not
see the application or desktop you require, you can search for it by selecting All
Applications and typing the name in the search field.
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Choosing Your Applications and Desktops

To subscribe to additional applications and desktops
1. Open Dazzle.
2. Select the store hosting your applications and desktops from the list of available stores.
3. If requested, enter the user name and password for the store hosting your applications
or desktops and click OK.
Note: If you want to add these details to your keychain, select Remember this
password in my keychain.
4. Select the applications and desktops you want to subscribe to and click Add. This adds
the applications and desktops to your Dazzle folder. Alternatively, you can drag the
applications or desktops to your local desktop or any folder of your choice. If you do not
see the application or desktop you require, you can search for it by selecting All
Applications and typing the name in the search field.
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Adding an Alias for an Application or
Desktop to the Dock
You can add an alias for a hosted application or virtual desktop to the Dock, quickly and
easily, by dragging the application or desktop icon from the folder view in Dazzle directly to
the Dock. Alternatively, you add an alias to the Dock in the same way as you can for any
local application, using the procedure below.

To add an alias for an application or desktop to the
Dock
1. In the Finder, open the folder containing the application or desktop you want to add to
the dock.
2. Drag the application or desktop icon to the Dock.
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Launching Applications and Desktops
Users launch hosted applications and virtual desktops in exactly the same way as local
applications. If a user does not add their account information for the Citrix server to the
keychain, they are asked to enter that information before the application or desktop
launches.
Users can search for applications and desktops to which they have subscribed using
Spotlight and can also rename them to more easily distinguish between local and hosted
versions.
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Removing Applications and Desktops
You can remove applications and desktops you no longer need access to by dragging them
to the Trash. Alternatively, you can use Dazzle to remove applications and desktops located
in both the Dazzle folder and any sub-folders you have created.
If you require access to an application or desktop after removing it, use Dazzle to subscribe
to that application or desktop again.

To remove applications and desktops using Dazzle
1. Open Dazzle.
2. Select the folder containing the applications and desktops you want to remove.
3. Click Remove to remove each application or desktop you no longer require access to.
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Working with Dazzle Stores
If you installed the plug-in manually, you need to add stores to the Dazzle stores list when
you start Dazzle for the first time.
If you installed the plug-in through Receiver, you are presented with a list of available
stores (XenApp or XenDesktop servers) from which you can choose your applications and
desktops when you start Dazzle for the first time. This list of stores is pre-configured using
Merchandising Server.
From time to time, you may also need to add new stores to or remove old stores from this
list. For example, if your applications and desktops are migrated from one server to
another, you can add the new server hosting those resources to the list and remove the
existing server to which you no longer require access. You may also need to edit the details
of a store you have set up; for example, if the URL for a store changes or you want to
change a store's name. You can add, remove, and edit stores by selecting Preferences...
from the list of available stores in Dazzle.
Note: You can edit the details of and remove from the list only those stores that you
added manually. Stores delivered through Merchandising Server, and denoted by a
padlock next to their entry in the Stores list, can not be removed.

To add a new store to the stores list
1. Select Preferences... from the list of available stores and then select the Dazzle
Stores pane.
2. Click the Plus sign.
3. Enter a name for the new store in the Store Name field.
4. Enter the address of the new store (server) to which you want to connect in the Store
URL field and click OK.

To connect to a new store
1. Open Dazzle.
2. Choose the new store to which you want to connect from the list of available stores.
3. If requested, enter the user name and password for the new store and click OK.
Note: If you want to add these details to your keychain, select Remember this
password in my keychain.
After you connect to the new store, you can subscribe to applications and desktops
hosted by that store in the usual way.
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Working with Dazzle Stores

To remove a store from the stores list
1. Select Preferences... from the list of available stores and then select the Dazzle
Stores pane.
2. Select the store you want to remove from the Stores list.
3. Click the Minus sign, then click OK to confirm you want to remove the store from the
list.

To edit the details of a store
1. Select Preferences... from the list of available stores and then select the Dazzle
Stores pane.
2. Double-click the store you want to edit.
3. Edit the details in Store Name and/or Store URL fields, as required.
4. Click OK.
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Configuring the Plug-in for Macintosh
After the plug-in software is installed, you can configure various plug-in settings.
The way you configure these settings depends on whether you installed the plug-in
manually or through Citrix Receiver. Although the settings themselves are identical in each
case, the way you access them differs.

Configuring a Plug-in You Installed Manually
If you installed the plug-in manually, choose Apple menu > System Preferences and click
Citrix online plug-in to display plug-in preferences. All user configurable settings are
contained within three tabs; Appearance, Keyboard, and Devices.

Configuring a Plug-in Installed through Citrix Receiver
If you installed the plug-in through Citrix Receiver, choose Apple menu > System
Preferences and click Citrix Receiver to display Receiver preferences. All user
configurable settings are accessed from the Application Delivery pane. Choose from
Appearance, Keyboard, or Devices depending on the settings you want to configure.
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Configuring Window Properties
You can configure the plug-in to display virtual desktops in either fixed size windows or as
full screen. Hosted applications are automatically displayed in seamless mode, in fully
resizable windows.

To configure window properties
1. Click Appearance.
2. Select whether you want to display virtual desktops in Windowed or Full Screen mode.
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Showing and Hiding the Menu Bar and
Dock
When viewing virtual desktops in full screen mode, the Macintosh menu bar and Dock might
be hidden.
To display the Macintosh menu bar, press Control-Option. The same key combination also
hides it again.
Note: If you are not in full screen mode, and your window size enables you to see the
entire desktop, you can use Control-Option to show a standard Macintosh resize control in
the bottom right corner of the ICA session window. The same key combination hides the
resize box again.
If the window size is too small to show the entire desktop, you must use the scroll bars to
see the hidden content of the desktop.
To display both the complete window and the Macintosh menu bar when connected to a
session, from the Citrix online plug-in menu, choose View > Best Window Position.
You can also configure the plug-in to show the menu bar and Dock automatically, whenever
you move your mouse to the top of the screen or to the edge where the Dock is located. If
you select this option, the Dock is hidden when you are not using it.

To show and hide the menu bar and Dock
automatically
1. Click Appearance.
2. Select Show the Dock and menu bar. Alternatively you can use the standard Macintosh
method from the Apple menu by choosing Dock > Dock Preferences > Automatically
hide and show the Dock.
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Mapping Client Devices
You can map local drives and devices so that they are available from within a session. If
enabled on the server, client device mapping allows a remote application or desktop
running on the server to access devices attached to the local client device. You can:
•

Access local drives, COM ports, and printers

•

Hear audio (system sounds and audio files) played from the session

Note that client audio mapping and client printer mapping do not require any configuration
on the client device.

Mapping Client Drives
Client drive mapping allows you to access the local disk drives of the client device,
including CD-ROM drives, during sessions. When a server is configured to allow client drive
mapping, users can access their locally stored files, work with them during their sessions,
and then save them either on a local drive or on a drive on the server.
In addition, you can configure servers to map their server drives. When server drives are
mapped and the drive letters clash with those selected for the user’s local drives, the
server automatically changes the client drive letters.
Because Windows operating systems recognize file paths with drive letters but not
Macintosh paths, the plug-in needs to map local Macintosh folders to drive letters for
published applications and remote desktop sessions to locate local files.
For example, to use the files in the Macintosh HD/MacClientDocs/Docs/MacPDF folder, you
can map Macintosh HD/MacClientDocs/Docs to drive M and within a session access the files
using the path M:\MacPDF.
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Mapping Client Devices

To map client drives
1. Click Devices. The Mapped Drives pane lists the disk or path name of every Macintosh
folder already mapped to each drive on the server. The Read and Write columns show
whether or not you have read and write access. Drives A, B, and C are mapped
automatically as follows:
Drive

Mapped to

A

A Macintosh removable media drive (floppy disk, USB flash drive, or any
other item that is removable and can be written to).

B

The Macintosh internal CD or DVD drive, or any other item that is
removable and non-writable, such as a disk image .dmg file.

C

Permanently mapped to the user’s Home folder on the Macintosh hard
disk.
2. Click the Plus button.
3. Select an available drive letter.
4. Click Browse.
5. Select the folder on the Macintosh hard drive that you want to map and click Browse.
6. Click Create. The Mapped Drives pane now displays the mapped folder.
7. Select the level of read and write access for the mapped drive from the Read and Write
pop-up menus.
8. Log out of any open sessions and reconnect to apply the changes.

Mapping Client COM Ports
Client COM port mapping allows devices attached to the COM ports of the client device to
be used during sessions on a server. These mappings can be used like any other network
mappings.
Macintosh serial ports do not provide all the control signal lines that are used by Windows
applications. The DSR (Data Set Ready), DCD (Device Carrier Detect), RI (Ring Indicator),
and RTS (Request To Send) lines are not provided. Windows applications that rely on these
signals for hardware handshaking and flow control may not work. The Macintosh
implementation of serial communications relies on CTS (Clear To Send) and DTR (Data
Terminal Ready) lines for input and output hardware handshaking only.
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Mapping Client Devices

To map client COM ports
1. Click Devices.
2. Select the COM port you want to map, from the Mapped COM Ports list. This is the
virtual COM port that is displayed in the session, not the physical port on the local
machine.
3. Select the device to associate with the virtual COM port from the Device pop-up menu.
4. Start the plug-in and log on to a server.
5. Run a command prompt.
6. At the prompt, type net use comx: \\client\comz: where x is the number of the
COM port on the server (ports 1 through 9 are available for mapping) and z is the
number of the client COM port (ports 1 through 4 are available).
7. To confirm the mapping, type net use at the prompt. A list displays mapped drives,
LPT ports, and mapped COM ports.
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Printing
You can access printers connected to client devices during a session. When a server is
configured to allow client printer mapping, applications running remotely on the server can
print to any printer that can be used from locally running applications.
No special configuration is needed to set up local printers to print during an ICA session.
Note, however, that A4 pages might not print correctly if you choose the A4 paper size
option in the Page Setup dialog box (or the Page Layout tab in the case of Microsoft Office
2007 applications). In order to print on A4 paper, the user must either specify it as a
default size and use the A4 paper size option, or choose the A4 210×297 option if available.
To set A4 as the default, from the plug-in File menu choose Default Paper Size > A4. All
other paper sizes will print correctly if the printer supports that paper size.
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Optimizing the Plug-in Environment
By optimizing your environment you gain the best performance from the plug-in and provide
the best user experience.
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Improving Performance
You can improve the performance of the plug-in software by enabling auto-client
reconnections, session reliability, and SpeedScreen Latency Reduction.

Reconnecting Users Automatically
Users can be disconnected from their sessions because of unreliable networks, highly
variable network latency, or range limitations of wireless devices. With the HDX Broadcast
auto-client reconnection feature, the plug-in can detect unintended disconnections of ICA
sessions and reconnect users to the affected sessions automatically.
When this feature is enabled on the server, users do not have to reconnect manually to
continue working. The plug-in attempts to reconnect to the session until there is a
successful reconnection or the user cancels the reconnection attempts. If user
authentication is required, a dialog box requesting credentials appears to a user during
automatic reconnection. Automatic reconnection does not occur if users exit applications
without logging off. Users can reconnect only to disconnected sessions.

Providing HDX Broadcast Session Reliability
With the HDX Broadcast Session Reliability feature, users continue to see a published
application’s window if the connection to the application experiences an interruption. For
example, wireless users entering a tunnel may lose their connection when they enter the
tunnel and regain it when they emerge on the other side. During such interruptions, the
session reliability feature enables the session window to remain displayed while the
connection is being restored.
You can configure your system to display a warning dialog box to users when the connection
is unavailable.
HDX Broadcast Session Reliability is enabled on the server by default. Users of the plug-in
cannot override the server settings for HDX Broadcast Session Reliability.
Important: If HDX Broadcast Session Reliability is enabled, the default port used for
session communication switches from 1494 to 2598.

Reducing Display Latency
Over high latency connections, you might experience significant delays between the time
when you type text at the keyboard and when it is displayed on the screen. Similarly, there
may be a delay between clicking a mouse button and the screen displaying any visible
feedback. This can result in you retyping text or making several unnecessary mouse clicks.
When enabled on the server, SpeedScreen Latency Reduction lessens the impact of high
latency connections on your display.
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Improving Performance
SpeedScreen Latency reduction is not supported when connecting to Citrix XenApp for UNIX.
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Changing the Way You Use the Plug-in
ICA technology is highly optimized and typically does not have high CPU and bandwidth
requirements. However, if you are using a very low-bandwidth connection, the following
tasks can impact performance:
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•

Accessing large files using client drive mapping. When you access a large file with
client drive mapping, the file is transferred over the ICA connection. On slow
connections, this may take a long time.

•

Printing large documents on local client printers. When you print a document on a
local client printer, the print file is transferred over the ICA connection. On slow
connections, this may take a long time.

•

Playing multimedia content. Playing multimedia content uses a lot of bandwidth and
can cause reduced performance.

Improving the User Experience
The plug-in provides a number of features for improving the user experience, including
improved support for ClearType font smoothing and substituting Windows special keys with
familiar Mac key combinations within a session.
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ClearType Font Smoothing in ICA
Sessions
Citrix XenApp supports ClearType font smoothing with Citrix online plug-in.
If you enable ClearType font smoothing on the XenApp server, you are not forcing client
devices to use ClearType font smoothing. You are enabling the server to support ClearType
font smoothing on client devices that have it enabled locally and are using the plug-in.
The plug-in automatically detects the client device's font smoothing setting and sends it to
the server. The session connects using this setting. When the session is disconnected or
terminated, the server's setting reverts to its original setting.
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Making Keystrokes with Macintosh
Keyboards
Remote sessions recognize most Macintosh keyboard combinations for text input, such as
Option-G to input the copyright symbol ©. However some keystrokes you make during a
session do not appear on the remote application or desktop, and instead are interpreted by
the Macintosh operating system. This can result in keys triggering Macintosh responses
instead. For example, F9 can be configured to run the All Windows feature of Exposé.
You might also face the problem of wanting to use certain PC keys, such as INSERT, that
many Macintosh keyboards do not have.
Keyboards and the ways keys are configured can differ widely between machines. The
plug-in therefore offers several choices to ensure that keystrokes can be correctly sent to
desktops and applications running within a session. These are listed in the table.
Conventions used in the table:
•

Letter keys are capitalized and do not imply that the Shift key should be pressed
simultaneously.

•

Hyphens between keystrokes indicate that keys should be pressed together (for
example, Control-C).

•

Character keys are those that create text input and include all letters, numbers, and
punctuation marks; special keys are those that do not create input by themselves but
act as modifiers or controllers. Special keys include Control, Alt, Shift, Command,
Option, arrow keys, and function keys.

•

Menu instructions relate to the menus in the session.

•

Depending on the configuration of the client device, some key combinations might not
work as expected, and alternative combinations are listed.

•

Fn refers to the Fn (Function) key on a Macintosh keyboard; function key refers to F1 to
F12 on either a PC or Macintosh keyboard.

PC key

Macintosh options

ALT+character key

Command–Option–character key (e.g. to send ALT-C, use
Command-Option-C)

ALT+special key

Option–special key (e.g. Option-Tab)
Command–Option–special key (e.g. Command-Option-Tab)

CTRL+character key

Command–character key (e.g. Command-C)
Control–character key (e.g. Control-C)
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Making Keystrokes with Macintosh Keyboards
CTRL+special key

Control–special key (e.g. Control-F4)
Command–Control–special key (e.g. Command-Control-F4

CTRL/ALT/SHIFT
combination + function key

Choose Keyboard > Send Key > Control/Alt/Shift-function
key

CTRL+ALT

Control-Command

CTRL+ALT+DEL

CTRL+ALT+DEL Control–Option–Forward Delete
Control-Option-Fn-Delete (on MacBook keyboards)

DELETE

Delete
Choose Keyboard > Send Key > Delete
Fn-Backspace (Fn-Delete on some US keyboards)

END

End
Fn-Right Arrow

ESC

Escape
Choose Keyboard > Send Key > Escape

F1 to F9

F1 to F9
Choose Keyboard > Send Function Key > F1 to F9

F10

F10
Choose Keyboard > Send Function Key > F10

F11

F11
Choose Keyboard > Send Function Key > F11

F12

F12
Choose Keyboard > Send Function Key > F12

HOME

Home
Fn–Left Arrow

INSERT

Command-Help
Choose Keyboard > Send Key > Insert

NUM LOCK

Clear
Fn-6

PAGE DOWN

Page Down
Fn–Down Arrow

PAGE UP

Page Up
Fn–Up Arrow
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Making Keystrokes with Macintosh Keyboards
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SPACEBAR

Choose Keyboard > Send Key > Space

TAB

Choose Keyboard > Send Key > Tab

Substituting Windows Special Keys
The plug-in provides a number of extra options and easier ways to substitute special keys
such as function keys in Windows applications with Mac keys. Use the Keyboard tab to
configure the options you want to use, as follows:
•

Send Control character using enables you to choose whether or not to send
Command-character key combinations as Ctrl+character key combinations within a
session. If you select Command or Control from the pop-up menu, you can use familiar
Command-character key combinations as Ctrl+character key combinations. If you select
Control, you must use Ctrl+character key combinations.

•

Send Alt character using enables you to choose how to replicate the Alt key within a
session. If you select Command-Option, you can send Command-Option- key
combinations as Alt+ key combinations within a session. Alternatively, if you select
Command, you can use the Command key as the Alt key.

•

Send special keys unchanged enables you to send keys that are normally used by the
Mac OS to a session. You may, however, need to use the Command key as part of the
key combination. For example, if F9 is assigned to Expose you send the F9 key to a
session by pressing Command+F9.

You send function and other special keys to a session using the Keyboard menu. You can
also use the following keystrokes:
PC Key or action

Macintosh options

INSERT

0 (zero) on the numeric keypad; Num Lock must be off
Option-Help

DELETE

Decimal point on the numeric keypad; Num Lock must be
off
Clear
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F1 to F9

Option 1 to 9 on numeric keypad

F10

Option 0 (zero) on numeric keypad

F11

Option minus sign on numeric keypad

F12

Option plus sign on numeric keypad

Using a Mouse
Citrix recommends using a two button mouse and configuring the right mouse button to be
the secondary button. You can also emulate a PC mouse right-click using Option and click.

44

Securing Plug-in Communication
This section describes measures you can take to secure the communication between your
server farm and the plug-ins. You can integrate your plug-in connections to the server farm
with a range of security technologies, including:
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•

A SOCKS proxy server or secure proxy server (also known as security proxy server,
HTTPS proxy server, or SSL tunneling proxy server)

•

Secure Gateway for Citrix XenApp or SSL Relay solutions with Secure Sockets Layer (SSL)
and Transport Layer Security (TLS) protocols

•

A firewall

Connecting Through a Proxy Server
Proxy servers are used to limit access to and from your network, and to handle connections
between plug-ins and servers. The plug-in support SOCKS and secure proxy protocols.
When communicating with the server farm, the plug-in uses proxy server settings that are
configured remotely on the server running the Web Interface. For information about
configuring proxy server settings for the plug-ins, see Citrix eDocs.
In communicating with the Web server, the plug-in uses the proxy server settings that are
configured for the default Web browser on the client device. You must configure the proxy
server settings for the default Web browser on the client device accordingly.

46

Connecting with the Secure Gateway or
Citrix Secure Sockets Layer Relay
You can integrate the plug-ins with the Secure Gateway or Secure Sockets Layer (SSL) Relay
service. The plugins support both SSL and TLS protocols.
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•

SSL provides strong encryption to increase the privacy of your ICA connections and
certificate-based server authentication to ensure the server you are connecting to is a
genuine server.

•

TLS (Transport Layer Security) is the latest, standardized version of the SSL protocol.
The Internet Engineering Taskforce (IETF) renamed it TLS when it took over
responsibility for the development of SSL as an open standard. TLS secures data
communications by providing server authentication, encryption of the data stream, and
message integrity checks. Because there are only minor technical differences between
SSL Version 3.0 and TLS Version 1.0, the certificates you use for SSL in your software
installation will also work with TLS. Some organizations, including U.S. government
organizations, require the use of TLS to secure data communications. These
organizations may also require the use of validated cryptography, such as FIPS 140
(Federal Information Processing Standard). FIPS 140 is a standard for cryptography.

Connecting with the Secure Gateway
You can use the Secure Gateway in either Normal mode or Relay mode to provide a secure
channel for communication between the plug-in and the server. No plug-in configuration is
required if you are using the Secure Gateway in Normal mode and users are connecting
through the Web Interface.
If the Secure Gateway Proxy is installed on a server in the secure network, you can use the
Secure Gateway Proxy in Relay mode. For more information about Relay mode, see Citrix
eDocs.
If you are using Relay mode, the Secure Gateway server functions as a proxy and you must
configure the plug-in to use:
•

The fully qualified domain name (FQDN) of the Secure Gateway server.

•

The port number of the Secure Gateway server. Note that Relay mode is not supported
by Secure Gateway Version 2.0.

The FQDN must list, in sequence, the following three components:
•

Host name

•

Intermediate domain

•

Top-level domain

For example, my_computer.my_company.com is a FQDN, because it lists, in sequence, a
host name (my_computer), an intermediate domain (my_company), and a top-level domain
(com). The combination of intermediate and top-level domain (my_company.com) is
generally referred to as the domain name.

Configuring the Plug-in for Secure Gateway
The plug-in uses settings that are configured remotely on the server running the Web
Interface to connect to servers running the Secure Gateway.
In communicating with the Web server, the plug-in uses the proxy server settings that are
configured for the default Web browser on the client device. You must configure the proxy
server settings for the default Web browser on the client device accordingly.
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Connecting with Citrix SSL Relay
By default, Citrix SSL Relay uses TCP port 443 on the Citrix server for SSL/TLS-secured
communication. When the SSL Relay receives an SSL/TLS connection, it decrypts the data
before redirecting it to the server, or, if the user selects SSL/TLS+HTTPS browsing, to the
Citrix XML Service.
You can use Citrix SSL Relay to secure communications:
•

Between an SSL/TLS-enabled client and a server.

•

With a server running the Web Interface, between the XenApp server and the Web
server.

For information about configuring and using SSL Relay to secure your installation or
configuring the server running the Web Interface to use SSL/TLS encryption, see Citrix
eDocs .

Configuring and Enabling the Plug-in for SSL and TLS
SSL and TLS are configured in the same way, use the same certificates, and are enabled
simultaneously.
When SSL and TLS are enabled, each time you initiate a connection the plug-in tries to use
TLS first, then tries SSL. If it cannot connect with SSL, the connection fails and an error
message appears.
There are two main steps involved in setting up SSL/TLS:
1. Set up SSL Relay on the XenApp server and server running the Web Interface and obtain
and install the necessary server certificate. For more information, see Citrix eDocs.
2. Install the equivalent root certificate on the client device.

Installing Root Certificates on Client Devices
To use SSL/TLS to secure communications between SSL/TLS-enabled plug-ins and the server
farm, you need a root certificate on the client device that can verify the signature of the
Certificate Authority on the server certificate.
Mac OS X comes with about 100 commercial root certificates already installed, but if you
want to use another certificate, you can obtain one from the Certificate Authority and
install it on each client device.
Depending on your organization’s policies and procedures, you may want to install the root
certificate on each client device instead of directing users to install it. The easiest and
safest way is to add root certificates to the Mac OS X keychain.
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Connecting with Citrix SSL Relay

To add a root certificate to the keychain
1. Double-click the file containing the certificate. This automatically starts the Keychain
Access application.
2. In the Add Certificates dialog box, choose one of the following from the Keychain
pop-up menu:
•

X509Anchors (if using Mac OS 10.4 Tiger)

System (if using Mac OS 10.5 Leopard)
3. Click OK.
•

4. Type your password in the Authenticate dialog box and click OK. The root certificate is
installed and can be used by SSL-enabled clients and by any other application using SSL.
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Connecting Through a Firewall
Network firewalls can allow or block packets based on the destination address and port. If
you are using a firewall in your deployment, the plug-in must be able to communicate
through the firewall with both the Web server and Citrix server. The firewall must permit
HTTP traffic (often over the standard HTTP port 80 or 443 if a secure Web server is in use)
for client device to Web server communication. For plug-in to Citrix server communication,
the firewall must permit inbound ICA traffic on ports 1494 and 2598.
If the firewall is configured for Network Address Translation (NAT), you can use the Web
Interface to define mappings from internal addresses to external addresses and ports. For
example, if your XenApp server is not configured with an alternate address, you can
configure the Web Interface to provide an alternate address to the plug-in. The plug-in
connects to the server using the external address and port number. For more information,
see Citrix eDocs.
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