Routing in einem Cluster

Das Routing in einem Cluster funktioniert genauso wie das Routing in einem eigenständigen System. Ein paar Punkte zu beachten:

  • Alle Routingkonfigurationen müssen über die Cluster-IP-Adresse ausgeführt werden, und die Konfigurationen werden an die anderen Clusterknoten weitergegeben.

  • Routen sind auf die maximale Anzahl von ECMP-Routen begrenzt, die vom Upstream-Router unterstützt werden.

  • Knotenspezifische Routing-Konfigurationen müssen mithilfe des Owner-Node-Arguments wie folgt durchgeführt werden:

  router ospf
    owner-node 0
      ospf router-id 97.131.0.1
    exit-owner-node
  !

Der folgende Befehl zeigt die konsolidierte Clusterkonfiguration für alle Knoten in VTYSH an.

show cluster-config

Der folgende Befehl zeigt den Clusterstatus auf jedem Knoten an.

show cluser node

IPv4-Routing im L2-Cluster

Der folgende Abschnitt enthält Beispielkonfigurationen, mit denen Sie IPv4-OSPF- und BGP-Routing im L2-Cluster konfigurieren können.

Hinzufügen von Spotted-SNIP-Adresse und Aktivieren von dynamischem Routing

In der folgenden Konfiguration sind OSPF und BGP-Routing aktiviert. Außerdem werden gespotte SNIP-Adressen hinzugefügt und dynamisches Routing für diese SNIP-Adressen aktiviert.

en ns fea ospf bgp
add vlan 10
add ns ip 10.10.10.1 255.255.255.0 -dynamicrouting enabled -ownernode 1
add ns ip 10.10.10.2 255.255.255.0 -dynamicrouting enabled -ownernode 2
add ns ip 10.10.10.3 255.255.255.0 -dynamicrouting enabled -ownernode 3
bind vlan 10 -ipaddress 10.10.10.1 255.255.255.0

VTYSH IPv4 OSPF-Konfiguration

Zum Konfigurieren von IPv4 OSPF im L2-Cluster müssen Sie

  • Legen Sie die Priorität auf Null fest.
  • Konfigurieren Sie die Router-ID als Spotted Konfiguration.

Hinweis:

Die OSPF-Konfigurationsrichtlinien für L2-Cluster gelten auch für OSPFv3.

In der folgenden Beispielkonfiguration wird IPv4 OSPF konfiguriert.

      interface vlan10
       IP OSPF PRIORITY 0
       !
      router ospf
          owner-node 1
            ospf router-id 97.131.0.1
          exit-owner-node
          owner-node 2
            ospf router-id 97.131.0.2
          exit-owner-node
          owner-node 3
            ospf router-id 97.131.0.3
          exit-owner-node
      network 10.10.10.0/24 area 0
      redistribute kernel
       !

VTYSH IPv4 BGP-Konfiguration

In der folgenden VTYSH Beispielkonfiguration ist IPv4 BGP konfiguriert.

    router bgp 100
      neighbor 10.10.10.10 remote-as 200
     owner-node 1
      neighbor 10.10.10.10 update-source 10.10.10.1
     exit-owner-node
     owner-node 2
      neighbor 10.10.10.10 update-source 10.10.10.2
     exit-owner-node
     owner-node 3
      neighbor 10.10.10.10 update-source 10.10.10.3
     exit-owner-node
    redistribute kernel
    !

Hinweis:

Der update-source Befehl wird für jeden Nachbarn mit Owner-Node-Argument in der folgenden Konfiguration verwendet, um eine Verbindung mit der richtigen Quell-IP herzustellen.

IPv6-Routing im L2-Cluster

Der folgende Abschnitt enthält Beispielkonfigurationen, mit denen Sie IPv6-OSPF- und BGP-Routing im L2-Cluster konfigurieren können.

IPv6-Routing aktivieren

Bevor Sie IPv6-Routing in einem L2-Cluster konfigurieren, müssen Sie das IPv6-Feature aktivieren.

So aktivieren Sie IPv6-Routing mit der CLI,

Geben Sie an der Eingabeaufforderung Folgendes ein:

  • enable ns fea ipv6pt

Hinzufügen von gespotted SNIP6-Adresse und Aktivieren von dynamischem Routing

In der folgenden Konfiguration sind OSPF und BGP-Routing aktiviert. Außerdem werden gespotte SNIP6-Adressen hinzugefügt und dynamisches Routing für diese SNIP6-Adressen aktiviert.

add ns ip6 3ffa::1/64 -dynamicrouting enabled -ownernode 1
add ns ip6 3ffa::2/64 -dynamicrouting enabled -ownernode 2
add ns ip6 3ffa::3/64 -dynamicrouting enabled -ownernode 3
add vlan 10
bind vlan 10 -ipaddress 3ffa::1/64

VTYSH IPv6 BGP-Konfiguration

In der folgenden VTYSH Beispielkonfiguration ist IPv6 BGP konfiguriert.

  router bgp 100
   neighbor 3ffa::10 remote-as 200
     owner-node 1
      neighbor 3ffa::10 update-source 3ffa::1
     exit-owner-node
     owner-node-2
      neighbor 3ffa::10 update-source 3ffa::2
     exit-owner-node
     owner-node-3
      neighbor 3ffa::10 update-source 3ffa::3
     exit-owner-node
   no neighbor 3ffa::10 activate
   address-family ipv6
    redistribute kernel
    neighbor 3ffa::10 activate
   exit-address-family
  !

Installieren von IPv6-erlernten Routen

Der Citrix ADC Cluster kann Routen verwenden, die von verschiedenen Routingprotokollen gelernt wurden, nachdem Sie die Routen in der Citrix ADC Cluster-Routingtabelle installiert haben.

So installieren Sie IPv6-gelernte Routen in die interne Routingtabelle mit der CLI:

Geben Sie an der Eingabeaufforderung Folgendes ein:

  • ns route-install ipv6 bgp

  • ns route-install ipv6 ospf

  • ns route-install default

Hinweis:

  • Wenn Sie IPv4-Routen auf einem IPv6-Nachbarn austauschen müssen, müssen Sie den Befehlno neighbor 3ffa::10 active VTYSH aus der früheren Konfiguration entfernen.

  • Derupdate-source VTYSH Befehl muss für jeden Besitzerknoten verwendet werden, um die richtige IPv6-Quell-IP anzugeben, während der Verbindung mit BGP-Peer wie in der BPG IPv4-Konfiguration angegeben wird.

Routing in einem L3-Cluster

Das Routing im L3-Cluster funktioniert nur, wenn die folgenden Konfigurationen auf der Citrix ADC Appliance durchgeführt werden.

  • Aktivieren Sie das dynamische Routing für ein VLAN.

     set vlan <id> -dynamicrouting enabled
    
  • Um alle Clusterknoten zu erreichen, müssen die VIP-, CLIP- und Citrix ADC IP (NSIP) durch Routingprotokolle zusammen mit demset vlan Befehl angekündigt werden.

Bereitstellungsszenario für BGP im L3-Cluster

Betrachten Sie ein Beispiel, bei dem alle Clusterknoten im AS 100-Netzwerk gruppiert sind und die Upstream-Router sich in unterschiedlichen AS 200 befinden.

Die folgende Abbildung zeigt die AS 100- und AS 200-Bereitstellung in einem Cluster-Setup.

lokalisiertes Bild

In dieser Bereitstellung wirbt CLIP CCO für Upstream-Router an. Einige Clusterknoten löschen den angekündigten Datenverkehr, da AS-Schleife erkannt wird.

Um das Problem zu beheben, konfigurieren Sie den folgenden Befehl im vtysh BGP-Router-Modus für jeden Nachbarn.

Geben Sie an der VTYSH Eingabeaufforderung Folgendes ein:

neighbor <peer_ip> allowas-in 1

Als bewährte Methode empfiehlt Citrix, eine der folgenden Optionen zu konfigurieren:

  • Konfigurieren Sie Routenkarten, um nur die gewünschten Netzwerke wie Standardroute, Citrix ADC IP (NSIP) und NSIP-Subnetze auf Clusterknoten zu lernen.

  • Konfigurieren Sie Upstream-Routen, um nur gewünschte Netzwerke wie CLIP und Citrix ADC IP (NSIP) im Cluster anzukündigen.