Citrix ADC

Konfiguration des Clusters ECMP mit Cisco Nexus 7000 Switch mit Routing-Protokoll

Mit ECMP über ein Cluster-Setup kann eine Citrix ADC Appliance den Datenverkehr über ein Routingprotokoll verarbeiten. Der ECMP-Mechanismus hilft bei der Werbung für die IP-Adressen des virtuellen Servers über alle aktiven Clusterknoten.

Um ECMP verwenden zu können, müssen Sie zuerst das BGP-Protokoll auf der Cluster-IP-Adresse aktivieren. Binden Sie die Schnittstellen und die gespotted IP-Adresse (mit aktiviertem dynamischem Routing) an ein VLAN. Konfigurieren Sie das ausgewählte Routingprotokoll und verteilen Sie die Kernelrouten auf den ZebOS mit der vtysh-Shell.

Anwendungsfall: Cluster ECMP mit Cisco Nexus 7000 Switch mit Routing-Protokoll

Betrachten Sie ein Beispiel für eine Clusterbereitstellung mit Cisco Nexus 7000 Switch:

  • Zwei Citrix ADC Appliances (Knoten 1 und Knoten 2), die mit dem Nexus-Switch verbunden sind (Upstream).
  • Zwei Cisco Nexus 7000 Switch.
  • Client und Server (Zeichnen des HTTP-Datenverkehrs über den Nexus-Switch). Mit aktiviertem Hot Standby Router Protocol (HSRP) auf der Client-Seite.

Citrix Cisco Nexus 7000

Voraussetzungen

Berücksichtigen Sie die folgenden Punkte, bevor Sie Clusterknoten auf einer Citrix ADC Appliance konfigurieren.

  1. Alle Appliances müssen vom gleichen Plattformtyp sein.
  2. Border Gateway Protocol (BGP) muss auf den Clusterknoten aktiviert sein.

Konfigurieren über die Befehlszeile auf der Citrix ADC Appliance

  1. Melden Sie sich an einer Appliance an (z. B. Appliance mit NSIP-Adresse 1.1.1.1)

  2. So fügen Sie einen Clusterknoten hinzu.

    add cluster node 0 1.1.1.2 –state ACTIVE –backplane 0/10/8
    
  3. So fügen Sie die Cluster-IP-Adresse hinzu

    add ns ip 1.1.1.10 255.255.255.254 –type clip
    
  4. Speichern der Konfiguration

    save ns config
    
  5. Warmer Neustart der Appliance

    reboot -warm
    
  6. So fügen Sie Knoten 1 mit CLIP hinzu

    add cluster node 1 2.2.2.2 –state ACTIVE –backplane 1/10/8
    
  7. So verbinden Sie einen Knoten mit dem Cluster

    join cluster –clip 1.1.1.10 –password nsroot
    
  8. Führen Sie die folgende Konfiguration auf CLIP durch

    • enable ns feature bgp ospf DYNAMICROUTING

    • add ns ip 11.1.1.3 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.7 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.5 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

    • add ns ip 11.1.1.9 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

Auf dem Cisco Nexus Router (11.1.1.2/31 und 11.1.1.4/31) müssen Sie die folgenden Konfigurationen über die Befehlszeile ausführen:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

    >  interface vlan100
        no shutdown
        ip address 50.1.1.1/8
         hsrp 50
          ip 50.50.50.50
    
    >  interface Ethernet 4/15
         ip address 11.1.1.2/31
         no shutdown
    
    >  interface Ethernet 4/19
         ip address 11.1.1.4/31
         no shutdown
    
    >  interface Ethernet 4/22
         switchport
          switchport access vlan 100
    

Auf dem Cisco Nexus Router (11.1.1.6/31 und 11.1.1.8/31) müssen Sie die folgenden Konfigurationen über die Befehlszeile ausführen:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

     >  interface vlan100
         no shutdown
         no ip redirects
         ip address 50.1.1.2/8
          hsrp 50
          ip 50.50.50.50
    
     >  interface Ethernet 4/13
         ip address 11.1.1.6/31
         no shutdown
    
     >  interface Ethernet 4/15
         ip address 11.1.1.8/31
         no shutdown
    
     >  interface Ethernet 4/22
         switchport
         switchport access vlan 100
    

Für das BGP-Protokoll müssen Sie die folgenden Konfigurationen auf CLIP der Citrix ADC Appliance ausführen:

>  vtysh
ns# router bgp 1
 redistribute kernel
 owner-node 0
 neighbor 11.1.1.2 remote-as 2
 neighbor 11.1.1.2 as-origination-interval 1
 neighbor 11.1.1.2 advertisement-interval 0
 neighbor 11.1.1.6 remote-as 2
 neighbor 11.1.1.6 as-origination-interval 1
 neighbor 11.1.1.6 advertisement-interval 0
owner-node 1
 neighbor 11.1.1.4 remote-as 2
 neighbor 11.1.1.4 as-origination-interval 1
 neighbor 11.1.1.4 advertisement-interval 0
 neighbor 11.1.1.8 remote-as 2
 neighbor 11.1.1.8 as-origination-interval 1
 neighbor 11.1.1.8 advertisement-interval 0
exit-owner-node

Führen Sie die folgenden Konfigurationen auf dem Cisco Nexus Router (11.1.1.3 und 11.1.1.5) durch.

> ip access-list acl1
  10 permit ip 50.0.0.0/8 any
  route-map test permit
  match ip address acl1
 router bgp 2
  address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
 neighbor 11.1.1.3 remote-as 1
  address-family ipv4 unicast
  neighbor 11.1.1.5 remote-as 1
 address-family ipv4 unicast

Führen Sie die folgenden Konfigurationen auf dem Cisco Nexus Router (11.1.1.7 und 11.1.1.9) durch.

> ip access-list acl1
   10 permit ip 50.0.0.0/8 any
  route-map test permit 1
   match ip address acl1
  router bgp 2
   address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
  neighbor 11.1.1.7 remote-as 1
   address-family ipv4 unicast
  neighbor 11.1.1.9 remote-as 1
   address-family ipv4 unicast

Für das OSPF-Protokoll müssen Sie die folgenden Konfigurationen auf CLIP der Citrix ADC Appliance ausführen:

> vtysh
ns# router osfp 1
redistribute kernel
owner-node 0
 network 15.1.1.2/31 area 0
 network 15.1.1.6/31 area 0
exit-owner-node

owner-node 1
 network 15.1.1.4/31 area 0
 network 15.1.1.8/31 area 0
exit-owner-node

route-map map2 permit 1
set metric 10

Auf dem Cisco Nexus Router (11.1.1.2/31 und 11.1.1.4/31) müssen Sie die folgenden Konfigurationen über die Befehlszeile ausführen:

> route-map- map2 permit 1
   set metric 10

   interface Ethernet4/15
     ip address 15.1.1.2/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   interface Ethernet4/19
     ip address 15.1.1.4/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   router ospf 1
    router-id 1.1.1.1
    redistribute direct route-map map2

Auf dem Cisco Nexus Router (11.1.1.7/31 und 11.1.1.9/31) müssen Sie die folgenden Konfigurationen über die Befehlszeile ausführen:

> route-map- map2 permit 1
    set metric 10

   interface Ethernet4/13
     ip address 15.1.1.6/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    interface Ethernet4/15
     ip address 15.1.1.8/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    router ospf 1
      router-id 1.1.1.2
      redistribute direct route-map map2

Konfiguration des Clusters ECMP mit Cisco Nexus 7000 Switch mit Routing-Protokoll