Citrix ADC

Dynamische Cluster-Link-Aggregation

Dynamischer Cluster LA-Kanal verwendet Link Aggregation Control Protocol (LACP).

Sie müssen ähnliche Konfigurationen für die Cluster-IP-Adresse und auf dem externen Verbindungsgerät durchführen. Konfigurieren Sie nach Möglichkeit den Upstream-Switch so, dass der Datenverkehr auf der Grundlage der IP-Adresse oder des Ports statt der MAC-Adresse verteilt wird.

Wichtige Punkte:

  • Aktivieren Sie LACP (indem Sie den LACP-Modus entweder als ACTIVE oder PASSIVE angeben).

    Hinweis:

    Stellen Sie sicher, dass der LACP-Modus sowohl auf dem Citrix ADC-Cluster als auch auf dem externen Verbindungsgerät nicht als PASSIVE festgelegt ist.

  • Geben Sie auf jeder Schnittstelle denselben LACP-Schlüssel an, der Teil des Kanals sein soll. Zum Erstellen eines Cluster-LA-Kanals kann der LACP-Schlüssel einen Wert von 5 bis 8 haben. Wenn Sie beispielsweise die LACP-Taste auf den Schnittstellen 0/1/2, 1/1/2 und 2/1/2 bis 5 festlegen, wird CLA/1 erstellt. Die Schnittstellen 0/1/2, 1/1/2 und 2/1/2 werden automatisch an CLA/1 gebunden. Wenn Sie den LACP-Schlüssel auf 6 setzen, wird der CLA/2-Kanal erstellt.

  • Geben Sie den LAG-Typ als Cluster an.

So konfigurieren Sie einen dynamischen Cluster-LA-Kanal mit der Befehlszeilenschnittstelle

Geben Sie auf der Cluster-IP-Adresse für jede Schnittstelle, die Sie dem LA-Kanal des Clusters hinzufügen möchten, Folgendes ein:

set interface <id> -lacpMode <lacpMode> -lacpKey <positive_integer> -lagType CLUSTER

Beispiel:

Konfigurieren eines Cluster-LA-Kanals CLA/1 mit 3 Schnittstellen.

> set interface 0/1/2 -lacpMode active -lacpKey 5 -lagType Cluster
> set interface 1/1/2 -lacpMode active -lacpKey 5 -lagType Cluster
> set interface 2/1/2 -lacpMode active -lacpKey 5 -lagType Cluster

Hinweis:

Optional können Sie diese Option aktivieren Redundanz in einem Cluster mit LACP verknüpfen.

Konfigurieren Sie dynamisches LA auf dem externen Switch. Die folgenden Beispielkonfigurationen werden für das Cisco® Nexus 7000 C7010 Release 5.2 (1) bereitgestellt. Ähnliche Konfigurationen müssen auf anderen Switches durchgeführt werden.

Globale Konfiguration:
Terminal konfigurieren
feature lacp
Konfiguration auf Schnittstellenebene:

interface Ethernet2/47
switchport
switchport access vlan 10
channel-group 7 mode active
no shutdown

interface Ethernet2/48
switchport
switchport access vlan 10
channel-group 7 mode active
no shutdown

Dynamische Cluster-Link-Aggregation