Citrix ADC

Bidirektionale Weiterleitungserkennung konfigurieren

Das bidirektionale Forwarding Detection (BFD) -Protokoll ist ein Mechanismus zur schnellen Erkennung von Ausfällen von Weiterleitungspfaden. BFD erkennt Pfadfehler in Millisekunden. BFD wird mit dynamischen Routing-Protokollen verwendet.

Im BFD-Vorgang tauschen Routing-Peers BFD-Pakete in einem ausgehandelten Intervall aus. Wenn ein Paket innerhalb des ausgehandelten Intervalls plus Gnadenintervalls nicht von einem Peer empfangen wird, gilt der Peer als tot und eine Benachrichtigung wird an die Gruppe der registrierten Routing-Protokolle gesendet. Die Routingprotokolle wiederum berechnen den besten Pfad neu und programmieren die Routingtabelle neu. BFD unterstützt im Vergleich zu den Timern, die von den Routingprotokollen bereitgestellt werden, ein geringeres Zeitintervall, was zu einer schnelleren Erkennung von Fehlern führt.

Die Citrix ADC Appliance unterstützt BFD für die folgenden Routingprotokolle: BGP (IPv4 und IPv6), OSPFv2 (IPv4) und OSPFv3 (IPv6). Die BFD-Unterstützung in der Citrix ADC Appliance ist mit RFCs 5880, 5881 und 5883 kompatibel.

Zu berücksichtigende Punkte für die Konfiguration der bidirektionalen Weiterleitungserkennung

Bevor Sie mit der Konfiguration von BFD beginnen, sollten Sie die folgenden Punkte beachten:

  • Stellen Sie sicher, dass Sie die verschiedenen Komponenten von BFD kennen, die in RFCs 5880, 5881 und 5883 beschrieben sind.
  • BFD auf einer Citrix ADC Appliance wird für die folgenden Routingprotokolle unterstützt:
    • BGP (IPv4 und IPv6)
    • OSPFv2 (IPv4)
    • OSPFv3 (IPv6)
  • BFD auf einer Citrix ADC Appliance wird für die folgenden Routingprotokolle nicht unterstützt:
    • ISIS
    • RIP (IPv4)
    • RipNG (IPv6)
  • Die folgenden BFD-Funktionen werden auf einer Citrix ADC Appliance nicht unterstützt:
    • BFD-Echo-Modus
    • BFD-Authentifizierung
    • Asynchroner BFD-Bedarfsmodus
  • Die Mindestwerte für BFD-Intervall- und BFD-Rx-Timer betragen 100 Millisekunden.
  • Wenn BFD in einer Topologie mit gemeinsam genutzten IP-Adressen verwendet wird (z. B. Layer-2-Hochverfügbarkeits-Setup mit SNIP-Adressen oder Cluster-Setup mit Striped IP-Adressen), führt BFD die aktiven Sitzungen während eines Failovers herunter, da die BFD-Fehlererkennungszeit (Reihenfolge von Millisekunden) kleiner als die HA ist. Failover-Erkennungsintervall (3—4 Sekunden). Daher empfiehlt Citrix die Verwendung von Graceful Neustart in Layer-2-HA-Topologien, da die Routen während des Failoverprozesses beibehalten werden.

Konfigurationsschritte

Die Konfiguration von BFD auf einer Citrix ADC Appliance umfasst die folgenden Aufgaben:

  • Konfigurieren von BFD-Parametern
  • Konfigurieren der BFD-Unterstützung für dynamische Routing-Protokolle

Konfigurieren von BFD-Parametern

Die Citrix ADC Appliance bietet separate BFD-Sitzungsparameter für Einzelhop-Sitzungen, IPv4-Mehrfachhop-Sitzungen und IPv6-Mehrfachhop-Sitzungen. Wenn Sie keine BFD-Parameter für einen Sitzungstyp konfigurieren, werden die Standardwerte für diese Sitzung angewendet.

Der Standardwert jedes BFD-Parameters ist für Einzelhop-Sitzungen, IPv4-Mehrfachhop-Sitzungen und IPv6-Mehrfachhop-Sitzungen gleich. In der folgenden Tabelle wird der Standardwert jedes BFD-Parameters angezeigt.

BFD-Parametername Standardwert
Intervall 750 Millisekunden
Mindestens Rx 500 Millisekunden
Multiplikator 3

Wichtig:

Die Initialisierung von Mellanox-NICs in einer Citrix Appliance dauert etwa 1500 ms. Sie müssen die BFD-Timer für eine Citrix ADC Appliance mit Mellanox-Netzwerkkarten auf mehr als 1500 ms festlegen. Citrix empfiehlt, die BFD-Timer auf 3000 ms festzulegen:

  • Intervall Tx = 600 ms
  • Minimum Rx = 600 ms
  • Multipler = 5

Konfigurieren von BFD-Parametern für eine Single-Hop-Sitzung

Um BFD-Parameter für eine einzelne Hop-Sitzung über dieVTYSH Befehlszeile zu konfigurieren, geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
interface vlan ID> Geben Sie den Schnittstellenkonfigurationsmodus ein.
bfd singlehop-peer interval <num> minrx <num> multiplier <num> Konfigurieren Sie die BFD-Parameter auf der angegebenen Schnittstelle.

Beispielkonfiguration:

> vtysh

ns# configure terminal

ns(config)# interface vlan3

ns(config-if)# bfd singlehop-peer interval 200 minrx 200 multiplier 5

ns(config-if)# exit

Konfigurieren von BFD-Parametern für IPv4-Mehrfachhop-Sitzungen

Um BFD-Parameter für mehrere IPv4-Hop-Sitzungen über dieVTYSH Befehlszeile zu konfigurieren, geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
bfd multihop-peer <ipv4addr> interval <num> minrx <num> multiplier <num> Konfigurieren Sie die BFD-Parameter für IPv4-Multiple Hops-Sitzungen.

Beispielkonfiguration:

    > vtysh

    ns# configure terminal

    ns(config)# bfd multihop-peer 20.20.20.138 interval 300 minrx 300 multiplier 5

    ns(config)# exit

Konfigurieren von BFD-Parametern für IPv6-Mehrfachhop-Sitzungen

Um BFD-Parameter für mehrere IPv6-Hop-Sitzungen über dieVTYSH Befehlszeile zu konfigurieren, geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
bfd multihop-peer ipv6 <ipv6addr> interval <num> minrx <num> multiplier <num> Konfigurieren Sie die BFD-Parameter für IPv6-Multi-Hops-Sitzungen.

Beispielkonfiguration:

    > vtysh

    ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

    ns(config)# exit

Konfigurieren der BFD-Unterstützung für dynamische Routing-Protokolle

Sie können BFD für ein dynamisches Routingprotokoll für einen Sitzungstyp mit einem Peer aktivieren. Zum Beispiel Single Hop und mehrere Hops. Die Citrix ADC Appliance wendet die entsprechenden BFD-Parametereinstellungen auf die Sitzung an.

Konfigurieren von BFD für eine IPv4 BGP Single Hop Session

Um BFD für eine IPv4-BGP-Einzelhop-Sitzung über dieVTYSH Befehlszeile zu konfigurieren, geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
router bgp <asnumber> BGP autonomes System.asnumber ist ein erforderlicher Parameter.
neighbor <ipv4addr> remote-as <num> Aktualisieren Sie die IPv4 BGP-Tabelle mit der IPv4-Adresse des Nachbarn im angegebenen autonomen System.
neighbor <ipv4addr> fall-over bfd Aktivieren Sie BFD für den angegebenen Nachbarn.

Beispielkonfiguration:

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Konfigurieren von BFD für eine IPv4 BGP Multiple Hop Session

Um BFD für eine IPv4-BGP-Mehrfachhop-Sitzung über dieVTYSH Befehlszeile zu konfigurieren, geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
router bgp <asnumber> BGP autonomes System.asnumber ist ein erforderlicher Parameter.
neighbor <ipv4addr> remote-as <num> Aktualisieren Sie die IPv4 BGP-Tabelle mit der IPv4-Adresse des Nachbarn im angegebenen autonomen System.
neighbor <ipv4addr> fall-over bfd multihop Aktivieren Sie BFD für den angegebenen Nachbarn.

Beispielkonfiguration:

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd multihop

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Konfigurieren von BFD für eine IPv6 BGP Single Hop Session

Um BFD für eine IPv6-BGP-Einzelhop-Sitzung über dieVTYSH Befehlszeile zu konfigurieren, geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
router bgp <asnumber> BGP autonomes System.asnumber ist ein erforderlicher Parameter.
neighbor <ipv6addr> remote-as <num> Aktualisieren Sie die IPv6-BGP-Tabelle mit der lokalen IPv6-Adresse des Nachbarn im angegebenen autonomen System.
neighbor <ipv6addr> fall-over bfd Aktivieren Sie BFD für den angegebenen Nachbarn.
address-family ipv6 Geben Sie den Konfigurationsmodus für die Adressfamilie ein.
neighbor <ipv6addr> activate Exchange-Präfixe für die IPv6-Routerfamilie zwischen dem Peer und dem lokalen Knoten mithilfe der lokalen Linkadresse.

Beispielkonfiguration:

> vtysh

ns# configure terminal ns(config)#router bgp 1

ns(config-router)#neighbor 30fe:123::124 remote-as 1

ns(config-router)#neighbor 30fe:123::124 fall-over bfd

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 30fe:123::124 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#exit

Konfigurieren von BFD für eine IPv6 BGP-Sitzung mit mehreren Hop

Um BFD für eine IPv6-BGP-Mehrfachhop-Sitzung über dieVTYSH Befehlszeile zu konfigurieren, geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
router bgp <asnumber> BGP autonomes System.asnumber ist ein erforderlicher Parameter.
neighbor <ipv6addr> remote-as <num> Aktualisieren Sie die IPv6-BGP-Tabelle mit der lokalen IPv6-Adresse des Nachbarn im angegebenen autonomen System.
neighbor <ipv6addr> fall-over bfd multihop Aktivieren Sie BFD für den angegebenen Nachbarn.
address-family ipv6 Geben Sie den Konfigurationsmodus für die Adressfamilie ein.
neighbor <ipv6addr> activate Exchange-Präfixe für die IPv6-Routerfamilie zwischen dem Peer und dem lokalen Knoten mithilfe der link-lokalen Adresse.

Beispielkonfiguration:

> vtysh

ns# configure terminal

ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

ns(config)#router bgp 1

ns(config-router)#neighbor 20fe:125::138 remote-as 1

ns(config-router)#neighbor 20fe:125::138 fall-over bfd multihop

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 20fe:125::138 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#end

Konfigurieren von BFD für OSPFv2 (IPv4) auf Schnittstellen

Sie können BFD auf allen oder auf einer bestimmten Schnittstelle aktivieren, die das OSPFv2-Protokoll verwendet.

So konfigurieren Sie BFD für OSPFv2 auf allen Schnittstellen über dieVTYSH Befehlszeile:

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
router ospf <process tag> Geben Sie den OSPFv2-Konfigurationsmodus ein.
bfd all-interfaces Aktivieren Sie BFD auf allen Schnittstellen, die OSPFv2 verwenden.

Beispielkonfiguration:

    > vtysh

    ns# configure terminal

    ns(config)#router ospf 1

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

So konfigurieren Sie BFD für OSPFv2 auf einer bestimmten Schnittstelle mithilfe derVTYSH Befehlszeile:

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
interface <vlan ID> Geben Sie den Schnittstellenkonfigurationsmodus ein.
ip ospf bfd Aktivieren Sie BFD auf der angegebenen Schnittstelle, die OSPFv2 verwendet.

Beispielkonfiguration:

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan5

    ns(config-if)# ip ospf bfd

    ns(config-if)# exit

Konfigurieren von BFD für OSPFv3 (IPv6) auf Schnittstellen

Sie können BFD auf allen oder auf einer bestimmten Schnittstelle aktivieren, die das OSPFv3-Protokoll verwendet.

So konfigurieren Sie BFD für OSPFv3 auf allen Schnittstellen über dieVTYSH Befehlszeile:

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
router ipv6 ospf <process tag> Rudern Sie den OSPFv3-Konfigurationsmodus ein.
bfd all-interfaces Aktivieren Sie BFD auf allen Schnittstellen, die OSPFv3 verwenden.

Beispielkonfiguration:

    > vtysh

    ns# configure terminal

    ns(config)#router ipv6 ospf 10

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

So konfigurieren Sie BFD für OSPFv3 auf einer bestimmten Schnittstelle mithilfe derVTYSH Befehlszeile:

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Gibt an
vtysh VTYSH`` Eingabeaufforderung anzeigen.
configure terminal Geben Sie den globalen Konfigurationsmodus ein.
interface <vlan ID> Geben Sie den Schnittstellenkonfigurationsmodus ein.
ipv6 ospf bfd Aktivieren Sie BFD auf der angegebenen Schnittstelle, die OSPFv3 verwendet.

Beispielkonfiguration:

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan15

    ns(config-if)# ipv6 ospf bfd

    ns(config-if)# exit

Bidirektionale Weiterleitungserkennung konfigurieren