Citrix ADC

Konfigurieren von ISIS

Die Citrix ADC Appliance unterstützt das dynamische Routingprotokoll Intermediate System-to-Intermediate System (IS-IS oder ISIS). Dieses Protokoll unterstützt sowohl IPv4- als auch IPv6-Routenaustausch. IS‑IS ist ein Verbindungsstatusprotokoll und ist daher weniger anfällig für Routingschleifen. Mit den Vorteilen einer schnelleren Konvergenz und der Fähigkeit, größere Netzwerke zu unterstützen, kann ISIS in Internet Service Provider (ISP) -Netzwerken sehr nützlich sein.

Voraussetzungen für die Konfiguration von ISIS

Bevor Sie mit der Konfiguration von ISIS beginnen, gehen Sie wie folgt vor:

  • Stellen Sie sicher, dass Sie das ISIS-Protokoll verstehen.
  • Aktivieren Sie für IPV6-Routen:
    • IPv6-Protokollübersetzungsfunktion.
    • IPv6-Option Dynamisches Routing auf den VLANs, auf denen Sie das ISIS-Protokoll ausführen möchten.

ISIS aktivieren

Verwenden Sie eines der folgenden Verfahren, um die ISIS-Routingfunktion auf der Citrix ADC Appliance zu aktivieren.

So aktivieren Sie das ISIS-Routing mit der CLI:

Geben Sie an der Eingabeaufforderung Folgendes ein:

enable ns feature ISIS

So aktivieren Sie das ISIS-Routing mit der GUI:

  1. Navigieren Sie zu System > Einstellungen, und klicken Sie in der Gruppe Modi und Features auf Erweiterte Funktionen ändern.
  2. Aktivieren oder deaktivieren Sie die Option ISIS-Routing.

ISIS-Routing-Prozess erstellen und auf einem VLAN starten

Um einen ISIS-Routingprozess zu erstellen, müssen Sie die VTYSH Befehlszeile verwenden.

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Beschreibung
VTYSH Zeigt die VTYSH Eingabeaufforderung an.
Terminal konfigurieren Wechselt in den globalen Konfigurationsmodus.
Router ISIS[tag] Erstellt einen ISIS-Routing- und Konfigurationsmodus für den Routingprozess.
net XX….XXXX.YYYY.YYYY.YYYY.00 Gibt einen NET-Wert für den Routing-Prozess an, wobei: ·XX.. .XXXX die Bereichsadresse (kann 1-13 Byte sein), ·YYYY.YYYY.YYYY die System-ID (6 Byte) und ·00 der N-Selektor (1 Byte) ist.
is-type (level-1|level-1-2|level-2-only) Legt den ISIS-Routingprozess auf die angegebene Weiterleitungsebene fest. Standard: level-1-2.
ns IPv6-routing Startet den dynamischen IPv6-Routing-Daemon.
interface <vlan_name> Wechselt in den VLAN-Konfigurationsmodus.
ip router ISIS Aktiviert den ISIS-Routing-Prozess im VLAN für IPv4-Routenaustausch.
ipv6 router ISIS Aktiviert den ISIS-Routing-Prozess im VLAN für IPv6-Routenaustausch.

Beispiel:

> VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# net 15.aabb.ccdd.0097.00
NS(config-router)# is-type level-1
NS(config-router)# exit
NS(config)# ns IPv6-routing
NS(config)# interface vlan0
NS(config-if)#  ip router isis 11
NS(config-if)# ipv6 router isis 11

Routen ankündigen

Routenankündigung ermöglicht es einem Upstream-Router, Netzwerkentitäten zu verfolgen, die sich hinter der Citrix ADC Appliance befinden.

So konfigurieren Sie ISIS für die Ankündigung von Routen mithilfe der VTYSH Befehlszeile:

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Beschreibung
VTYSH Zeigt die VTYSH Eingabeaufforderung an.
Terminal konfigurieren Wechselt in den globalen Konfigurationsmodus.
Router ISIS[tag] Startet die ISIS-Routinginstanz und wechselt in den Konfigurationsmodus für den Routingprozess.
redistribute connected (level-1 or level-1-2 or level-2) Verteilt verbundene Routen neu, wobei: level-1: Verteilen Sie verbundene Routen in Level-1, level-1-2: Verteilen Sie verbundene Routen in Level-1 und Level-2, level-2: Verteilen Sie verbundene Routen in Level-2.
redistribute kernel (level-1 or level-1-2 or level-2) Verteilt Kernel-Routen neu, wobei: level-1: Kernel-Routen in Level-1 umverteilen, level-1-2: Kernel-Routen neu in Level-1 und Level-2 verteilen, level-2: Kernel-Routen neu in Level-2 verteilen.

Beispiel:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# redistribute connected level-1
NS(config-router)# redistribute kernel level-1

ISIS-Propagierungen einschränken

Wenn Sie Probleme mit der Konfiguration beheben müssen, können Sie den Nur-Liste-Modus auf einem beliebigen VLAN konfigurieren.

So beschränken Sie die ISIS-Propagierung mithilfe der VTYSH Befehlszeile:

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehl Beschreibung
VTYSH Zeigt die VTYSH Eingabeaufforderung an.
Terminal konfigurieren Wechselt in den globalen Konfigurationsmodus.
router isis [tag] Wechselt in den Konfigurationsmodus für den Routing-Prozess.
passive-interface <vlan_name> Unterdrückt Routingaktualisierungen auf Schnittstellen, die an das angegebene VLAN gebunden sind.

Beispiel:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# passive-interface VLAN0

Überprüfen der ISIS-Konfiguration

Sie können VTYSH verwenden, um die ISIS-Routingtabelle und ISIS-Informationen für ein spezifiziertes VLAN anzuzeigen.

So zeigen Sie die ISIS-Einstellungen mithilfe der VTYSH Befehlszeile an:

Geben Sie an der Eingabeaufforderung die folgenden Befehle in der angegebenen Reihenfolge ein:

Befehle Beschreibung
VTYSH Zeigt die VTYSH Eingabeaufforderung an.
show ip isis route Zeigt die aktualisierte IPv4-ISIS-Routingtabelle an.
show ipv6 isis route Zeigt die aktualisierte IPv6-ISIS-Routingtabelle an.
sh isis interface <vlan_name> Zeigt IPv6-ISIS-Informationen für das angegebene VLAN an.

Beispiel:

NS# VTYSH
NS#  show ip isis route
NS#  show ipv6 isis route
NS# sh isis interface VLAN0

Konfigurieren von ISIS