Citrix ADC

Anycast-Unterstützung in Citrix ADC

Anycast ist ein Netzwerktyp, in dem eine Gruppe von Servern dieselbe IP-Adresse verwendet. Die Clientanforderung wird basierend auf ihren Routingtabellen an den topografisch nächstgelegenen Server weitergeleitet. Dieses Routing reduziert Latenzprobleme, sorgt für hohe Verfügbarkeit und minimiert Ausfallzeiten.

Citrix ADC unterstützt Anycast-Netzwerk mit Global Server Load Balancing (GSLB) und DNS-Funktionen.

Das folgende Diagramm veranschaulicht ein Topologiediagramm von Anycast in Citrix ADC.

lokalisiertes Bild

Anycast GSLB

Die Citrix ADC GSLB-Funktion bietet Lastausgleich an global verteilten Standorten zusammen mit Disaster Recovery und gewährleistet eine kontinuierliche Verfügbarkeit von Anwendungen.

Bei einem Ausfall bietet GSLB eine sofortige Notfallwiederherstellung, indem Datenverkehr zum nächstgelegenen oder leistungsstärksten Rechenzentrum weitergeleitet wird. Die GSLB kann jedoch Folgendes nicht kontrollieren:

  • Wie der DNS-Datenverkehr an GSLB-Knoten weitergeleitet wird, die sich an verschiedenen geografischen Standorten befinden.
  • Wie viel Latenz hinzugefügt wird, während DNS-Abfragen an GSLB-Knoten weitergeleitet werden.

In einem typischen GSLB-Setup verfügt jedes Rechenzentrum über einen GSLB-Knoten, der mit dem standortspezifischen Autoritative Domain Name Server (ADNS) konfiguriert ist, um DNS-Abfragen zu empfangen. Der ADNS jedes Standorts wird als Nameserver im DNS-Resolver konfiguriert. Wenn die Anzahl der GSLB-Knoten zunimmt, erhöht sich auch die Anzahl der Nameserver-Datensätze. In solchen Fällen muss LDNS bei einem Ausfall eines Rechenzentrums die Auflösung mit einem anderen Nameserver wiederholen, was die Latenz in der DNS-Auflösung erhöhen würde. Jedes Mal, wenn ein GSLB-Knoten hinzugefügt wird, müssen die Nameserver-Datensätze aktualisiert werden .

Um diese Nachteile zu überwinden, können Sie Anycast ADNS verwenden. In Anycast ADNS wird eine einzelne ADNS-IP-Adresse für alle GSLB-Knoten verwendet und der DNS-Datenverkehr wird über dynamisches Routing an GSLB-Knoten weitergeleitet.

Wenn beispielsweise eine GSLB-Site DOWN ist, wird die Routing-Tabelle aktualisiert, und die Route zu dieser Site wird entfernt. Daher werden die DNS-Abfragen nicht an die Sites gesendet, die DOWN sind. Infolgedessen gibt es keine Wiederholungen.

Wenn ein neuer GSLB-Knoten hinzugefügt wird, wird dem neuen Knoten die gleiche ADNS-IP-Adresse zugewiesen. Das dynamische Routing aktualisiert automatisch die Routingtabellen mit Routen zu neuen Standorten basierend auf den Routingalgorithmen. Daher müssen Sie die DNS-Namensserver-Einträge nicht aktualisieren. Der Rollout neuer GSLB-Standorte wird mit Anycast einfacher und schneller gestaltet.

Konfigurieren der ADNS-IP-Adresse in einem Anycast-Modus

Sie müssen das Hostrouting auf der ADNS-IP in Citrix ADC aktivieren und die entsprechende RHI-Ebene (Route Health Injection) festlegen. Meistens gäbe es keine virtuellen Server auf der ADNS IP und daher muss RHI Level als NONE ausgewählt werden. Durch Aktivieren der Hostroute auf der ADNS-IP wird sie zu einer Kernelroute. Sie können dann das dynamische Routing Ihrer Wahl aktivieren und das Routingprotokoll so konfigurieren, dass die Kernel-Routen neu verteilt werden.

ADNS-IP-Konfiguration - Beispiel

Geben Sie an der Eingabeaufforderung;

add service adns_public 5.5.5.5 ADNS 53

set ip 5.5.5.5 -hostRoute ENABLED -vserverRHILevel ALL_VSERVERS

BGP-Konfiguration im GSLB-Standort - Beispiel

Site1#sh run
!
hostname Site1
!
log syslog
log record-priority
!
ns route-install bgp
!
interface lo0
 ip address 127.0.0.1/8
 ipv6 address fe80::1/64
 ipv6 address ::1/128
!
interface vlan0
 ip address 10.102.148.94/25
 ipv6 address fe80::e84c:f4ff:fe74:4588/64
!
interface vlan2
 ip address 172.18.30.15/24
!
router bgp 5
 redistribute kernel -----> redistributing the kernel routes
 neighbor 172.18.30.30 remote-as 4
 neighbor 172.18.30.30 advertisement-interval 1
 neighbor 172.18.30.30 timers 4 16
!
End

Site1#

GSLB-Standort-Routingtabelle - Beispiel

Site1#sh ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
       O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, I - Intranet
       * - candidate default

K       5.5.5.5/32 via 0.0.0.0 ---------------------------------------> Kernel Route for ADNS
C       10.102.148.0/25 is directly connected, vlan0
C       127.0.0.0/8 is directly connected, lo0
B       172.18.10.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       172.18.20.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
C       172.18.30.0/24 is directly connected, vlan2
B       192.168.3.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       192.168.5.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       192.168.10.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h

Gateway of last resort is not set
Site1#

Anycast DNS

Sie können Anycast DNS für virtuelle DNS-Proxyserver auf Citrix ADC verwenden. Wenn mehrere DNS-Namensserver konfiguriert sind, reagiert der DNS-Resolver basierend auf Round-Robin-Methode. Wenn der Resolver beispielsweise keine Antwort vom ersten Server erhält, wechselt er nach Ablauf des konfigurierten Zeitüberschreitungswerts zum zweiten Server usw. Der Wechsel vom ersten Server zum zweiten Server erhöht die Latenz in der DNS-Auflösung. Wenn die DNS-Resolver mit Anycast konfiguriert sind, kann diese Latenz eliminiert werden.

DNS-Konfiguration - Beispiel

Geben Sie an der Eingabeaufforderung;

add lb vserver dns DNS 5.5.5.50 53

set ip 5.5.5.50 -hostRoute ENABLED -vserverRHILevel ALL_VSERVERS

Anycast-Unterstützung in Citrix ADC