Product Documentation

Installation Fails

Dec 08, 2016

This topic provides troubleshooting tips for when the installation step fails during an Install Capture – for example, if the virtual machine closes during the installation and the import fails. This may be because an unexpected error was encountered during the installation.

To troubleshoot issues:

  1. Launch the virtual machine independently of AppDNA.
  2. Check that you can browse from the virtual machine to the location of the installation package (as specified on the Import Applications screen) .
  3. Attempt to launch the installation manually from the virtual machine using the same UNC path that was specified on the Import Applications screen.

This should reveal any errors, such as that the virtual machine cannot access the file, the file is missing, incorrect permissions, or the location of the installation file was not specified using a UNC path. If you are using a mapped drive, see "Mapped drive issues" below.

Check that there are no security warnings or prompts when launching the installation. If there are, the problem may be a characteristic of the specific installer. Try running the capture in manual mode.

After you have addressed any issues:

  1. Close down the virtual machine.
  2. If necessary, on the Install Capture tab in the Import Applications screen, correct the path to the installation file so that it is specified correctly using a UNC path.
  3. Then try the import through AppDNA again.

If the installation continues to fail:

Mapped drive issues

If you are using a mapped drive for the input or output location, check that the same drive letter is mapped to the same location on both the AppDNA machine and the virtual machine.

If the guest OS is Windows 7, Windows 8, or another OS that supports User Access Control (UAC) and UAC is not completely disabled, a mapped drive that was created using the net use command may be inaccessible to Remote Admin during Install Capture. This can lead to Install Capture failing.

If you encounter this issue, instead of using net use, map the drive using the Map network drive option in Windows Explorer, and select the Reconnect at logon check box. Typically, this resolves the issue. For an alternative solution, see http://support.microsoft.com/kb/937624.