Deprecated features and functionalities

Classic policy-based features and functionalities are deprecated from NetScaler 12.0 build 56.20 onwards. As an alternative, Citrix recommends you to use the Advanced policy infrastructure. As part of this effort, when you upgrade your appliance to Citrix ADC 12.1 build 51.16 or later, you must replace the Classic policy-based features and functionalities to its corresponding non-deprecated features and functionalities. Also, you must convert Classic policies and their expressions to Advanced policies and expressions. Also, all new Citrix ADC features support only Advanced policy infrastucture.

You can migration your Classic policies and expressions either manually or by using the nspepi tool. The tool helps you to auto-convert Classic policies and their expressions (in the Citrix ADC commands, expressions, and configurations) to Advanced policy infrastructure.

For deprecated features and their alternatives, see Deprecated Features and Functionalities pdf.

Deprecated features and functionalities