Product Documentation

Static cluster link aggregation

You must configure a static cluster LA channel on the cluster IP address and on the external connecting device. If possible, configure the upstream switch to distribute traffic based on IP address or port instead of MAC address.

To configure a static cluster LA channel by using the command line interface

  1. Log on to the cluster IP address.

    Note

    Make sure that you configure the cluster LA channel on the cluster IP address before configuring link aggregation on the external switch. Otherwise, the switch will forward traffic to the cluster even though the cluster LA channel is not configured. This can lead to loss of traffic.

  2. Create a cluster LA channel.

    add channel <id> -speed <speed>```
    

    Example

    add channel CLA/1 -speed 1000
    

    Note

    You must not specify the speed as AUTO. Rather, you must explicitly specify the speed as 10, 100, 1000, or 10000. Only interfaces that have the speed matching the <speed> attribute in the cluster LA channel are added to the active distribution list.

  3. Bind the required interfaces to the cluster LA channel. Make sure that the interfaces are not used for the cluster backplane.

    bind channel <id> <ifnum>
    

    Example

    bind channel CLA/1 0/1/2 1/1/2 2/1/2 ```
    
  4. Verify the configurations.

    show channel <id>
    

    Example

    show channel CLA/1
    

    Note

    You can bind the cluster LA channel to a VLAN by using the bind vlan command. The interfaces of the channel are automatically bound to the VLAN.

  5. Configure static LA on the external switch. The following sample configurations are provided for the Cisco® Nexus 7000 C7010 Release 5.2(1). Similar configurations must be performed on other switches.

    Global config:
    Configure terminal
    
    Interface level config:
    
    interface Ethernet2/47
    switchport
    switchport access vlan 10
    channel-group 7 mode on
    no shutdown
    
    interface Ethernet2/48
    switchport
    switchport access vlan 10
    channel-group 7 mode on
    no shutdown
    

Static cluster link aggregation