Product Documentation

System Requirements for Worx Apps

Jan 02, 2014

This topic describes the operating systems and XenMobile component versions that are supposed for Worx apps. The topic also lists the requirements for uploading Worx Apps (WorxMail and WorxWeb) to App Controller, for enabling remote connections through NetScaler Gateway, and for running the Worx apps on iOS and Android mobile devices.

The following table lists the minimum recommended operating systems and component versions that are supported for Worx apps:

  • You can upload WorxMail and WorxWeb wrapped mobile apps to AppController 2.6, App Controller 2.8 and App Controller 2.9.
  • Remote users can connect through NetScaler Gateway 10.1.
  • To allow users to connect from an Android device through NetScaler Gateway, the Android device must be running a minimum of Version 4.0.
  • To allow users to connect from an iOS device through NetScaler Gateway, the iOS device much be running a minimum of Version 5.1.
App type iOS Android App Controller NetScaler Gateway Device Manager
MDM 5.1 2.3 N/A 10.1 8.0.1
Enterprise 6.0 4.0 2.6, 2.8, and 2.9 10.1 N/A

Device Requirements

You can run Worx apps on iOS and Android devices with the following minimum operating systems:

iOS devices

  • Worx Home minimum iOS 5.1
  • WorxWeb, iOS 5 or 6
  • For WorxMail, iOS 6 minimum, all devices

Android devices

  • Worx Home minimum Android version 2.3
  • For WorxWeb, minimum Android 2.3
  • For WorxMail, minimum Android 4.0

    Includes phones, 7-inch and 10-inch tablets