Citrix ADC

Enrutamiento en un clúster

El enrutamiento en un clúster funciona de la misma manera que el enrutamiento en un sistema independiente. Algunos puntos a tener en cuenta:

  • Todas las configuraciones de enrutamiento deben realizarse desde la dirección IP del clúster y las configuraciones se propagan a los demás nodos del clúster.

  • Las rutas están limitadas al número máximo de rutas ECMP admitidas por el enrutador ascendente.

  • Las configuraciones de enrutamiento específicas de nodo se deben realizar mediante el argumento owner-node de la siguiente manera:

  router ospf
    owner-node 0
      ospf router-id 97.131.0.1
    exit-owner-node
  !

El siguiente comando muestra la configuración del clúster consolidado para todos los nodos de VTYSH.

show cluster-config

El siguiente comando muestra el estado del clúster en cada nodo.

show cluser node

Enrutamiento IPv4 en clúster L2

La siguiente sección contiene configuraciones de ejemplo que le ayudan a configurar el enrutamiento OSPF y BGP IPv4 en el clúster L2.

Agregar dirección SNIP detectada y habilitar el enrutamiento dinámico

En la siguiente configuración, el enrutamiento OSPF y BGP están habilitados. Además, se agregan direcciones SNIP detectada y se habilita el enrutamiento dinámico en estas direcciones SNIP.

en ns fea ospf bgp
add vlan 10
add ns ip 10.10.10.1 255.255.255.0 -dynamicrouting enabled -ownernode 1
add ns ip 10.10.10.2 255.255.255.0 -dynamicrouting enabled -ownernode 2
add ns ip 10.10.10.3 255.255.255.0 -dynamicrouting enabled -ownernode 3
bind vlan 10 -ipaddress 10.10.10.1 255.255.255.0

Configuración OSPF IPv4 de VTYSH

Para configurar IPv4 OSPF en clúster L2, debe

  • Establezca la prioridad en cero.
  • Configure el ID del enrutador como una configuración detectada.

Nota

Las directrices de configuración OSPF para el clúster L2 también son aplicables para OSPFv3.

En la siguiente configuración de ejemplo se configura OSPF IPv4.

      interface vlan10
       IP OSPF PRIORITY 0
       !
      router ospf
          owner-node 1
            ospf router-id 97.131.0.1
          exit-owner-node
          owner-node 2
            ospf router-id 97.131.0.2
          exit-owner-node
          owner-node 3
            ospf router-id 97.131.0.3
          exit-owner-node
      network 10.10.10.0/24 area 0
      redistribute kernel
       !

Configuración de VTYSH IPv4 BGP

En la siguiente configuración de ejemplo de VTYSH, se configura IPv4 BGP.

    router bgp 100
      neighbor 10.10.10.10 remote-as 200
     owner-node 1
      neighbor 10.10.10.10 update-source 10.10.10.1
     exit-owner-node
     owner-node 2
      neighbor 10.10.10.10 update-source 10.10.10.2
     exit-owner-node
     owner-node 3
      neighbor 10.10.10.10 update-source 10.10.10.3
     exit-owner-node
    redistribute kernel
    !

Nota

El comando update-source se utiliza para cada vecino con argumento owner-node en la siguiente configuración para conectarse con la IP de origen adecuada.

Enrutamiento IPv6 en clúster L2

La siguiente sección contiene configuraciones de ejemplo que ayudan a configurar IPv6 OSPF y el enrutamiento BGP en clúster L2.

Habilitar enrutamiento IPv6

Antes de configurar el enrutamiento IPv6 en un clúster L2, debe habilitar la función IPv6.

Para habilitar el enrutamiento IPv6 mediante el CLI,

En el símbolo del sistema, escriba:

  • enable ns fea ipv6pt

Agregar la dirección SNIP6 detectada y habilitar el enrutamiento dinámico

En la siguiente configuración, el enrutamiento OSPF y BGP están habilitados. Además, se agregan direcciones SNIP6 detectada y se habilita el enrutamiento dinámico en estas direcciones SNIP6.

add ns ip6 3ffa::1/64 -dynamicrouting enabled -ownernode 1
add ns ip6 3ffa::2/64 -dynamicrouting enabled -ownernode 2
add ns ip6 3ffa::3/64 -dynamicrouting enabled -ownernode 3
add vlan 10
bind vlan 10 -ipaddress 3ffa::1/64

Configuración de VTYSH IPv6 BGP

En la siguiente configuración de ejemplo de VTYSH, se configura IPv6 BGP.

  router bgp 100
   neighbor 3ffa::10 remote-as 200
     owner-node 1
      neighbor 3ffa::10 update-source 3ffa::1
     exit-owner-node
     owner-node-2
      neighbor 3ffa::10 update-source 3ffa::2
     exit-owner-node
     owner-node-3
      neighbor 3ffa::10 update-source 3ffa::3
     exit-owner-node
   no neighbor 3ffa::10 activate
   address-family ipv6
    redistribute kernel
    neighbor 3ffa::10 activate
   exit-address-family
  !

Instalar rutas aprendidas de IPv6

El clúster de Citrix ADC puede utilizar rutas aprendidas por varios protocolos de enrutamiento después de instalar las rutas en la tabla de redirecciones del clúster de Citrix ADC.

Para instalar rutas aprendidas de IPv6 en la tabla de redirecciones interno mediante la CLI:

En el símbolo del sistema, escriba:

  • ns route-install ipv6 bgp

  • ns route-install ipv6 ospf

  • ns route-install default

Nota

  • Si tiene que intercambiar rutas IPv4 en un vecino IPv6, debe quitar el comando no neighbor 3ffa::10 active VTYSH de la configuración anterior.

  • El comando update-source VTYSH debe utilizarse para que cada nodo propietario especifique la IP de origen IPv6 correcta mientras se conecta al par BGP como se indica en la configuración IPv4 de BPG.

Enrutamiento en un clúster L3

El enrutamiento en clúster L3 solo funciona cuando se realizan las siguientes configuraciones en el dispositivo Citrix ADC.

  • Habilite el enrutamiento dinámico para una VLAN.

     set vlan <id> -dynamicrouting enabled
    
  • Para llegar a todos los nodos del clúster, el VIP, CLIP y Citrix ADC IP (NSIP) deben anunciarse mediante protocolos de enrutamiento junto con el comando set vlan.

Caso de implementación para BGP en clúster L3

Considere un ejemplo en el que todos los nodos del clúster se agrupan en la red AS 100 y los enrutadores ascendentes están en un AS 200 diferente.

En la siguiente figura se muestra la implementación de AS 100 y AS 200 en una configuración de clúster.

Imagen localizada

En esta implementación, CLIP anuncia CCO a los routers ascendentes. Algunos nodos del clúster descartan el tráfico anunciado, a medida que se detecta el bucle AS.

Para superar el problema, configure el siguiente comando en el modo de enrutador vtysh BGP para cada vecino.

En el símbolo del sistema VTYSH, escriba:

neighbor <peer_ip> allowas-in 1

Como práctica recomendada, Citrix recomienda configurar cualquiera de las siguientes opciones:

  • Configure los mapas de ruta para aprender solo las redes deseadas, como; ruta predeterminada, Citrix ADC IP (NSIP) y subredes NSIP en los nodos del clúster.

  • Configure las rutas ascendentes para anunciar solo las redes deseadas como, por ejemplo, CLIP y Citrix ADC IP (NSIP) en el clúster.

Enrutamiento en un clúster