Citrix ADC

Configuración del ECMP del clúster mediante el switch Cisco Nexus 7000 con protocolo de enrutamiento

Con ECMP sobre una configuración de clúster, un dispositivo Citrix ADC puede manejar el tráfico a través de un protocolo de enrutamiento. El mecanismo ECMP ayuda a anunciar las direcciones IP del servidor virtual a través de todos los nodos de clúster activos.

Para utilizar ECMP, primero debe habilitar el protocolo BGP en la dirección IP del clúster. Enlazar las interfaces y la dirección IP detectada (con enrutamiento dinámico habilitado) a una VLAN. Configure el protocolo de enrutamiento seleccionado y redistribuya las rutas del kernel en los ZebOS mediante el shell vtysh.

Caso de uso: Cluster ECMP mediante el switch Cisco Nexus 7000 con protocolo de enrutamiento

Considere un ejemplo de implementación de clúster con el switch Cisco Nexus 7000:

  • Dos dispositivos Citrix ADC (nodo 1 y nodo 2), conectados al conmutador Nexus (ascendente).
  • Dos conmutadores Cisco Nexus 7000.
  • Cliente y servidor (dibujo del tráfico HTTP a través del conmutador Nexus). Con el protocolo de enrutador en espera activa (HSRP) habilitado en el lado del cliente.

Citrix Cisco Nexus 7000

Requisitos previos

Tenga en cuenta los siguientes puntos antes de configurar los nodos de clúster en un dispositivo Citrix ADC.

  1. Todos los dispositivos deben ser del mismo tipo de plataforma.
  2. El protocolo de puerta de enlace de borde (BGP) debe estar habilitado en los nodos del clúster.

Configuración mediante la línea de comandos del dispositivo Citrix ADC

  1. Inicie sesión en un dispositivo (por ejemplo, dispositivo con dirección NSIP 1.1.1.1)

  2. Para agregar un nodo de clúster.

    add cluster node 0 1.1.1.2 —state ACTIVE —backplane 0/10/8
    
  3. Para agregar la dirección IP del clúster

    add ns ip 1.1.1.10 255.255.255.254 –type clip
    
  4. Guardar la configuración

    save ns config
    
  5. Reinicie el dispositivo en caliente

    reboot -warm
    
  6. Para agregar el nodo 1 mediante CLIP

    add cluster node 1 2.2.2.2 —state ACTIVE —backplane 1/10/8
    
  7. Para unir un nodo al clúster

    join cluster —clip 1.1.1.10 —password nsroot
    
  8. Realice la siguiente configuración en CLIP

    • enable ns feature bgp ospf DYNAMICROUTING

    • add ns ip 11.1.1.3 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.7 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.5 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

    • add ns ip 11.1.1.9 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

En el router Cisco Nexus (11.1.1.2/31 y 11.1.1.4/31), debe realizar las siguientes configuraciones mediante la línea de comandos:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

    >  interface vlan100
        no shutdown
        ip address 50.1.1.1/8
         hsrp 50
          ip 50.50.50.50
    
    >  interface Ethernet 4/15
         ip address 11.1.1.2/31
         no shutdown
    
    >  interface Ethernet 4/19
         ip address 11.1.1.4/31
         no shutdown
    
    >  interface Ethernet 4/22
         switchport
          switchport access vlan 100
    

En el router Cisco Nexus (11.1.1.6/31 y 11.1.1.8/31), debe realizar las siguientes configuraciones mediante la línea de comandos:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

     >  interface vlan100
         no shutdown
         no ip redirects
         ip address 50.1.1.2/8
          hsrp 50
          ip 50.50.50.50
    
     >  interface Ethernet 4/13
         ip address 11.1.1.6/31
         no shutdown
    
     >  interface Ethernet 4/15
         ip address 11.1.1.8/31
         no shutdown
    
     >  interface Ethernet 4/22
         switchport
         switchport access vlan 100
    

Para el protocolo BGP, debe realizar las siguientes configuraciones en CLIP del dispositivo Citrix ADC:

>  vtysh
ns# router bgp 1
 redistribute kernel
 owner-node 0
 neighbor 11.1.1.2 remote-as 2
 neighbor 11.1.1.2 as-origination-interval 1
 neighbor 11.1.1.2 advertisement-interval 0
 neighbor 11.1.1.6 remote-as 2
 neighbor 11.1.1.6 as-origination-interval 1
 neighbor 11.1.1.6 advertisement-interval 0
owner-node 1
 neighbor 11.1.1.4 remote-as 2
 neighbor 11.1.1.4 as-origination-interval 1
 neighbor 11.1.1.4 advertisement-interval 0
 neighbor 11.1.1.8 remote-as 2
 neighbor 11.1.1.8 as-origination-interval 1
 neighbor 11.1.1.8 advertisement-interval 0
exit-owner-node

Realice las siguientes configuraciones en el router Cisco Nexus (11.1.1.3 y 11.1.1.5)

> ip access-list acl1
  10 permit ip 50.0.0.0/8 any
  route-map test permit
  match ip address acl1
 router bgp 2
  address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
 neighbor 11.1.1.3 remote-as 1
  address-family ipv4 unicast
  neighbor 11.1.1.5 remote-as 1
 address-family ipv4 unicast

Realice las siguientes configuraciones en el router Cisco Nexus (11.1.1.7 y 11.1.1.9)

> ip access-list acl1
   10 permit ip 50.0.0.0/8 any
  route-map test permit 1
   match ip address acl1
  router bgp 2
   address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
  neighbor 11.1.1.7 remote-as 1
   address-family ipv4 unicast
  neighbor 11.1.1.9 remote-as 1
   address-family ipv4 unicast

Para el protocolo OSPF, debe realizar las siguientes configuraciones en CLIP del dispositivo Citrix ADC:

> vtysh
ns# router osfp 1
redistribute kernel
owner-node 0
 network 15.1.1.2/31 area 0
 network 15.1.1.6/31 area 0
exit-owner-node

owner-node 1
 network 15.1.1.4/31 area 0
 network 15.1.1.8/31 area 0
exit-owner-node

route-map map2 permit 1
set metric 10

En el router Cisco Nexus (11.1.1.2/31 y 11.1.1.4/31), debe realizar las siguientes configuraciones mediante la línea de comandos:

> route-map- map2 permit 1
   set metric 10

   interface Ethernet4/15
     ip address 15.1.1.2/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   interface Ethernet4/19
     ip address 15.1.1.4/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   router ospf 1
    router-id 1.1.1.1
    redistribute direct route-map map2

En el router Cisco Nexus (11.1.1.7/31 y 11.1.1.9/31), debe realizar las siguientes configuraciones mediante la línea de comandos:

> route-map- map2 permit 1
    set metric 10

   interface Ethernet4/13
     ip address 15.1.1.6/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    interface Ethernet4/15
     ip address 15.1.1.8/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    router ospf 1
      router-id 1.1.1.2
      redistribute direct route-map map2

Configuración del ECMP del clúster mediante el switch Cisco Nexus 7000 con protocolo de enrutamiento