Citrix ADC

Configuración de la detección de reenvío bidireccional

El protocolo de detección de reenvío bidireccional (BFD) es un mecanismo para la detección rápida de fallas de rutas de reenvío. BFD detecta errores de ruta en el orden de milisegundos. BFD se utiliza con protocolos de enrutamiento dinámico.

En la operación BFD, los pares de enrutamiento intercambian paquetes BFD en un intervalo negociado. Si no se recibe un paquete de un par dentro del intervalo negociado más el intervalo de gracia, se considera que el par está muerto y se enviará una notificación al conjunto de protocolos de enrutamiento registrados. A su vez, los protocolos de enrutamiento vuelven a calcular la mejor ruta y reprograman la tabla de enrutamiento. BFD admite intervalos de tiempo más pequeños, en comparación con los temporizadores proporcionados por los protocolos de enrutamiento, lo que resulta en una detección más rápida de fallas.

El dispositivo Citrix ADC admite BFD para los siguientes protocolos de enrutamiento: BGP (IPv4 e IPv6), OSPFv2 (IPv4) y OSPFv3 (IPv6). La compatibilidad con BFD en el dispositivo Citrix ADC es compatible con RFC 5880, 5881 y 5883.

Puntos a considerar para configurar la detección de reenvío bidireccional

Antes de comenzar a configurar BFD, tenga en cuenta los siguientes puntos:

  • Asegúrese de que comprende los diferentes componentes de BFD, descritos en RFC 5880, 5881 y 5883.
  • BFD en un dispositivo Citrix ADC es compatible con los siguientes protocolos de enrutamiento:
    • BGP (IPv4 e IPv6)
    • OSPFv2 (IPv4)
    • OSPFv3 (IPv6)
  • BFD en un dispositivo Citrix ADC no es compatible con los siguientes protocolos de enrutamiento:
    • ISIS
    • RIP (IPv4)
    • RipNG (IPv6)
  • Las siguientes funciones de BFD no son compatibles con un dispositivo Citrix ADC:
    • Modo de eco BFD
    • Autenticación BFD
    • Modo asíncrono de demanda BFD
  • Los valores mínimos para los temporizadores de intervalo BFD y Rx BFD son 100 milisegundos.
  • Cuando se utiliza BFD en una topología con direcciones IP compartidas (por ejemplo, configuración de alta disponibilidad de capa 2 con direcciones SNIP o configuración de clúster con direcciones IP seccionadas), BFD desactiva las sesiones activas durante una conmutación por error porque el tiempo de detección de fallos BFD (orden de milisegundos) es menor que el HA intervalo de detección de conmutación por error (3 a 4 segundos). Por lo tanto, Citrix recomienda el uso de Graceful restart en topologías de alta disponibilidad de capa 2, ya que las rutas se conservan durante el proceso de conmutación por error.

Pasos de configuración

La configuración de BFD en un dispositivo Citrix ADC consta de las siguientes tareas:

  • Configurar parámetros de BFD
  • Configurar compatibilidad con BFD para protocolos de enrutamiento dinámico

Configurar parámetros de BFD

El dispositivo Citrix ADC proporciona parámetros de sesión BFD independientes para sesiones de salto único, sesiones de salto múltiple IPv4 e sesiones de salto múltiple IPv6. Si no configura parámetros BFD para un tipo de sesión, se aplicarán los valores predeterminados para esa sesión.

El valor predeterminado de cada parámetro BFD es el mismo para sesiones de salto único, sesiones de salto múltiple IPv4 y sesiones de salto múltiple IPv6. En la siguiente tabla se muestra el valor predeterminado de cada parámetro BFD.

Nombre del parámetro BFD Valor predeterminado
Intervalo 750 milisegundos
Rx mínimo 500 milisegundos
Multiplicador 3

IMPORTANTE:

Las NIC Mellanox en un dispositivo Citrix tardan alrededor de 1500 ms en inicializarse. Debe establecer los temporizadores BFD en más de 1500 ms para un dispositivo Citrix ADC con NIC Mellanox. Citrix recomienda establecer los temporizadores BFD en 3000 ms:

  • Intervalo Tx = 600 ms
  • Rx mínimo = 600 ms
  • Multipler = 5

Configuración de parámetros BFD para una sesión de salto único

Para configurar parámetros BFD para una sesión de salto único mediante la línea deVTYSH comandos, en el símbolo del sistema, escriba los comandos siguientes, en el orden mostrado:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
interface vlan ID> Entre en el modo de configuración de la interfaz.
bfd singlehop-peer interval <num> minrx <num> multiplier <num> Configure los parámetros BFD en la interfaz especificada.

Configuración de ejemplo:

> vtysh

ns# configure terminal

ns(config)# interface vlan3

ns(config-if)# bfd singlehop-peer interval 200 minrx 200 multiplier 5

ns(config-if)# exit

Configuración de Parámetros BFD para Sesiones de Saltos Múltiples IPv4

Para configurar parámetros BFD para sesiones de múltiples saltos IPv4 mediante la línea deVTYSH comandos, en el símbolo del sistema, escriba los comandos siguientes, en el orden mostrado:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
bfd multihop-peer <ipv4addr> interval <num> minrx <num> multiplier <num> Configure los parámetros BFD para sesiones de múltiples saltos IPv4.

Configuración de ejemplo:

    > vtysh

    ns# configure terminal

    ns(config)# bfd multihop-peer 20.20.20.138 interval 300 minrx 300 multiplier 5

    ns(config)# exit

Configuración de Parámetros de BFD para Sesiones de Saltos Múltiples IPv6

Para configurar parámetros BFD para sesiones de varios saltos de IPv6 mediante la línea deVTYSH comandos, en el símbolo del sistema, escriba los comandos siguientes, en el orden mostrado:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
bfd multihop-peer ipv6 <ipv6addr> interval <num> minrx <num> multiplier <num> Configure los parámetros BFD para sesiones de varios saltos de IPv6.

Configuración de ejemplo:

    > vtysh

    ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

    ns(config)# exit

Configurar compatibilidad con BFD para protocolos de enrutamiento dinámico

Puede habilitar BFD para un protocolo de enrutamiento dinámico para un tipo de sesión con un par. Por ejemplo, salto único y saltos múltiples. El dispositivo Citrix ADC aplica la configuración de parámetros BFD relevantes a la sesión.

Configuración de BFD para una sesión de salto único BGP IPv4

Para configurar BFD para una sesión de salto único BGP IPv4 mediante la línea deVTYSH comandos, en el símbolo del sistema, escriba los comandos siguientes, en el orden mostrado:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
router bgp <asnumber> Sistema autónomo BGP.asnumber es un parámetro obligatorio.
neighbor <ipv4addr> remote-as <num> Actualice la tabla IPv4 BGP con la dirección IPv4 del vecino en el sistema autónomo especificado.
neighbor <ipv4addr> fall-over bfd Habilite BFD para el vecino especificado.

Configuración de ejemplo:

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Configuración de BFD para una sesión de salto múltiple BGP IPv4

Para configurar BFD para una sesión de múltiples saltos BGP IPv4 mediante la línea deVTYSH comandos, en el símbolo del sistema, escriba los comandos siguientes, en el orden mostrado:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
router bgp <asnumber> Sistema autónomo BGP.asnumber es un parámetro obligatorio.
neighbor <ipv4addr> remote-as <num> Actualice la tabla IPv4 BGP con la dirección IPv4 del vecino en el sistema autónomo especificado.
neighbor <ipv4addr> fall-over bfd multihop Habilite BFD para el vecino especificado.

Configuración de ejemplo:

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd multihop

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Configuración de BFD para una sesión de salto único BGP IPv6

Para configurar BFD para una sesión de salto único BGP IPv6 mediante la línea deVTYSH comandos, en el símbolo del sistema, escriba los comandos siguientes, en el orden mostrado:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
router bgp <asnumber> Sistema autónomo BGP.asnumber es un parámetro obligatorio.
neighbor <ipv6addr> remote-as <num> Actualice la tabla IPv6 BGP con la dirección IPv6 local del vínculo del vecino en el sistema autónomo especificado.
neighbor <ipv6addr> fall-over bfd Habilite BFD para el vecino especificado.
address-family ipv6 Introduzca el modo de configuración de familia de direcciones.
neighbor <ipv6addr> activate Exchange prefijos para la familia de enrutadores IPv6 entre el par y el nodo local mediante la dirección local del vínculo.

Configuración de ejemplo:

> vtysh

ns# configure terminal ns(config)#router bgp 1

ns(config-router)#neighbor 30fe:123::124 remote-as 1

ns(config-router)#neighbor 30fe:123::124 fall-over bfd

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 30fe:123::124 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#exit

Configuración de BFD para una sesión de saltos múltiples BGP IPv6

Para configurar BFD para una sesión de múltiples saltos BGP IPv6 mediante la línea deVTYSH comandos, en el símbolo del sistema, escriba los comandos siguientes, en el orden mostrado:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
router bgp <asnumber> Sistema autónomo BGP.asnumber es un parámetro obligatorio.
neighbor <ipv6addr> remote-as <num> Actualice la tabla IPv6 BGP con la dirección IPv6 local del vínculo del vecino en el sistema autónomo especificado.
neighbor <ipv6addr> fall-over bfd multihop Habilite BFD para el vecino especificado.
address-family ipv6 Introduzca el modo de configuración de familia de direcciones.
neighbor <ipv6addr> activate Exchange prefijos para la familia de enrutadores IPv6 entre el par y el nodo local mediante la dirección local del vínculo.

Configuración de ejemplo:

> vtysh

ns# configure terminal

ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

ns(config)#router bgp 1

ns(config-router)#neighbor 20fe:125::138 remote-as 1

ns(config-router)#neighbor 20fe:125::138 fall-over bfd multihop

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 20fe:125::138 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#end

Configuración de BFD para OSPFv2 (IPv4) en interfaces

Puede habilitar BFD en todas o en una interfaz específica que utilice el protocolo OSPFv2.

Para configurar BFD para OSPFv2 en todas las interfaces mediante la línea deVTYSH comandos:

En el símbolo del sistema, escriba los siguientes comandos, en el orden que se muestra:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
router ospf <process tag> Introduzca el modo de configuración OSPFv2.
bfd all-interfaces Habilite BFD en todas las interfaces que usan OSPFv2.

Configuración de ejemplo:

    > vtysh

    ns# configure terminal

    ns(config)#router ospf 1

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Para configurar BFD para OSPFv2 en una interfaz específica mediante la línea deVTYSH comandos:

En el símbolo del sistema, escriba los siguientes comandos, en el orden que se muestra:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
interface <vlan ID> Entre en el modo de configuración de la interfaz.
ip ospf bfd Habilite BFD en la interfaz especificada que utiliza OSPFv2.

Configuración de ejemplo:

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan5

    ns(config-if)# ip ospf bfd

    ns(config-if)# exit

Configuración de BFD para OSPFv3 (IPv6) en interfaces

Puede habilitar BFD en todas o en una interfaz específica que utilice el protocolo OSPFv3.

Para configurar BFD para OSPFv3 en todas las interfaces mediante la línea deVTYSH comandos:

En el símbolo del sistema, escriba los siguientes comandos, en el orden que se muestra:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
router ipv6 ospf <process tag> Introduzca el modo de configuración OSPFv3.
bfd all-interfaces Habilite BFD en todas las interfaces que usan OSPFv3.

Configuración de ejemplo:

    > vtysh

    ns# configure terminal

    ns(config)#router ipv6 ospf 10

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Para configurar BFD para OSPFv3 en una interfaz específica mediante la línea deVTYSH comandos:

En el símbolo del sistema, escriba los siguientes comandos, en el orden que se muestra:

Comando Especifica
vtysh Muestra el símbolo del sistema VTYSH.
configure terminal Acceda al modo de configuración global.
interface <vlan ID> Entre en el modo de configuración de la interfaz.
ipv6 ospf bfd Habilite BFD en la interfaz especificada que utiliza OSPFv3.

Configuración de ejemplo:

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan15

    ns(config-if)# ipv6 ospf bfd

    ns(config-if)# exit

Configuración de la detección de reenvío bidireccional