Citrix ADC

Compatibilidad con Anycast en Citrix ADC

Anycast es un tipo de red donde un conjunto de servidores comparte una dirección IP. La solicitud del cliente se dirige al servidor topográficamente más cercano en función de sus tablas de redirección. Esta redirección reduce los problemas de latencia, garantiza una alta disponibilidad y minimiza el tiempo de inactividad.

Citrix ADC admite la red Anycast con funciones de equilibrio de carga global de servidores (GSLB) y DNS.

El siguiente diagrama ilustra un diagrama de topología de Anycast en Citrix ADC.

Topología Anycast

Anycast GSLB Negro

La función Citrix ADC GSLB proporciona equilibrio de carga entre sitios distribuidos globalmente junto con recuperación ante desastres y garantiza la disponibilidad continua de las aplicaciones.

Durante una interrupción, GSLB proporciona recuperación ante desastres inmediata al enrutar el tráfico al centro de datos más cercano o al mejor rendimiento. Sin embargo, GSLB no puede controlar lo siguiente:

  • Cómo se enruta el tráfico DNS a nodos GSLB en diferentes ubicaciones geográficas.
  • Cuánta latencia se agrega mientras las consultas DNS se enrutan a los nodos GSLB.

En una configuración típica de GSLB, cada centro de datos tiene un nodo GSLB configurado con el servidor de nombres de dominio autoritativo (ADNS) específico del sitio para recibir consultas DNS. El ADNS de cada sitio está configurado como servidor de nombres en el solucionador DNS. A medida que aumenta el número de nodos GSLB, el número de registros del servidor de nombres también aumenta. En tales casos, si hay una falla de un centro de datos, LDNS tiene que volver a intentar la resolución con un servidor de nombres diferente. Este reintento se agrega a la latencia en la resolución DNS. Además, cada vez que se agrega un nodo GSLB, se deben actualizar los registros del servidor de nombres.

Para superar estos inconvenientes, puede usar Anycast ADNS. En Anycast ADNS, se utiliza una única dirección IP ADNS para todos los nodos GSLB y el tráfico DNS se enruta a nodos GSLB mediante redirección dinámica.

Por ejemplo, si un sitio GSLB está DESCONECTADO, la tabla de redirección se actualiza y se quita la ruta a este sitio. Como resultado, Las consultas DNS no se envían a los sitios que están ABAJO. Como resultado, no hay reintentos.

Si se agrega un nuevo nodo GSLB, al nuevo nodo se le asigna la misma dirección IP de ADN. El redirección dinámica actualiza automáticamente las tablas de redirección con rutas a nuevos sitios basados en los algoritmos de redirección. Por lo tanto, no es necesario actualizar los registros del servidor de nombres DNS. El implementación de nuevos sitios GSLB se hace más simple y más rápido con Anycast.

Cómo configurar una dirección IP de ADNS en modo Anycast

Habilite la redirección de host en la IP de ADNS en un dispositivo Citrix ADC y establezca el nivel adecuado de inyección de estado de ruta (RHI). Principalmente, no habría ningún servidor virtual en la IP de ADNS y, por lo tanto, el nivel RHI debe seleccionarse como NONE. Al habilitar la ruta del host en la IP de ADNS, se convierte en una ruta del kernel. A continuación, puede habilitar la redirección dinámica de elección y configurar el protocolo de redirección para redistribuir las rutas del núcleo.

Configuración IP de ADNS: Ejemplo

En el símbolo del sistema, escriba;

add service adns_public 5.5.5.5 ADNS 53

set ip 5.5.5.5 -hostRoute ENABLED -vserverRHILevel ALL_VSERVERS
<!--NeedCopy-->

Configuración de BGP en el sitio GSLB: Ejemplo

Site1#sh run
!
hostname Site1
!
log syslog
log record-priority
!
ns route-install bgp
!
interface lo0
 ip address 127.0.0.1/8
 ipv6 address fe80::1/64
 ipv6 address ::1/128
!
interface vlan0
 ip address 10.102.148.94/25
 ipv6 address fe80::e84c:f4ff:fe74:4588/64
!
interface vlan2
 ip address 172.18.30.15/24
!
router bgp 5
 redistribute kernel -----> redistributing the kernel routes
 neighbor 172.18.30.30 remote-as 4
 neighbor 172.18.30.30 advertisement-interval 1
 neighbor 172.18.30.30 timers 4 16
!
End

Site1#
<!--NeedCopy-->

Tabla de redirección de sitios GSLB: Ejemplo

Site1#sh ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
       O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, I - Intranet
       * - candidate default

K       5.5.5.5/32 via 0.0.0.0 ---------------------------------------> Kernel Route for ADNS
C       10.102.148.0/25 is directly connected, vlan0
C       127.0.0.0/8 is directly connected, lo0
B       172.18.10.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       172.18.20.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
C       172.18.30.0/24 is directly connected, vlan2
B       192.168.3.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       192.168.5.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       192.168.10.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h

Gateway of last resort is not set
Site1#
<!--NeedCopy-->

DNS Anycast

Puede usar Anycast DNS para servidores virtuales proxy DNS en Citrix ADC. Cuando hay varios servidores de nombres DNS configurados, el solucionador DNS responde en función del método round robin. Por ejemplo, si el solucionador no recibe ninguna respuesta del primer servidor, cambia al segundo servidor después de que caduque el valor de tiempo de espera configurado. El cambio del primer servidor al segundo servidor aumenta la latencia en la resolución DNS. Si los resolvers DNS están configurados con Anycast, entonces esta latencia se puede eliminar.

Configuración DNS: Ejemplo

En el símbolo del sistema, escriba;

add lb vserver dns DNS 5.5.5.50 53

set ip 5.5.5.50 -hostRoute ENABLED -vserverRHILevel ALL_VSERVERS
<!--NeedCopy-->
Compatibilidad con Anycast en Citrix ADC