Citrix Gateway

Requisitos de software cliente

Citrix Gateway admite las conexiones de los usuarios mediante el agente de Citrix Secure Access. Cuando los usuarios inician sesión con el complemento, se establece un túnel VPN completo. Con el agente de Citrix Secure Access, los usuarios pueden conectarse a los recursos de red a los que permite el acceso.

Si las directivas de endpoint están configuradas en Citrix Gateway, Citrix Gateway descarga e instala el complemento Endpoint Analysis en el dispositivo del usuario automáticamente cuando los usuarios inician sesión.

Requisitos del sistema del agente de Citrix Secure Access

El agente Citrix Secure Access establece una conexión segura desde la máquina cliente al dispositivo Citrix Gateway.

El complemento se distribuye como aplicación de escritorio para los sistemas operativos Microsoft Windows, macOS X y Linux. Después de autenticarse en la URL segura del dispositivo Citrix Gateway con el explorador web, el complemento se descarga e instala automáticamente en el equipo.

El plug-in se aprovisiona como aplicación móvil para dispositivos Android e iOS.

Nota:

  • Para instalar el plug-in, se necesitan privilegios de administrador y root en el sistema operativo.

  • Los exploradores que admiten el agente de Citrix Secure Access también admiten VPN sin cliente.

El agente Citrix Secure Access como aplicación de escritorio es compatible con los siguientes sistemas operativos y exploradores web.

Sistema operativo Exploradores Web compatibles
macOS X (10.9 y posteriores) Safari 7.1 o posterior; Google Chrome versión 30 o posterior; Mozilla Firefox versión 30 o posterior
Windows 11 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows 10 (x86 y x64) Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows 8.1 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows 8 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Linux; Ubuntu 18.04 LTS, 16.04 LTS, 14.04 LTS y 12.04 LTS. Se admite SO de 32 y 64 bits. Mozilla Firefox versión 44 y superior; Google Chrome 50 y superior

Importante: Debido a un error (1573408) en Ubuntu 16.04 LTS, la instalación del complemento VPN falla. La solución alternativa para el mismo se muestra a continuación.

Escriba el siguiente comando mediante la interfaz de línea de comandos:

sudo dpkg -i nsgclient*.deb
<!--NeedCopy-->

Si faltan los paquetes de dependencias necesarios, el comando los enumera y se produce un error en la instalación del complemento. Estos paquetes de dependencias se deben instalar manualmente. Los administradores pueden instalar un paquete que falta escribiendo el siguiente comando mediante la interfaz de línea de comandos.

apt-get install <dependency package>
<!--NeedCopy-->

El agente Citrix Secure Access como aplicación móvil es compatible con los siguientes sistemas operativos.

Aplicación VPN Sistemas operativos compatibles
Android Android 7.0 y versiones posteriores
iOS iOS 12.0 y versiones posteriores

requisitos de Endpoint Analysis

Citrix Gateway instala el complemento Endpoint Analysis en el dispositivo del usuario. El complemento Endpoint Analysis explora el dispositivo del usuario en busca de los requisitos de seguridad de dispositivos de punto final que ha configurado en Citrix Gateway. Los requisitos incluyen información, como el sistema operativo, el antivirus o las versiones del explorador web.

Cuando los usuarios de Windows se conectan a Citrix Gateway mediante el explorador por primera vez, el portal solicita la instalación del complemento Endpoint Analysis. En los siguientes intentos de inicio de sesión, el complemento comprueba la configuración del control de actualización para comprobar si es necesaria la actualización del complemento de análisis de endpoint del cliente. Si es necesario, el usuario recibe una solicitud para descargar e instalar el nuevo complemento Endpoint Analysis. El complemento Endpoint Analysis para Windows se instala como una aplicación Windows de 32 bits. No se necesitan privilegios especiales para instalarlo o utilizarlo.

Para macOS, el usuario debe instalar el complemento Endpoint Analysis. El complemento para macOS se instala como una aplicación de 64 bits. No se necesitan privilegios especiales para instalarlo. En los siguientes intentos de inicio de sesión, si las versiones del complemento no coinciden, se solicita al usuario que descargue e instale el complemento.

La información sobre herramientas de la consola de la interfaz de usuario de administración explica los análisis en detalle. Para obtener más información sobre las bibliotecas de la EPA, consulte https://www.citrix.com/en-in/downloads/citrix-gateway/epa-libraries/.

Importante:

  • Los exploradores compatibles con EPA también admiten VPN sin cliente.

  • En el análisis de endpoint previo a la autenticación, el usuario no puede iniciar sesión con el agente de Citrix Secure Access si el usuario no instala el complemento de Endpoint Analysis u omite la exploración.

  • En el análisis de endpoint posterior a la autenticación, el usuario puede acceder a los recursos para los que no es necesario realizar un análisis mediante el acceso sin cliente o mediante la aplicación Citrix Workspace.

  • Para los análisis relacionados con OPSWAT, debe instalar el paquete binario epaPackage.exe en el equipo cliente.

Se necesita el siguiente software en los dispositivos de usuario para utilizar el complemento Endpoint Analysis:

Sistema operativo Exploradores Web compatibles
macOS (10.9 y posteriores) Safari 7.1 o posterior; Google Chrome versión 30 o posterior; Mozilla Firefox versión 30 o posterior
Windows 11 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows 10 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows 8.1 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows 8 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows 7 Versión 30 de Google Chrome o una posterior; versión 24 de Mozilla Firefox o una posterior; Edge Chromium
Windows Vista Versiones 9 y 10 de Mozilla Firefox
Linux; Ubuntu 12.04 LTS, 14.04 LTS, 16.04 LTS y 18.04 LTS. Se admiten sistemas operativos de 32 bits y 64 bits. Se admiten sistemas operativos de 32 bits y 64 bits. Mozilla Firefox versión 44 y posteriores; Google Chrome 50 y versiones posteriores

Nota:

  • Todas las ediciones de las variantes del sistema operativo mencionadas anteriormente son compatibles.

  • Para las ediciones de Windows, se deben instalar todos los service packs y las actualizaciones críticas.

  • Para las versiones de Mozilla Firefox, Endpoint Analysis debe tener habilitado el complemento La versión mínima requerida es 3.0.

Requisitos de software cliente