Configuración de un router

Para admitir el modo en línea virtual, un router debe reenviar el tráfico WAN entrante y saliente al dispositivo SD-WAN. Una vez que el dispositivo procesa el tráfico, el enrutador debe reenviar el tráfico entrante desde el dispositivo a la LAN y el tráfico saliente desde el dispositivo a la WAN. Debe configurar reglas basadas en directivas para evitar bucles de enrutamiento. Además, el enrutador debe supervisar el estado del dispositivo para que se pueda omitir el dispositivo si falla.

Si el enrutador admite la función Reenvío de ruta inversa, debe inhabilitarla en las interfaces con directivas para redirigir el tráfico a un dispositivo SD-WAN, incluida la interfaz que está conectada al dispositivo. De lo contrario, el enrutador interrumpe el tráfico. De forma predeterminada, la función Reverse Path Forwarding está habilitada en el router.

Nota: Si la red tiene dos enrutadores, configure los siguientes procedimientos para cada enrutador utilizando las direcciones IP apropiadas identificadas en la hoja de cálculo.

Reglas basadas en políticas

En el modo virtual en línea, los métodos de reenvío de paquetes pueden crear bucles de enrutamiento si las reglas de enrutamiento no distinguen entre un paquete que ha sido reenviado por el dispositivo y otro que no lo ha hecho. Puede usar cualquier método que haga esa distinción.

Un método típico consiste en dedicar uno de los puertos Ethernet del router al dispositivo y crear reglas de enrutamiento basadas en el puerto Ethernet al que llegan los paquetes. Los paquetes que llegan a la interfaz dedicada al dispositivo nunca se reenvían al dispositivo, pero pueden serlo los paquetes que llegan a cualquier otra interfaz.

El modelado del tráfico no es efectivo a menos que todo el tráfico WAN pase a través del dispositivo. A continuación se presenta el algoritmo de enrutamiento básico:

  • No reenvíe paquetes desde el dispositivo al dispositivo.
  • Si el paquete llega de la WAN, reenvíe el paquete al dispositivo.
  • Si el paquete está destinado a la WAN, reenvíe el paquete al dispositivo.
  • No reenvíe el tráfico de LAN a LAN al dispositivo.

Supervisión de estado

Si el dispositivo falla, los datos no se deben enrutar a él. De forma predeterminada, el enrutamiento basado en políticas de Cisco no realiza la supervisión del estado. Para habilitar la supervisión del estado, defina una regla para supervisar la disponibilidad del dispositivo y especifique la opción verify-availability para el comando set ip next-hop. Con esta configuración, si el dispositivo no está disponible, no se aplica la ruta y se omite el dispositivo.

Nota: Citrix recomienda el modo virtual en línea solo cuando se utiliza con supervisión de estado. Muchos enrutadores que admiten enrutamiento basado en políticas no admiten la comprobación de estado. La función de supervisión de la salud es relativamente nueva. Estaba disponible por primera vez en la versión 12.3(4)T de Cisco IOS.

A continuación se muestra un ejemplo de una regla para supervisar la disponibilidad del dispositivo mediante el Cisco Router modelo 7600 con la versión del software IOS:

``` pre codeblock !- Use a ping (ICMP echo) to see if appliance is in the connected track 123 rtr 1 reachability ! rtr 1 type echo protocol IpIcmpecho 17.17.17.2 schedule 1 life forever start-time now


Esta regla hace ping al dispositivo en 17.17.17.2 periódicamente. Puede probar con 123 para ver si la unidad está arriba.

## Ejemplo de configuración del router

A continuación se muestra un ejemplo de configuración de un router Cisco para el modo en línea virtual:

``` pre codeblock
!
! For health-checking to work, do not forget to start
! the monitoring process.
!
! Original configuration is in normal type.
! appliance-specific configuration is in bold.
!
ip cef
!
interface FastEthernet0/0
ip address 10.200.51.0   255.255.255.0
ip policy route-map server_side_map
!
interface FastEthernet0/1
ip address 17.17.17.1   255.255.255.0!
interface FastEthernet1/0
ip address 192.168.1.5 255.255.255.0
ip policy route-map wan_side_map
!
ip classless
ip route 0.0.0.0 0.0.0.0 171.68.1.1
!
ip access-list extended server_side
permit ip 10.100.51.0 0.0.0.255 10.20.20.0 0.0.0.255
ip access-list extended wan_side
permit ip 10.20.20.0 0.0.0.255 10.100.51.0 0.0.0.255
!
route-map wan_side_map permit 20
match ip address wan_side
!-  Now set the appliance as the next hop, if it’s up.
set ip next-hop verify-availability 17.17.17.1   20 track 123
!
route-map client_side_map permit 10
match ip address client_side
set ip next-hop verify-availability 17.17.17.1   10 track 123

En este ejemplo se aplica una lista de acceso a un mapa de ruta y se adjunta el mapa de ruta a una interfaz. Las listas de acceso identifican todo el tráfico que se origina en un sitio acelerado y termina en el otro (dirección IP de origen 10.100.51.0/24 y dirección IP de destino 10.20.20.0/24 o viceversa). Consulte la documentación de su router para obtener los detalles de las listas de acceso y los mapas de rutas.

Esta configuración redirige todo el tráfico IP correspondiente a los dispositivos. Si desea redirigir solo el tráfico TCP, puede cambiar la configuración de la lista de acceso de la siguiente manera (solo se muestra la configuración del lado remoto):

pre codeblock ! ip access-list extended server_side permit tcp 10.200.51.0 0.0.0.255 10.20.20.0 0.0.0.255 ip access-list extended wan_side permit tcp 10.20.20.0 0.0.0.255 10.200.51.0 0.0.0.255 !

Configuración de enrutadores en una instalación de alta disponibilidad

Para configurar la alta disponibilidad entre enrutadores, consulte el manual de configuración de alta disponibilidad específico del enrutador.