Product Documentation

Requisitos del sistema para XenDesktop 7.1

Nov 18, 2015

En este tema se enumeran los sistemas compatibles para el Delivery Controller, Citrix Studio, Citrix Director y los agentes Virtual Delivery Agents (VDA) en el momento de la publicación de esta versión de XenDesktop.

Los requisitos del sistema para otras funciones y componentes, como, por ejemplo, StoreFront, sistemas host, HDX, Receivers y plug-ins, Desktop Lock y Provisioning Services se describen en su respectiva documentación.

A menos que se indique lo contrario, el programa de instalación instala automáticamente los requisitos previos de los componentes. Esto incluye .NET 3.5 SP1, que es necesario para instalar los componentes en sistemas Windows 7 o Windows Server 2008 R2.

Los medios de instalación contienen varios componentes de terceros. Antes de usar el software de Citrix, busque actualizaciones para los componentes de terceros e instálelas.

Si instala todos los componentes principales (Controller, Studio, Director, StoreFront y Licensing) en un único servidor, necesita un mínimo de 3 GB de RAM para evaluar el producto; se recomiendan más cuando se ejecuta un entorno para los usuarios. El rendimiento variará según sus parámetros exactos, incluidos el número de usuarios, aplicaciones, escritorios y otros factores.

Delivery Controller

Sistemas operativos respaldados:
  • Windows Server 2012 R2, Standard y Datacenter Edition.
  • Windows Server 2012, Standard y Datacenter Edition.
  • Windows Server 2008 R2 SP1, Standard, Enterprise y Datacenter Edition.
Requisitos:
  • Espacio en disco: 100 MB.
  • Microsoft .NET Framework 3.5.1 (requerido solo en Windows Server 2008 R2).
  • Microsoft .NET 4.0.
  • Windows PowerShell 2.0 (incluido con Windows Server 2008 R2) o 3.0 (incluido con Windows Server 2012 R2 y Windows Server 2012).
  • Visual C++ 2005, 2008 SP1 y los 2010 Redistributable Packages. El programa de instalación los instala automáticamente. También están disponibles en los medios de instalación de Citrix, en la carpeta Support.

Base de datos

Las versiones de Microsoft SQL Server respaldadas para la base de datos de configuración de sitios (que inicialmente incluye la base de datos de registros de configuración y la base de datos de supervisión) son:
  • SQL Server 2012 SP1, Express, Standard y Enterprise Edition. De forma predeterminada, SQL Server 2012 Express se instala al mismo tiempo que se instala Controller.
  • SQL Server 2008 R2 SP2, Express, Standard, Enterprise y Datacenter Edition.
Son compatibles las siguientes funciones de base de datos (excepto en SQL Server Express Edition, que solo es compatible con el modo autónomo).
  • Instancias en clúster de SQL Server.
  • Creaciones de reflejos de SQL Server.
  • Grupos de disponibilidad de AlwaysOn de SQL Server 2012.

Se requiere autenticación de Windows para las conexiones entre el Controller y la base de datos de SQL Server.

Para obtener información sobre las versiones de base de datos compatibles, consulte CTX114501.

Studio

Sistemas operativos respaldados:
  • Windows 8.1, Professional y Enterprise Edition.
  • Windows 8, Professional y Enterprise Edition.
  • Windows 7 Professional, Enterprise y Ultimate Edition.
  • Windows Server 2012 R2, Standard y Datacenter Edition.
  • Windows Server 2012, Standard y Datacenter Edition.
  • Windows Server 2008 R2 SP1, Standard, Enterprise y Datacenter Edition.
Requisitos:
  • Espacio en disco: 75 MB.
  • Microsoft .NET Framework 3.5 SP1 (obligatorio solo en Windows Server 2008 R2).
  • Microsoft Management Console 3.0 (incluido con todos los sistemas operativos compatibles).
  • Windows PowerShell 2.0 (incluido con Windows 7 y Windows Server 2008 R2) o 3.0 (incluido con Windows 8.1, Windows 8, Windows Server 2012 R2 y Windows Server 2012).

Director

Sistemas operativos respaldados:
  • Windows Server 2012 R2, Standard y Datacenter Edition.
  • Windows Server 2012, Standard y Datacenter Edition.
  • Windows Server 2008 R2 SP1, Standard, Enterprise y Datacenter Edition.
Requisitos:
  • Espacio en disco: 50 MB.
  • Microsoft .NET Framework 4.0. El programa de instalación lo instala automáticamente. También está disponible en los medios de instalación de Citrix, en la carpeta Support\DotNet4.
  • Microsoft Internet Information Services (IIS) 7.0 y ASP.NET 2.0. Si estos componentes aún no están instalados, se le solicitará que introduzca los medios de instalación de Windows Server y, a continuación, se instalarán.
  • Exploradores compatibles para ver Director:
    • Internet Explorer 9 - 11 (no se admite el modo de compatibilidad de Internet Explorer 10)

      Para Internet Explorer 10, no se admite el modo de compatibilidad. Debe usar la configuración recomendada del explorador; en caso contrario, no podrá acceder a Director. Al instalar Internet Explorer 10, acepte el valor predeterminado para usar la configuración de compatibilidad y seguridad recomendada. Si ya ha instalado el explorador y eligió no usar la configuración recomendada, vaya a Herramientas > Opciones de Internet > Opciones avanzadas > Restablecer, y siga las instrucciones.

    • Firefox
    • Chrome

Virtual Delivery Agent (VDA) para sistemas operativos de escritorio Windows

Sistemas operativos respaldados:
  • Windows 8.1, Professional y Enterprise Edition.
  • Windows 8, Professional y Enterprise Edition.
  • Windows 7 SP1, Professional, Enterprise y Ultimate Edition.
El instalador implementa automáticamente los siguientes requisitos, que también están disponibles en las carpetas Support de los medios de instalación de Citrix:
  • (Solo para sistemas Windows 7). Microsoft .NET Framework 3.5.1: Si utiliza la interfaz de línea de comandos, debe instalar esto manualmente antes de instalar el VDA.
  • Microsoft .NET Framework 4.0.
  • Microsoft Visual C++ 2010 Runtime (de 32 o 64 bits, según la plataforma).

El acceso con Remote PC usa este VDA, que se instala en equipos físicos de oficina.

Algunas funciones de aceleración multimedia (como, por ejemplo, la redirección de Windows Media de HDX MediaStream) requieren que Microsoft Media Foundation esté instalado en la máquina donde desea instalar el VDA. Si la máquina no tiene instalado Media Foundation, las funciones de aceleración multimedia no se instalarán y no funcionarán. No quite Media Foundation de la máquina después de instalar el software de Citrix; de lo contrario, los usuarios no podrán iniciar sesión en ella. En la mayoría de ediciones de Windows 7, Windows 8 y Windows 8.1, la compatibilidad para Media Foundation ya está instalada y no se puede quitar. Sin embargo, las ediciones N no incluyen ciertas tecnologías relacionadas con elementos multimedia, pero se puede obtener el software de Microsoft o de un tercero.

No puede instalar un VDA suministrado con XenDesktop 7.1 en una máquina con Windows XP o Windows Vista; no obstante, sí que puede instalar una versión anterior de Virtual Desktop Agent en estos sistemas operativos, si fuera necesario. Para obtener más información, consulte las instrucciones de instalación de una versión anterior de VDA en esos sistemas operativos. La versión de acceso con Remote PC proporcionada con esta versión no se admite en sistemas operativos de Windows Vista.

Virtual Delivery Agent (VDA) para sistemas operativos de servidor Windows

Sistemas operativos respaldados:
  • Windows Server 2012 R2, Standard y Datacenter Edition.
  • Windows Server 2012, Standard y Datacenter Edition.
  • Windows Server 2008 R2 SP1, Standard, Enterprise y Datacenter Edition.
El instalador implementa automáticamente los siguientes requisitos, que también están disponibles en las carpetas Support de los medios de instalación de Citrix:
  • (Solo para sistemas Windows 2008 R2). Microsoft .NET Framework 3.5.1: Si utiliza la interfaz de línea de comandos, debe instalar esto manualmente antes de instalar el VDA.
  • Microsoft .NET Framework 4.0.
  • Bibliotecas de tiempo de ejecución de Microsoft Visual C++ 2005, 2008 y 2010 (de 32 y 64 bits).

El instalador automáticamente instala y habilita los servicios de rol de los Servicios de Escritorio remoto si aún no están instalados y habilitados.

Algunas funciones de aceleración multimedia (como, por ejemplo, la redirección de Windows Media de HDX MediaStream) requieren que Microsoft Media Foundation esté instalado en la máquina donde desea instalar el VDA. Si la máquina no tiene instalado Media Foundation, las funciones de aceleración multimedia no se instalarán y no funcionarán. No quite Media Foundation de la máquina después de instalar el software de Citrix; de lo contrario, los usuarios no podrán iniciar sesión en ella. En la mayoría de las ediciones de Windows Server 2012 R2, Windows Server 2012 y Windows Server 2008 R2, la función de Media Foundation se instala con el Administrador de servidores (para Windows Server 2012 R2 y Windows Server 2012: ServerMediaFoundation; para Windows Server 2008 R2: DesktopExperience). Sin embargo, las ediciones N no incluyen ciertas tecnologías relacionadas con elementos multimedia, pero se puede obtener el software de Microsoft o de un tercero.

El servicio de Cola de impresión está habilitado de forma predeterminada en el servidor de Windows. Si inhabilita este servicio, no podrá instalar correctamente un VDA para los sistemas operativos de servidor Windows. Por lo tanto, asegúrese de que este servicio esté habilitado antes de instalar un VDA.

Host

Plataformas respaldadas:
  • XenServer.
    • XenServer 6.2
    • XenServer 6.1
    • XenServer 6.0.2
  • VMware vSphere. No se ofrece respaldo para la operación "Linked Mode" de vSphere vCenter.
    • VMware vSphere 5.1 Update 3
    • VMware vSphere 5.1 Update 2
    • VMware vSphere 5.1 Update 1
    • VMware vSphere 5.0 Update 3
    • VMware vSphere 5.0 Update 2
  • System Center Virtual Machine Manager. Incluye cualquier versión de Hyper-V que se pueda registrar con las versiones compatibles de System Center Virtual Machine Manager.
    • System Center Virtual Machine Manager 2012 R2
    • System Center Virtual Machine Manager 2012 SP1
    • System Center Virtual Machine Manager 2012

Consulte la documentación de la plataforma para ver los requisitos del sistema. Consulte CTX131239 si desea información actualizada de asistencia de hipervisores.

Las siguientes combinaciones de tecnologías de alojamiento y almacenamiento están respaldadas para Machine Creation Services y la inyección de cuentas de Active Directory en tiempo de ejecución en máquinas virtuales. Se recomiendan las combinaciones marcadas con un asterisco (*).
HostDiscos localesNFSAlmacenamiento en bloque (Block Storage)StorageLink
XenServerSí*No
VMware ESXSí (no hay vMotion ni ubicación dinámica)Sí*No
Hyper-VNoSí* (requiere los volúmenes compartidos de clúster)No

Otros

  • StoreFront requiere 2 GB de memoria. Consulte la documentación de StoreFront para obtener todos los requisitos del sistema. StoreFront 2.0 es la versión mínima compatible con esta versión de XenDesktop.
  • Solo se admite el servidor de licencias de Citrix para Windows. La versión mínima compatible es 11.11. El servidor de licencias de Citrix necesita 40 MB de espacio en disco. Consulte la documentación sobre el sistema de licencias para ver todos los requisitos del sistema.
  • Sistemas operativos respaldados con Universal Print Server (el Controller incluye la funcionalidad Universal Print Server; solo necesita instalarlo en los servidores de impresión):
    • Windows Server 2008 R2 SP1
    • Windows Server 2008 de 32 bits
  • La Consola de administración de directivas de grupo (GPMC) de Microsoft es necesaria si desea almacenar la información sobre directivas de Citrix en Active Directory en lugar de la base de datos de configuración de sitios. Para más información, consulte la documentación de Microsoft.
  • Puede instalar Receiver para Windows al instalar un VDA suministrado en los medios de instalación de XenDesktop. Para obtener información sobre los requisitos del sistema para otras plataformas, consulte la documentación de Receiver para Windows.
  • Receiver para Linux y Receiver para Mac se incluyen en los medios de instalación de XenDesktop. Consulte la documentación para ver los requisitos del sistema.
  • Al usar los servicios Provisioning Services con esta versión de XenDesktop, la versión mínima compatible de Provisioning Services es la versión 7.0.
  • Cuando se utilizan versiones de Access Gateway anteriores a 10.0 con esta versión de XenDesktop, no se respaldan los clientes de Windows 8.1 y Windows 8.