Citrix ADC

Routage dans un cluster

Le routage dans un cluster fonctionne de la même manière que le routage dans un système autonome. Quelques points à noter :

  • Toutes les configurations de routage doivent être effectuées à partir de l’adresse IP du cluster et les configurations sont propagées aux autres nœuds du cluster.

  • Les routes sont limitées au nombre maximal de routes ECMP prises en charge par le routeur amont.

  • Les configurations de routage spécifiques au nœud doivent être effectuées à l’aide de l’argument du nœud propriétaire comme suit :

  router ospf
    owner-node 0
      ospf router-id 97.131.0.1
    exit-owner-node
  !

La commande suivante affiche la configuration du cluster consolidé pour tous les nœuds de VTYSH.

show cluster-config

La commande suivante affiche l’état du cluster sur chaque nœud.

show cluser node

Routage IPv4 dans le cluster L2

La section suivante contient des exemples de configurations qui vous aident à configurer le routage IPv4 OSPF et BGP dans le cluster L2.

Ajout d’une adresse SNIP spotted et activation du routage dynamique

Dans la configuration suivante, le routage OSPF et BGP sont activés. En outre, les adresses SNIP spotted sont ajoutées et le routage dynamique est activé sur ces adresses SNIP.

en ns fea ospf bgp
add vlan 10
add ns ip 10.10.10.1 255.255.255.0 -dynamicrouting enabled -ownernode 1
add ns ip 10.10.10.2 255.255.255.0 -dynamicrouting enabled -ownernode 2
add ns ip 10.10.10.3 255.255.255.0 -dynamicrouting enabled -ownernode 3
bind vlan 10 -ipaddress 10.10.10.1 255.255.255.0

Configuration VTYSH IPv4 OSPF

Pour configurer IPv4 OSPF dans le cluster L2, vous devez

  • Définir la priorité sur zéro.
  • Configurez l’ID du routeur en tant que configuration spotted.

Remarque

Les instructions de configuration OSPF pour le cluster L2 sont également applicables pour OSPFv3.

Dans l’exemple de configuration suivant, IPv4 OSPF est configuré.

      interface vlan10
       IP OSPF PRIORITY 0
       !
      router ospf
          owner-node 1
            ospf router-id 97.131.0.1
          exit-owner-node
          owner-node 2
            ospf router-id 97.131.0.2
          exit-owner-node
          owner-node 3
            ospf router-id 97.131.0.3
          exit-owner-node
      network 10.10.10.0/24 area 0
      redistribute kernel
       !

Configuration de VTYSH IPv4 BGP

Dans l’exemple de configuration VTYSH suivant, IPv4 BGP est configuré.

    router bgp 100
      neighbor 10.10.10.10 remote-as 200
     owner-node 1
      neighbor 10.10.10.10 update-source 10.10.10.1
     exit-owner-node
     owner-node 2
      neighbor 10.10.10.10 update-source 10.10.10.2
     exit-owner-node
     owner-node 3
      neighbor 10.10.10.10 update-source 10.10.10.3
     exit-owner-node
    redistribute kernel
    !

Remarque

La commande update-source est utilisée pour chaque voisin avec l’argument de nœud propriétaire dans la configuration suivante pour se connecter à l’adresse IP source appropriée.

Routage IPv6 dans le cluster L2

La section suivante contient des exemples de configurations qui vous aident à configurer le routage IPv6 OSPF et BGP dans le cluster L2.

Activer le routage IPv6

Avant de configurer le routage IPv6 dans un cluster L2, vous devez activer la fonction IPv6.

Pour activer le routage IPv6 à l’aide de la CLI,

À l’invite de commandes, tapez :

  • enable ns fea ipv6pt

Ajout d’une adresse SNIP6 spotted et activation du routage dynamique

Dans la configuration suivante, le routage OSPF et BGP sont activés. En outre, les adresses SNIP6 spotted sont ajoutées et le routage dynamique est activé sur ces adresses SNIP6.

add ns ip6 3ffa::1/64 -dynamicrouting enabled -ownernode 1
add ns ip6 3ffa::2/64 -dynamicrouting enabled -ownernode 2
add ns ip6 3ffa::3/64 -dynamicrouting enabled -ownernode 3
add vlan 10
bind vlan 10 -ipaddress 3ffa::1/64

Configuration de VTYSH IPv6 BGP

Dans l’exemple de configuration VTYSH suivant, IPv6 BGP est configuré.

  router bgp 100
   neighbor 3ffa::10 remote-as 200
     owner-node 1
      neighbor 3ffa::10 update-source 3ffa::1
     exit-owner-node
     owner-node-2
      neighbor 3ffa::10 update-source 3ffa::2
     exit-owner-node
     owner-node-3
      neighbor 3ffa::10 update-source 3ffa::3
     exit-owner-node
   no neighbor 3ffa::10 activate
   address-family ipv6
    redistribute kernel
    neighbor 3ffa::10 activate
   exit-address-family
  !

Installer les itinéraires appris IPv6

Le cluster Citrix ADC peut utiliser des routes apprises par divers protocoles de routage après avoir installé les routes dans la table de routage de cluster Citrix ADC.

Pour installer des routes apprises IPv6 vers la table de routage interne à l’aide de l’interface de ligne de commande :

À l’invite de commandes, tapez :

  • ns route-install ipv6 bgp

  • ns route-install ipv6 ospf

  • ns route-install default

Remarque

  • Si vous devez échanger des routes IPv4 sur un voisin IPv6, vous devez supprimer la commande VTYSH no neighbor 3ffa::10 active de la configuration antérieure.

  • La commande VTYSH update-source doit être utilisée pour chaque nœud propriétaire afin de spécifier l’IP source IPv6 correcte lors de la connexion à l’homologue BGP comme indiqué dans la configuration IPv4 de BPG.

Routage dans un cluster L3

Le routage dans le cluster L3 fonctionne uniquement lorsque les configurations suivantes sont effectuées sur l’appliance Citrix ADC.

  • Activez le routage dynamique pour un VLAN.

     set vlan <id> -dynamicrouting enabled
    
  • Pour atteindre tous les nœuds de cluster, le VIP, CLIP et Citrix ADC IP (NSIP) doivent être annoncés par des protocoles de routage accompagnés de la commande set vlan.

Scénario de déploiement pour BGP dans le cluster L3

Prenons un exemple où tous les nœuds de cluster sont regroupés dans le réseau AS 100, et les routeurs en amont sont dans différents AS 200.

La figure suivante illustre le déploiement AS 100 et AS 200 dans une configuration de cluster.

image localisée

Dans ce déploiement, CLIP annonce CCO aux routeurs en amont. Certains nœuds de cluster suppriment le trafic annoncé, car la boucle AS est détectée.

Pour résoudre le problème, configurez la commande suivante en mode routeur BGP vtysh pour chaque voisin.

À l’invite de commandes VTYSH, tapez :

neighbor <peer_ip> allowas-in 1

Citrix vous recommande de configurer l’un des éléments suivants :

  • Configurez des mapping d’itinéraire pour ne connaître que les réseaux souhaités, tels que l’itinéraire par défaut, l’IP Citrix ADC (NSIP) et les sous-réseaux NSIP sur les nœuds de cluster.

  • Configurez les routes en amont pour ne faire connaître que les réseaux souhaités tels que CLIP et Citrix ADC IP (NSIP) dans le cluster.

Routage dans un cluster