Citrix ADC

Agrégation de liens de cluster dynamique

Le canal LA de cluster dynamique utilise le protocole LACP (Link Aggregation Control Protocol).

Vous devez effectuer des configurations similaires sur l’adresse IP du cluster et sur le périphérique de connexion externe. Si possible, configurez le commutateur amont pour distribuer le trafic en fonction de l’adresse IP ou du port au lieu de l’adresse MAC.

Points à retenir :

  • Activez LACP (en spécifiant le mode LACP comme ACTIVE ou PASSIVE).

    Remarque

    Assurez-vous que le mode LACP n’est pas défini comme PASSIVE sur le cluster Citrix ADC et sur le périphérique de connexion externe.

  • Spécifiez la même clé LACP sur chaque interface que vous souhaitez faire partie du canal. Pour créer un canal LA de cluster, la clé LACP peut avoir une valeur comprise entre 5 et 8. Par exemple, si vous définissez la clé LACP sur les interfaces 0/1/2, 1/1/2 et 2/1/2 à 5, CLA/1 est créé. Les interfaces 0/1/2, 1/1/2 et 2/1/2 sont automatiquement liées à CLA/1. De même, si vous définissez la touche LACP sur 6, le canal CLA/2 est créé.

  • Spécifiez le type de LAG en tant que Cluster.

Pour configurer un canal LA de cluster dynamique à l’aide de l’interface de ligne de commande

Sur l’adresse IP du cluster, pour chaque interface que vous souhaitez ajouter au canal LA du cluster, tapez :

set interface <id> -lacpMode <lacpMode> -lacpKey <positive_integer> -lagType CLUSTER

Exemple :

Pour configurer un cluster CLA/1 canal LA sur 3 interfaces.

> set interface 0/1/2 -lacpMode active -lacpKey 5 -lagType Cluster
> set interface 1/1/2 -lacpMode active -lacpKey 5 -lagType Cluster
> set interface 2/1/2 -lacpMode active -lacpKey 5 -lagType Cluster

Remarque

Le cas échéant, vous pouvez activer Lier la redondance dans un cluster avec LACP.

De même, configurez LA dynamique sur le commutateur externe. Les exemples de configuration suivants sont fournis pour le Cisco® Nexus 7000 C7010 version 5.2 (1). Des configurations similaires doivent être effectuées sur d’autres commutateurs.

Configuration globale :
Configurer le terminal
feature lacp
Configuration au niveau de l'interface :

interface Ethernet2/47
switchport
switchport access vlan 10
channel-group 7 mode active
no shutdown

interface Ethernet2/48
switchport
switchport access vlan 10
channel-group 7 mode active
no shutdown

Agrégation de liens de cluster dynamique