Citrix ADC

Agrégation de liens de cluster statique

Vous devez configurer un canal LA de cluster statique sur l’adresse IP du cluster et sur le périphérique de connexion externe. Si possible, configurez le commutateur amont pour distribuer le trafic en fonction de l’adresse IP ou du port au lieu de l’adresse MAC.

Pour configurer un canal LA de cluster statique à l’aide de l’interface de ligne de commande

  1. Connectez-vous à l’adresse IP du cluster.

    Remarque

    Assurez-vous de configurer le canal LA du cluster sur l’adresse IP du cluster avant de configurer l’agrégation des liens sur le commutateur externe. Sinon, le commutateur transmet le trafic au cluster même si le canal LA du cluster n’est pas configuré. Cela peut entraîner une perte de trafic.

  2. Créez un canal LA de cluster.

    add channel <id> -speed <speed>```
    

    Exemple

    add channel CLA/1 -speed 1000
    

    Remarque

    Vous ne devez pas spécifier la vitesse comme AUTO. Vous devez plutôt spécifier explicitement la vitesse comme 10, 100, 1000 ou 10000. Seules les interfaces dont la vitesse correspond à l’attribut <speed> dans le canal LA du cluster sont ajoutées à la liste de distribution active.

  3. Liez les interfaces requises au canal LA du cluster. Assurez-vous que les interfaces ne sont pas utilisées pour le backplane du cluster.

    bind channel <id> <ifnum>
    

    Exemple

    bind channel CLA/1 0/1/2 1/1/2 2/1/2 \`\`\`
    
  4. Vérifiez les configurations.

    show channel <id>
    

    Exemple

    show channel CLA/1
    

    Remarque

    Vous pouvez lier le canal LA du cluster à un VLAN à l’aide de la commande bind vlan. Les interfaces du canal sont automatiquement liées au VLAN.

  5. Configurez LA statique sur le commutateur externe. Les exemples de configuration suivants sont fournis pour le Cisco® Nexus 7000 C7010 version 5.2 (1). Des configurations similaires doivent être effectuées sur d’autres commutateurs.

    Configuration globale :
    Configurer le terminal
    
    Configuration au niveau de l'interface :
    
    interface Ethernet2/47
    switchport
    switchport access vlan 10
    channel-group 7 mode on
    no shutdown
    
    interface Ethernet2/48
    switchport
    switchport access vlan 10
    channel-group 7 mode on
    no shutdown
    

Agrégation de liens de cluster statique