Citrix ADC

Configuration de la détection de transfert bidirectionnel

Le protocole BFD (Bidirectional Forwarding Detection) est un mécanisme de détection rapide des défaillances des chemins de transfert. BFD détecte les échecs de chemin dans l’ordre de millisecondes. BFD est utilisé avec des protocoles de routage dynamique.

En opération BFD, les homologues de routage échangent des paquets BFD à un intervalle négocié. Si un paquet n’est pas reçu d’un pair dans l’intervalle négocié plus l’intervalle de grâce, l’homologue est considéré comme mort et une notification sera envoyée à l’ensemble des protocoles de routage enregistrés. À leur tour, les protocoles de routage recalculent le meilleur chemin d’accès et reprogramment la table de routage. BFD prend en charge un intervalle de temps plus petit, par rapport aux minuteries fournies par les protocoles de routage, ce qui entraîne une détection plus rapide des défaillances.

L’appliance Citrix ADC prend en charge BFD pour les protocoles de routage suivants : BGP (IPv4 et IPv6), OSPFv2 (IPv4) et OSPFv3 (IPv6). La prise en charge BFD dans l’appliance Citrix ADC est conforme aux RFC 5880, 5881 et 5883.

Points à prendre en considération pour la configuration de la détection de transfert bidirectionnel

Avant de commencer à configurer BFD, tenez compte des points suivants :

  • Assurez-vous de bien comprendre les différents composants de BFD décrits dans les RFC 5880, 5881 et 5883.
  • Le BFD sur une appliance Citrix ADC est pris en charge pour les protocoles de routage suivants :
    • BGP (IPv4 et IPv6)
    • OSPFv2 (IPv4)
    • OSPFv3 (IPv6)
  • BFD sur un dispositif Citrix ADC n’est pas pris en charge pour les protocoles de routage suivants :
    • ISIS
    • RIP (IPv4)
    • Ripng (IPv6)
  • Les fonctionnalités BFD suivantes ne sont pas prises en charge sur un appliance Citrix ADC :
    • Mode Echo BFD
    • Authentification BFD
    • BFD Demander mode asynchrone
  • Les valeurs minimales pour l’intervalle BFD et les minuteurs BFD Rx sont de 100 millisecondes.
  • Lorsque BFD est utilisé dans une topologie avec des adresses IP partagées (par exemple, configuration haute disponibilité de couche 2 avec des adresses SNIP ou configuration de cluster avec des adresses IP par bandes), BFD réduit les sessions actives pendant un basculement car le temps de détection d’échec BFD (ordre de millisecondes) est inférieur à la valeur HA intervalle de détection de basculement (3 à 4 secondes). Par conséquent, Citrix recommande l’utilisation du redémarrage Graceful dans les topologies HA de couche 2 car les routes sont conservées pendant le processus de basculement.

Étapes de configuration

La configuration de BFD sur une appliance Citrix ADC comporte les tâches suivantes :

  • Configurer les paramètres BFD
  • Configurer la prise en charge BFD pour les protocoles de routage dynamique

Configurer les paramètres BFD

L’appliance Citrix ADC fournit des paramètres de session BFD distincts pour les sessions à saut unique, les sessions à saut multiple IPv4 et les sessions à saut multiple IPv6. Si vous ne configurez pas les paramètres BFD pour un type de session, les valeurs par défaut sont appliquées pour cette session.

La valeur par défaut de chaque paramètre BFD est identique pour les sessions de saut unique, les sessions de saut multiples IPv4 et les sessions de saut multiples IPv6. Le tableau suivant affiche la valeur par défaut de chaque paramètre BFD.

Nom du paramètre BFD Valeur par défaut
Intervalle 750 millisecondes
Rx minimum 500 millisecondes
Multiplicateur 3

IMPORTANT :

Les cartes réseau Mellanox d’une appliance Citrix prennent environ 1500 ms pour s’initialiser. Vous devez définir les minuteurs BFD sur plus de 1500 ms pour une appliance Citrix ADC avec cartes réseau Mellanox. Citrix recommande de définir les temporisateurs BFD sur 3000 ms :

  • Interval Tx = 600 ms
  • Minimum Rx = 600 ms
  • Multipler = 5

Configuration des paramètres BFD pour une session de saut unique

Pour configurer les paramètres BFD pour une session de saut unique à l’aide de la ligne de commande VTYSH, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrer en mode de configuration globale.
interface vlan ID> Entrer le mode de configuration de l’interface.
bfd singlehop-peer interval <num> minrx <num> multiplier <num> Configurer les paramètres BFD sur l’interface spécifiée.

Exemple de configuration :

> vtysh

ns# configure terminal

ns(config)# interface vlan3

ns(config-if)# bfd singlehop-peer interval 200 minrx 200 multiplier 5

ns(config-if)# exit

Configuration des paramètres BFD pour les sessions de saut multiples IPv4

Pour configurer les paramètres BFD pour les sessions de saut multiples IPv4 à l’aide de la ligne de commande VTYSH, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
bfd multihop-peer <ipv4addr> interval <num> minrx <num> multiplier <num> Configurez les paramètres BFD pour les sessions de sauts multiples IPv4.

Exemple de configuration :

    > vtysh

    ns# configure terminal

    ns(config)# bfd multihop-peer 20.20.20.138 interval 300 minrx 300 multiplier 5

    ns(config)# exit

Configuration des paramètres BFD pour les sessions de saut multiples IPv6

Pour configurer les paramètres BFD pour les sessions de saut multiples IPv6 à l’aide de la ligne de commande VTYSH, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
bfd multihop-peer ipv6 <ipv6addr> interval <num> minrx <num> multiplier <num> Configurez les paramètres BFD pour les sessions de plusieurs sauts IPv6.

Exemple de configuration :

    > vtysh

    ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

    ns(config)# exit

Configurer la prise en charge BFD pour les protocoles de routage dynamique

Vous pouvez activer BFD pour un protocole de routage dynamique pour un type de session avec un homologue. Par exemple, le houblon unique et le houblon multiple. L’appliance Citrix ADC applique les paramètres BFD pertinents à la session.

Configuration de BFD pour une session de saut unique BGP IPv4

Pour configurer BFD pour une session IPv4 BGP single hop à l’aide de la ligne deVTYSH commande, à l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
router bgp <asnumber> Système autonome BGP. asnumber est un paramètre obligatoire.
neighbor <ipv4addr> remote-as <num> Mettez à jour la table BGP IPv4 avec l’adresse IPv4 du voisin dans le système autonome spécifié.
neighbor <ipv4addr> fall-over bfd Activez BFD pour le voisin spécifié.

Exemple de configuration :

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Configuration de BFD pour une session de saut multiple BGP IPv4

Pour configurer BFD pour une session de saut multiple IPv4 BGP à l’aide de la ligne deVTYSH commande, à l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
router bgp <asnumber> Système autonome BGP. asnumber est un paramètre obligatoire.
neighbor <ipv4addr> remote-as <num> Mettez à jour la table BGP IPv4 avec l’adresse IPv4 du voisin dans le système autonome spécifié.
neighbor <ipv4addr> fall-over bfd multihop Activez BFD pour le voisin spécifié.

Exemple de configuration :

    > vtysh

    ns# configure terminal

    ns(config)#router bgp 1

    ns(config-router)#neighbor 20.20.20.138 remote-as 1

    ns(config-router)#neighbor 20.20.20.138 fall-over bfd multihop

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Configuration de BFD pour une session IPv6 BGP Single Hop

Pour configurer BFD pour une session IPv6 BGP single hop à l’aide de la ligne deVTYSH commande, à l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
router bgp <asnumber> Système autonome BGP. asnumber est un paramètre obligatoire.
neighbor <ipv6addr> remote-as <num> Mettez à jour la table IPv6 BGP avec le lien adresse IPv6 locale du voisin dans le système autonome spécifié.
neighbor <ipv6addr> fall-over bfd Activez BFD pour le voisin spécifié.
address-family ipv6 Entrez le mode de configuration de la famille d’adresses.
neighbor <ipv6addr> activate Préfixes d’échange pour la famille de routeurs IPv6 entre l’homologue et le nœud local à l’aide de l’adresse locale du lien.

Exemple de configuration :

> vtysh

ns# configure terminal ns(config)#router bgp 1

ns(config-router)#neighbor 30fe:123::124 remote-as 1

ns(config-router)#neighbor 30fe:123::124 fall-over bfd

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 30fe:123::124 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#exit

Configuration de BFD pour une session de saut multiple BGP IPv6

Pour configurer BFD pour une session de saut multiple IPv6 BGP à l’aide de la ligne deVTYSH commande, à l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
router bgp <asnumber> Système autonome BGP. asnumber est un paramètre obligatoire.
neighbor <ipv6addr> remote-as <num> Mettez à jour la table IPv6 BGP avec le lien adresse IPv6 locale du voisin dans le système autonome spécifié.
neighbor <ipv6addr> fall-over bfd multihop Activez BFD pour le voisin spécifié.
address-family ipv6 Entrez le mode de configuration de la famille d’adresses.
neighbor <ipv6addr> activate Préfixes d’échange pour la famille de routeurs IPv6 entre le pair et le nœud local à l’aide de l’adresse lien-local.

Exemple de configuration :

> vtysh

ns# configure terminal

ns(config)# bfd multihop-peer ipv6 20fe:125::138 interval 500 minrx 500 multiplier 5

ns(config)#router bgp 1

ns(config-router)#neighbor 20fe:125::138 remote-as 1

ns(config-router)#neighbor 20fe:125::138 fall-over bfd multihop

ns(config-router)#address-family ipv6

ns(config-router-af)#neighbor 20fe:125::138 activate

ns(config-router-af)#redistribute kernel

ns(config-router-af)#end

Configuration de BFD pour OSPFv2 (IPv4) sur les interfaces

Vous pouvez activer BFD sur tout ou sur une interface spécifique qui utilise le protocole OSPFv2.

Pour configurer BFD pour OSPFv2 sur toutes les interfaces à l’aide de la ligne deVTYSH commande :

À l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
router ospf <process tag> Entrez le mode de configuration OSPFv2.
bfd all-interfaces Activez BFD sur toutes les interfaces qui utilisent OSPFv2.

Exemple de configuration :

    > vtysh

    ns# configure terminal

    ns(config)#router ospf 1

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Pour configurer BFD pour OSPFv2 sur une interface spécifique à l’aide de la ligne deVTYSH commande :

À l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
interface <vlan ID> Entrer le mode de configuration de l’interface.
ip ospf bfd Activez BFD sur l’interface spécifiée qui utilise OSPFv2.

Exemple de configuration :

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan5

    ns(config-if)# ip ospf bfd

    ns(config-if)# exit

Configuration de BFD pour OSPFv3 (IPv6) sur les interfaces

Vous pouvez activer BFD sur tout ou sur une interface spécifique qui utilise le protocole OSPFv3.

Pour configurer BFD pour OSPFv3 sur toutes les interfaces à l’aide de la ligne deVTYSH commande :

À l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
router ipv6 ospf <process tag> Entrez le mode de configuration OSPFv3.
bfd all-interfaces Activez BFD sur toutes les interfaces qui utilisent OSPFv3.

Exemple de configuration :

    > vtysh

    ns# configure terminal

    ns(config)#router ipv6 ospf 10

    ns(config-router)#bfd all-interfaces

    ns(config-router)#redistribute kernel

    ns(config-router)#exit

Pour configurer BFD pour OSPFv3 sur une interface spécifique à l’aide de la ligne deVTYSH commande :

À l’invite de commandes, tapez les commandes suivantes, dans l’ordre indiqué :

Commande Spécifie
vtysh Afficher l’invite de commandes VTYSH.
configure terminal Entrez en mode de configuration globale.
interface <vlan ID> Entrer le mode de configuration de l’interface.
ipv6 ospf bfd Activez BFD sur l’interface spécifiée qui utilise OSPFv3.

Exemple de configuration :

    > vtysh

    ns# configure terminal

    ns(config)# interface vlan15

    ns(config-if)# ipv6 ospf bfd

    ns(config-if)# exit

Configuration de la détection de transfert bidirectionnel