Citrix ADC

Configuration du cluster ECMP à l’aide du commutateur Cisco Nexus 7000 avec protocole de routage

Avec ECMP sur une configuration de cluster, une appliance Citrix ADC est capable de gérer le trafic via un protocole de routage. Le mécanisme ECMP aide à faire la publicité des adresses IP du serveur virtuel via tous les nœuds de cluster actifs.

Pour utiliser ECMP, vous devez d’abord activer le protocole BGP sur l’adresse IP du cluster. Liez les interfaces et l’adresse IP spotted (avec le routage dynamique activé) à un VLAN. Configurez le protocole de routage sélectionné et redistribuez les routes du noyau sur les ZEBO à l’aide du shell VTYSH.

Cas d’utilisation : Cluster ECMP à l’aide du commutateur Cisco Nexus 7000 avec protocole de routage

Prenons un exemple de déploiement de cluster avec un commutateur Cisco Nexus 7000 :

  • Deux appliances Citrix ADC (nœud 1 et nœud 2), connectées au commutateur Nexus (en amont).
  • Deux commutateurs Cisco Nexus 7000.
  • Client et serveur (tracer le trafic HTTP via le commutateur Nexus). Avec HSRP (Hot Standby Router Protocol) activé côté client.

Citrix Cisco Nexus 7000

Conditions préalables

Tenez compte des points suivants avant de configurer les nœuds de cluster sur une appliance Citrix ADC.

  1. Toutes les appliances doivent être du même type de plate-forme.
  2. Le protocole BGP (BGP) doit être activé sur les nœuds du cluster.

Configuration à l’aide de l’interface de ligne de commande sur une appliance Citrix ADC

  1. Ouvrir une session sur une appliance (par exemple, avec l’adresse NSIP 1.1.1.1)

  2. Pour ajouter un nœud de cluster.

    add cluster node 0 1.1.1.2 –state ACTIVE –backplane 0/10/8
    
  3. Pour ajouter l’adresse IP du cluster

    add ns ip 1.1.1.10 255.255.255.254 –type clip
    
  4. Enregistrer la configuration

    save ns config
    
  5. Redémarrage à chaud de l’appliance

    reboot -warm
    
  6. Pour ajouter le nœud 1 à l’aide de CLIP

    add cluster node 1 2.2.2.2 –state ACTIVE –backplane 1/10/8
    
  7. Pour joindre un nœud au cluster

    join cluster –clip 1.1.1.10 –password nsroot
    
  8. Effectuez la configuration suivante sur CLIP

    • enable ns feature bgp ospf DYNAMICROUTING

    • add ns ip 11.1.1.3 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.7 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.5 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

    • add ns ip 11.1.1.9 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

Sur le routeur Cisco Nexus (11.1.1.2/31 et 11.1.1.4/31), vous devez effectuer les configurations suivantes à l’aide de la ligne de commande :

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

    >  interface vlan100
        no shutdown
        ip address 50.1.1.1/8
         hsrp 50
          ip 50.50.50.50
    
    >  interface Ethernet 4/15
         ip address 11.1.1.2/31
         no shutdown
    
    >  interface Ethernet 4/19
         ip address 11.1.1.4/31
         no shutdown
    
    >  interface Ethernet 4/22
         switchport
          switchport access vlan 100
    

Sur le routeur Cisco Nexus (11.1.1.6/31 et 11.1.1.8/31), vous devez effectuer les configurations suivantes à l’aide de la ligne de commande :

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

     >  interface vlan100
         no shutdown
         no ip redirects
         ip address 50.1.1.2/8
          hsrp 50
          ip 50.50.50.50
    
     >  interface Ethernet 4/13
         ip address 11.1.1.6/31
         no shutdown
    
     >  interface Ethernet 4/15
         ip address 11.1.1.8/31
         no shutdown
    
     >  interface Ethernet 4/22
         switchport
         switchport access vlan 100
    

Pour le protocole BGP, vous devez effectuer les configurations suivantes sur CLIP de l’appliance Citrix ADC :

>  vtych
ns# router bgp 1
 redistribute kernel
 owner-node 0
 neighbor 11.1.1.2 remote-as 2
 neighbor 11.1.1.2 as-origination-interval 1
 neighbor 11.1.1.2 advertisement-interval 0
 neighbor 11.1.1.6 remote-as 2
 neighbor 11.1.1.6 as-origination-interval 1
 neighbor 11.1.1.6 advertisement-interval 0
owner-node 1
 neighbor 11.1.1.4 remote-as 2
 neighbor 11.1.1.4 as-origination-interval 1
 neighbor 11.1.1.4 advertisement-interval 0
 neighbor 11.1.1.8 remote-as 2
 neighbor 11.1.1.8 as-origination-interval 1
 neighbor 11.1.1.8 advertisement-interval 0
exit-owner-node

Effectuez les configurations suivantes sur le routeur Cisco Nexus (11.1.1.3 et 11.1.1.5)

> ip access-list acl1
  10 permit ip 50.0.0.0/8 any
  route-map test permit
  match ip address acl1
 router bgp 2
  address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
 neighbor 11.1.1.3 remote-as 1
  address-family ipv4 unicast
  neighbor 11.1.1.5 remote-as 1
 address-family ipv4 unicast

Effectuez les configurations suivantes sur le routeur Cisco Nexus (11.1.1.7 et 11.1.1.9)

> ip access-list acl1
   10 permit ip 50.0.0.0/8 any
  route-map test permit 1
   match ip address acl1
  router bgp 2
   address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
  neighbor 11.1.1.7 remote-as 1
   address-family ipv4 unicast
  neighbor 11.1.1.9 remote-as 1
   address-family ipv4 unicast

Pour le protocole OSPF, vous devez effectuer les configurations suivantes sur CLIP de l’appliance Citrix ADC :

> vtych
ns# router osfp 1
redistribute kernel
owner-node 0
 network 15.1.1.2/31 area 0
 network 15.1.1.6/31 area 0
exit-owner-node

owner-node 1
 network 15.1.1.4/31 area 0
 network 15.1.1.8/31 area 0
exit-owner-node

route-map map2 permit 1
set metric 10

Sur le routeur Cisco Nexus (11.1.1.2/31 et 11.1.1.4/31), vous devez effectuer les configurations suivantes à l’aide de la ligne de commande :

> route-map- map2 permit 1
   set metric 10

   interface Ethernet4/15
     ip address 15.1.1.2/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   interface Ethernet4/19
     ip address 15.1.1.4/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   router ospf 1
    router-id 1.1.1.1
    redistribute direct route-map map2

Sur le routeur Cisco Nexus (11.1.1.7/31 et 11.1.1.9/31), vous devez effectuer les configurations suivantes à l’aide de la ligne de commande :

> route-map- map2 permit 1
    set metric 10

   interface Ethernet4/13
     ip address 15.1.1.6/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    interface Ethernet4/15
     ip address 15.1.1.8/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    router ospf 1
      router-id 1.1.1.2
      redistribute direct route-map map2
Configuration du cluster ECMP à l’aide du commutateur Cisco Nexus 7000 avec protocole de routage