Citrix Gateway

Contrôle de mise à niveau du plug-in Citrix Gateway

Généralités

Les administrateurs système contrôlent le fonctionnement du plug-in Citrix ADC lorsque sa version ne correspond pas à la révision Citrix Gateway. Les nouvelles options contrôlent le comportement de mise à niveau du plug-in pour Mac, Windows ou systèmes d’exploitation.

Pour les plug-ins VPN, l’option de mise à niveau peut être définie à deux endroits dans l’interface utilisateur Citrix ADC :

  • Dans les paramètres globaux
  • Au niveau du profil de session

Comportements de plug-in

Pour chaque type de client, Citrix Gateway autorise les trois options suivantes pour contrôler le comportement de mise à niveau du plug-in :

a.Toujours

Le plug-in est toujours mis à niveau lorsque la version du plug-in de l’utilisateur final ne correspond pas au plug-in fourni avec Citrix ADC. Il s’agit du comportement par défaut. Choisissez cette option si vous ne souhaitez pas que plusieurs versions de plug-in s’exécutent dans votre entreprise.

b. Essentiel (et sécurité)

Le plug-in n’a été mis à niveau que lorsque cela est jugé nécessaire. Les mises à niveau sont jugées nécessaires dans les deux circonstances suivantes

  • Le plug-in installé est incompatible avec la version actuelle de Citrix ADC.

  • Le plug-in installé doit être mis à jour pour le correctif de sécurité nécessaire.

Vous devez choisir cette option si vous souhaitez réduire le nombre de mises à niveau des plug-ins, mais ne pas manquer les mises à jour de sécurité des plug-ins

c.     Jamais

Le plug-in n’est pas mis à niveau.

Paramètres CLI pour contrôler la mise à niveau du plug-in VPN

Citrix Gateway prend en charge deux types de plug-ins (EPA et VPN) pour les systèmes d’exploitation Windows et Mac. Pour prendre en charge le contrôle de mise à niveau de plug-in VPN au niveau de la session, Citrix Gateway prend en charge deux paramètres de profil de session nommés WindowsInPluginUpgrade et MacPluginUpgrade.

Ces paramètres sont disponibles au niveau global, serveur virtuel, groupe et utilisateur. Chaque paramètre peut avoir la valeur Always, Essential ou Never. Pour une description de ces paramètres, reportez-vous à la section Comportements de plug-in.

Paramètres CLI pour contrôler la mise à niveau du plug-in EPA

Citrix Gateway prend en charge les plug-ins EPA pour les systèmes d’exploitation Windows et Mac. Pour prendre en charge le contrôle de mise à niveau de plug-in EPA au niveau Vserver, Citrix Gateway prend en charge deux paramètres Vserver nommés WindowsepaPluginUpgrade et MacEpaPluginUpgrade.

Les paramètres sont disponibles au niveau du serveur virtuel. Chaque paramètre peut avoir la valeur Always, Essential ou Never. Pour une description de ces paramètres, voir Comportements de plug-in

Configuration VPN

Suivez ces étapes pour la configuration VPN des plug-ins Windows, Linux et Mac.

  1. Accédez à Citrix NetScaler>Policies>Session.

    image localisée

  2. Sélectionnez la stratégie de session souhaitée, puis cliquez sur Modifier.

    image localisée

  3. Cliquez sur l’icône + .

    image localisée

  4. Sélectionnez l’onglet Expérience client .

    image localisée

  5. Ces options de boîtes de dialogue affectent le comportement de mise à niveau.

    • Always

    • Essential

    • Never

La valeur par défaut est Toujours.

  1. Cochez la case située à droite de chaque option. Sélectionnez la fréquence à appliquer le comportement de mise à niveau.

    image localisée

Configuration de l’EPA

Suivez ces étapes pour la configuration EPA des plug-ins Windows, Linux et Apple.

       1.Accédez à Citrix Gateway > Serveurs virtuels.

image localisée

       2. Sélectionnez un serveur et cliquez sur le bouton Modifier .

image localisée

      3.Cliquez sur l’icône en forme de crayon .

image localisée

      4. Cliquez sur Plus

image localisée

       5.Les boîtes de dialogue qui s’affichent affectent le comportement de mise à niveau. Les options disponibles sont :

  • Always
  • Essential
  • Never

image localisée

Exigences

  • La version du plug-in Windows EPA et VPN doit être supérieure à 11.0.0.0

  • La version du plug-in Mac EPA doit être supérieure à 3.0.0.31

  • La version du plug-in VPN Mac doit être supérieure à 3.1.4 (357)

Remarque : si Citrix ADC est mis à niveau vers la version 11.0, tous les plug-ins VPN (et EPA) précédents seront mis à niveau vers la dernière version, quelle que soit la configuration du contrôle de mise à niveau. Pour les mises à niveau ultérieures, elles respecteront la configuration de contrôle de mise à niveau ci-dessus.

Contrôle de mise à niveau du plug-in Citrix Gateway