Linux Virtual Delivery Agent

Configuration système requise

Distributions Linux

Remarque :

la configuration système requise des composants non couverts dans ce document (telles que l’application Citrix Workspace) est décrite dans leur documentation respective.

Pour plus d’informations sur l’utilisation de cette version Current Release (CR) dans un environnement Long Term Service Release (LTSR) et d’autres questions fréquemment posées, consultez cet article du centre de connaissances.

Linux VDA prend en charge les distributions Linux suivantes :

  • SUSE Linux Enterprise :
    • Server 12 Service Pack 5 + SUSE Linux Enterprise Workstation Extension 12 SP5
    • Server 12 Service Pack 5
  • Red Hat Enterprise Linux
    • Workstation 8.2
    • Workstation 8.1
    • Workstation 7.8
    • Server 8.2
    • Server 8.1
    • Server 7.8
  • CentOS Linux
    • CentOS 8.2
    • CentOS 8.1
    • CentOS 7.8
  • Ubuntu Linux
    • Ubuntu Desktop 20.04 (expérimental)
    • Ubuntu Server 20.04 (expérimental)
    • Ubuntu Desktop 18.04
    • Ubuntu Server 18.04
    • Ubuntu Live Server 18.04
    • Ubuntu Desktop 16.04
    • Serveur Ubuntu 16.04

En tant que fonctionnalité expérimentale, vous pouvez distribuer le Linux VDA sur Ubuntu 20.04. Pour obtenir la liste des fonctionnalités prises en charge par le Linux VDA sur Ubuntu 20.04, consultez le tableau suivant :

Fonctionnalité Pris en charge sur Ubuntu 20.04 ?
Citrix Virtual Apps (non transparent) Oui
Citrix Virtual Apps (transparent) Oui
Partage de session Oui
Citrix Virtual Desktops Oui
IPv6 Oui
MCS Oui
Capture audio Oui
Lecture audio Oui
Impression locale Oui
Impression réseau Oui
Impression PDF (application Citrix Workspace pour Windows) Oui
Presse-papiers Oui
Mappage des lecteurs clients Oui
Transfert de fichiers Oui
MRVC Oui
Redirection USB générique Oui
Carte à puce Oui
HDX Insight Oui
NSAP Oui
Bureau GNOME Oui
Bureau KDE Non testé
Bureau Unity Non testé
Graphiques 3D Pro Non testé
Graphiques 3D Pro vGPU Non testé
Autres graphiques 3D Pro Non testé
Multimoniteur Oui
Graphiques H.264 sélectifs Non testé
Graphiques H.265 Non testé
Xauthority Oui
Observation de session Non testé
Stratégie de groupe Oui
Easy Install Oui
SSSD Oui
Winbind Oui
Centrify Oui
Quest Oui
Authentification non AD Non testé
FAS Oui
Intégration NIS Oui
Ouverture de session anonyme Oui
LDAPS Oui
Transport adaptatif Non testé
DTLS pour le transport adaptatif Non testé
SSL Oui
Fiabilité de session/protocole CGP (Common Gateway Protocol) Oui
WebSockets Oui
Reconnexion automatique des clients Oui
Pré-démarrage de session Non testé
Traçage activé Oui
Éditeur IME client Non testé
Serveur IME (GNOME uniquement) Non testé

Pour une matrice des distributions Linux et des versions Xorg que cette version du Linux VDA prend en charge, consultez le tableau suivant. Pour plus d’informations, consultez la page XorgModuleABIVersions.

Distribution Linux Version Xorg
RHEL 8.2, CentOS 8.2 1.20
RHEL 8.1, CentOS 8.1 1.20
RHEL 7.8, CentOS 7.8 1.20
Ubuntu 20.04 (expérimental) 1.20
Ubuntu 18.04 1.19
Ubuntu 16.04 1.18
SUSE 12.5 1.19

N’utilisez pas le serveur HWE Xorg 1.19 sur Ubuntu 16.04.

Dans tous les cas, l’architecture de processeur prise en charge est x86-64.

Remarque :

La prise en charge par Citrix d’une plate-forme et d’une version de système d’exploitation Linux expire lorsque le support du fournisseur du système d’exploitation expire.

Important :

les bureaux GNOME et KDE sont pris en charge dans SUSE 12, RHEL 7 et CentOS 7. Le bureau Unity est pris en charge sur Ubuntu 16.04. Le bureau GNOME est pris en charge sur Ubuntu 20.04 et Ubuntu 18.04. Au moins un bureau doit être installé.

Citrix Virtual Desktops

Le Linux VDA est compatible avec toutes les versions actuellement prises en charge de Citrix Virtual Apps and Desktops. Pour de plus amples informations sur le cycle de vie des produits Citrix et savoir quand Citrix arrête la prise en charge de versions spécifiques des produits, consultez le tableau du cycle de vie des produits Citrix.

Le processus de configuration des agents Linux VDA diffère légèrement de celui des VDA Windows. Toutefois, toute batterie de Delivery Controller est capable de négocier les connexions aux bureaux Windows et Linux.

Environnements de virtualisation et plates-formes hôte pris en charge

  • Serveurs bare metal
  • Citrix Hypervisor
  • VMware ESX et ESXi
  • Microsoft Hyper-V
  • Nutanix AHV
  • Microsoft Azure Resource Manager
  • Amazon Web Services (AWS)
  • Google Cloud Platform (GCP)

Conseil :

consultez la documentation du fournisseur pour obtenir la liste des plates-formes prises en charge.

Remarque :

Azure, AWS et GCP ne sont compatibles qu’avec le service Citrix Virtual Apps and Desktops. Les serveurs GCP et bare metal ne sont pas pris en charge lorsque MCS est utilisé pour créer des machines virtuelles.

Packages d’intégration d’Active Directory

Linux VDA prend en charge les produits ou packages d’intégration d’Active Directory suivants :

  • Samba Winbind
  • Quest Authentication Services v4.1 ou version ultérieure
  • Centrify DirectControl
  • SSSD
  • PBIS (compatible avec RHEL 7 et Ubuntu)

Conseil :

pour obtenir la liste des plates-formes prises en charge, reportez-vous à la documentation des fournisseurs des packages d’intégration d’Active Directory.

HDX 3D Pro

Les hyperviseurs et processeurs graphiques NVIDIA GRID™ suivants sont requis pour la prise en charge de HDX 3D Pro.

Hyperviseurs

  • Citrix Hypervisor
  • VMware ESX et ESXi
  • Nutanix AHV
Remarque

les hyperviseurs sont compatibles avec certaines distributions Linux.

Processeur graphique

Le Linux VDA prend en charge les GPU suivants pour le GPU pass-through :

  • NVIDIA GRID - Tesla T4
  • NVIDI GTX750Ti
  • NVIDIA GRID - Tesla M60
  • NVIDIA GRID - K2
  • NVIDIA GRID - Tesla P40
  • NVIDIA GRID - Tesla P4
  • NVIDIA GRID - Tesla P100

Le Linux VDA prend en charge les GPU suivants pour vGPU :

  • NVIDIA GRID - Tesla T4
  • NVIDIA GRID - Tesla V100
  • NVIDIA GRID - Tesla M60
  • NVIDIA GRID - Tesla M10
  • NVIDIA GRID - Tesla P40
  • NVIDIA GRID - Tesla P4
  • NVIDIA GRID - Tesla P100
Configuration système requise