Configuration système requise

27 février 2018

Cet article décrit la configuration système requise pour le MDX Toolkit 10.3 et le SDK Worx App.

MDX Toolkit et SDK Worx App (iOS et Android)

  • Java Development Kit (JDK) 1.7 ou 1.8.

    Vous pouvez télécharger le JDK 1.8 depuis Java SE Development Kit Downloads sur le site Web Oracle. Pour obtenir les instructions d’installation, veuillez consulter la section JDK 8 and JRE 8 Installation Guide sur le site Web d’Oracle. Veillez à installer le JDK complet : définissez JDK 1.8 comme valeur par défaut.

  • macOS 10.10 (version minimum pour applications avant iOS 9)

    Le programme d’installation de l’outil MDX Toolkit et du SDK Worx App doit être exécuté sur un macOS. Le programme d’installation comprend des outils macOS qui encapsulent les applications iOS et Android, ainsi qu’un outil de ligne de commande Java qui encapsule les applications Android.

  • Pour le SDK Worx App : SDK 9 : iOS avec Xcode 7 ; génération de bitcode désactivée.

    La génération de bitcode est activée par défaut dans Xcode 7. Vous devez désactiver cette option pour utiliser Xcode 7 avec le SDK Worx App.

Autre configuration requise pour encapsuler des applications mobiles iOS

  • Pour obtenir l’accès à la configuration requise pour l’encapsulation d’applications pour iOS, vous devez vous enregistrer afin d’obtenir un compte de distribution Apple. Il existe trois types de comptes développeur iOS : Enterprise, Individual et University. Citrix recommande fortement les comptes iOS Developer Enterprise.
    • Comptes iOS Developer Enterprise : seul type de compte Apple Developer qui vous permet de provisionner, déployer et tester un nombre illimité d’applications pour un nombre illimité d’appareils, avec ou sans encapsulation d’application. Veillez à distribuer votre certificat Developer à vos développeurs pour qu’ils puissent signer les applications.
    • Comptes iOS Developer Individual : limité à 100 périphériques inscrits par an et ne permet pas l’encapsulation d’applications d’entreprise ni la distribution d’entreprise avec XenMobile.
    • Comptes iOS Developer University : limité à 200 périphériques inscrits par an et ne permet pas l’encapsulation d’applications d’entreprise ni la distribution d’entreprise avec XenMobile.
  • Configuration requise pour l’encapsulation d’applications iOS 9 :
    • OS X 10.10 (Yosemite ; version minimum)
    • Xcode 7 (version minimum)
    • Outils de ligne de commande Xcode disponibles (avril 2013)

Remarque : téléchargez les outils de ligne de commande Xcode disponibles sur le site Web Xcode Apple Developer. macOS 10.10 n’installe pas les outils automatiquement. Pour installer les outils, suivez ces étapes :

  1. Dans Applications > Utilities, cliquez sur Terminal pour utiliser l’interface de ligne de commande Mac.

  2. Exécutez la commande suivante :

    xcode-select --install
    

    Veillez à inclure deux tirets avant le mot install dans la commande.

  3. Une fois les outils de ligne de commande Xcode installés, exécutez Xcode to pour installer les éléments pré-requis.

Autre configuration requise pour encapsuler des applications mobiles Android

  • SDK Android, Niveau API 19 (version minimum prise en charge).

    • Téléchargez le SDK Android à partir de la page de téléchargement du SDK sur le site Web de développeurs Google.

    • Installez les outils SDK Android les plus récents, SDK Android Platform-tools et Android SDK Build-tools.

      Pour de plus amples informations, consultez la section Installing the Android SDK sur le site Web de développeurs Google.

    • Ajoutez l’emplacement des nouveaux dossiers à la variable PATH dans votre environnement.

  • Keystore valide (contenant les certificats signés numériquement utilisés pour signer vos applications Android)

    Vous créez un keystore une fois et vous conservez ce fichier pour le réutiliser à des fins d’encapsulation. Si vous n’utilisez pas le même keystore lors de l’encapsulation de la nouvelle version d’une application que vous avez déjà déployée, les mises à niveau de cette application ne fonctionneront pas. Les utilisateurs devront supprimer manuellement la version précédente avant d’installer la version la plus récente.

    Un keystore peut contenir plusieurs clés privées, mais dans la plupart des cas, une seule clé existe.

    Pour de plus amples informations sur les certificats, consultez la section Signing Your Applications sur le site Web des développeurs Android.

    Vous devez signer vos applications avec une clé répondant aux exigences suivantes :

    • Taille de clé 1024 bits
    • Algorithme de clé DSA (keyalg)
    • Algorithme de signature DSA avec SHA1 (sigalg)