XenCenter

Modification des options XenCenter

Vous pouvez modifier divers paramètres qui affectent votre environnement de travail XenCenter. Dans le menu Outils, cliquez sur Options, sur un onglet et modifiez le paramètre, puis cliquez sur OK pour enregistrer vos modifications.

Paramètres de sécurité

Option Description Défaut
M’avertir lorsqu’un nouveau certificat SSL est trouvé Activez cette case à cocher pour que XenCenter affiche un avertissement chaque fois qu’un nouveau certificat de sécurité TLS est détecté sur un serveur géré. Désactivez la case à cocher si vous ne souhaitez pas voir d’avertissement concernant les nouveaux certificats détectés sur vos serveurs gérés lors de la connexion à ces derniers. Désactivé
M’avertir en cas de modification d’un certificat SSL Désactivez cette case à cocher si vous ne souhaitez pas voir d’avertissement concernant les certificats modifiés détectés sur vos serveurs gérés lors de la connexion à ces derniers. Cochez la case pour que XenCenter affiche un avertissement chaque fois qu’un certificat modifié est détecté sur un serveur géré. Activé

Voir également : Connexion et déconnexion de serveurs.

Paramètres de mise à

Option Description Défaut
Vérifiez la présence de nouvelles versions de Citrix Hypervisor Activez cette case à cocher pour que XenCenter vérifie et vous avertisse régulièrement lorsque de nouvelles versions de Citrix Hypervisor sont disponibles. Désactivez la case à cocher pour désactiver la vérification périodique. Activé
Vérifiez les mises à jour de Citrix Hypervisor Activez cette case à cocher pour que XenCenter vérifie et vous avertisse régulièrement lorsque des mises à jour sont disponibles pour votre serveur Citrix Hypervisor. Désactivez la case à cocher pour désactiver la vérification périodique. Activé
Vérifiez les nouvelles versions de XenCenter Activez cette case à cocher pour que XenCenter vérifie et vous informe régulièrement lorsqu’une nouvelle version de XenCenter est disponible. Désactivez la case à cocher pour désactiver la vérification périodique. Activé

Voir aussi :

Paramètres d’affichage

Cet onglet vous permet de configurer la façon dont les graphiques sont affichés dans l’onglet Performances .

Option Description
Graphique en aires Sélectionnez cette case d’option si vous souhaitez afficher les données de performance affichées dans l’onglet Performances sous forme de graphiques en aires. Par exemple : un graphique en aires montrant des lignes avec des espaces remplis entre la ligne et l'axe des abscisses
Graphique linéaire Sélectionnez cette case d’option si vous souhaitez afficher les données de performance affichées dans l’onglet Performances sous forme de graphiques en courbes. Par exemple : un graphique linéaire

Voir également : Surveillance des performances du système.

Vous pouvez également utiliser cet onglet pour configurer si XenCenter se souvient du dernier onglet sélectionné pour une ressource.

Paramètres de la console

Option Description Défaut
Partager le contenu du presse-papiers avec la console dist Activez cette case à cocher pour partager le contenu de votre presse-papiers texte local avec la console distante. Les éléments coupés ou copiés sont placés dans le presse-papiers et peuvent être collés sur votre ordinateur local ou sur la console distante. Activé
Mode plein écran Raccourci clavier permettant de basculer la console vers et depuis le mode plein écran. Ctrl+Entrée
Ancre/Déconnecter Raccourci clavier permettant de déconnecter l’onglet Console de la fenêtre XenCenter et de le réancrer. Alt+Maj+U
Release clavier et souris Lorsque le système d’exploitation d’une machine virtuelle capture le curseur de votre clavier et de votre souris pour une utilisation dans le système d’exploitation invité. Toutes les frappes au clavier, les mouvements de souris et les clics de bouton que vous effectuez sont redirigé vers la machine virtuelle. Pour redonner la propriété du clavier et de la souris à votre système d’exploitation hôte, XenCenter réserve une touche spéciale sur votre clavier : cette touche est la clé de l’hôte. Par défaut, la touche d’hôte est la touche Ctrl droite de votre clavier. Vous pouvez modifier cette valeur par défaut ici. Ctrl droit
Conserver le réglage d’échelle actuel lorsque la console est déconnectée Activez cette case à cocher pour utiliser le même paramètre d’échelle de console lorsque la console est ancrée et lorsqu’elle est déconnectée. Activé
Conserver le réglage d’échelle actuel lors du retour à la console par défaut Activez cette case à cocher pour conserver le même paramètre d’échelle de console lorsque vous passez d’un type de console à un autre (par exemple, console VNC/texte). Activé
Envoyer des combinaisons de touches Windows à la console Bureau à distance Activez cette case à cocher pour que XenCenter envoie toutes les combinaisons de touches Windows saisies sur votre clavier à la console Bureau à distance. Activé
Recevez le son de la console Bureau à distance Activez cette case à cocher pour que XenCenter diffuse des sons provenant d’applications exécutées sur la console Bureau à distance sur votre ordinateur local (l’ordinateur sur lequel vous exécutez XenCenter). Activé
Basculer automatiquement vers la console Bureau à distance lorsqu’elle est disponible Activez cette case à cocher pour que XenCenter passe automatiquement de l’utilisation de la console graphique standard à l’utilisation de la console Bureau à distance chaque fois qu’elle est disponible. Activé
Connectez-vous directement à la session de console du serveur Activez cette case à cocher pour que XenCenter se connecte à la session de console existante sur le serveur distant. Lors de l’ouverture d’une session de console Bureau à distance, XenCenter utilise cette session au lieu de créer une nouvelle session de console virtuelle. Activé
Activer l’analyse de la console de bureau Activez cette case à cocher pour que XenCenter recherche automatiquement une connexion RDP. Désactivez la case à cocher pour empêcher XenCenter d’analyser (interrogation) automatiquement le port RDP, par exemple si vous disposez d’un pare-feu qui bloque le trafic RDP. Lorsque cette option est activée, XenCenter continue d’analyser le port RDP même si l’option Basculer automatiquement vers le Bureau à distance est désactivée. Vous pouvez passer au protocole RDP lorsqu’il sera disponible. Activé

Toutes les modifications que vous apportez aux paramètres de la console Bureau à distance Windows s’appliquent lorsque vous redémarrez XenCenter.

Voir également : Exécuter une session de console distante.

Paramètres de connexion

Serveur proxy

XenCenter peut être configuré pour se connecter directement à vos serveurs gérés ou pour utiliser un serveur proxy. Vous pouvez utiliser les paramètres de votre serveur proxy Internet Explorer ou spécifier un serveur proxy.

  • Sélectionnez Ne pas utiliser de serveur proxy pour que XenCenter se connecte directement aux serveurs gérés sans utiliser de serveur proxy.
  • Sélectionnez Utiliser les paramètres du serveur proxy d’Internet Explorer pour utiliser les mêmes paramètres proxy qu’Internet Explorer.
  • Sélectionnez Utiliser ce serveur proxy si vous souhaitez que XenCenter se connecte au serveur proxy spécifié. Utilisez HTTP CONNECT pour établir un tunnel TLS sécurisé vers vos serveurs. Entrez l’adresse du serveur proxy et le numéro de port à utiliser.

Pour que les demandes de connexion Citrix Hypervisor soient effectuées directement et non via le serveur proxy, cochez la case Ignorer le serveur proxy pour les connexions Citrix Hypervisor . Pour que toutes les demandes de connexion soient effectuées via le serveur proxy, désactivez la case à cocher.

La connexion Citrix Hypervisor est toute connexion qui fournit une communication entre XenCenter et le système Citrix Hypervisor, telle que l’envoi de commandes et l’utilisation de la console. Une connexion non Citrix Hypervisor est une opération telle que la recherche de mises à jour.

Activez la case à cocher Fournir les informations d’identification et entrez le nom d’ utilisateur et le mot de passe qui correspondent à un compte d’utilisateur configuré sur le serveur proxy spécifié.

Sélectionnez la méthode d’authentification souhaitée : Basic ou Digest (par défaut).

La méthode d’authentification est utilisée pour s’authentifier auprès du serveur proxy. Sélectionnez la même méthode d’authentification que celle pour laquelle le serveur proxy est défini.

Par exemple, si le serveur proxy demande à XenCenter de s’authentifier à l’aide de Digest, XenCenter ne parvient pas à s’authentifier si la méthode d’authentification de base est sélectionnée.

Par défaut : ne pas utiliser de serveur proxy

Délai d’expiration de la connexion

Vous pouvez spécifier la durée d’attente lors de l’établissement d’une connexion avec un serveur géré en ajustant le nombre de secondes d’attente d’un délai de connexion. Ne définissez pas cette valeur trop faible si vous ne souhaitez pas recevoir de nombreuses fausses alertes en raison de problèmes liés au réseau.

Par défaut : 20 secondes

Voir également : Connexion et déconnexion de serveurs.

Enregistrer et restaurer les paramètres

Utilisez les paramètres de cet onglet pour spécifier si vous souhaitez stocker vos informations d’identification de connexion pour les serveurs gérés. Les informations d’identification de connexion stockées peuvent être utilisées pour se reconnecter automatiquement à tous vos serveurs gérés au début de chaque session XenCenter. Vous pouvez également définir un mot de passe principal ici pour protéger vos identifiants de connexion enregistrés.

Option Description Défaut
Enregistrer et restaurer l’état de connexion au serveur au démarrage Les informations d’identification de connexion - votre nom d’utilisateur et votre mot de passe - pour tous vos serveurs gérés peuvent être stockées entre XenCenter. Ces informations d’identification sont utilisées pour se reconnecter automatiquement au début de chaque nouvelle session XenCenter. Lorsque cette case est cochée, XenCenter mémorise l’état de connexion de tous vos serveurs gérés à la fin de chaque session. XenCenter tente de restaurer ces serveurs au début de votre prochaine session. Désactivé
Exiger un mot de passe principal Lorsque l’option Enregistrer et restaurer l’état de connexion au serveur au démarrage est activée, vous pouvez protéger vos informations d’identification de connexion stockées avec un mot de passe principal pour garantir leur sécurité. Au début de chaque session, vous êtes invité à entrer ce mot de passe principal avant que les connexions à vos serveurs gérés ne soient automatiquement restaurées. Désactivé
Changer le mot de passe Sélectionnez cette option pour modifier le mot de passe principal actuel. Vous êtes invité à entrer le mot de passe actuel, puis à saisir et confirmer le nouveau mot de passe principal.  

Paramètres des plug-ins

Les plug-ins sont des composants facultatifs que vous pouvez ajouter à XenCenter pour étendre ses fonctionnalités. Vous pouvez ajouter des éléments de menu personnalisés ou même des onglets entiers à la fenêtre principale à l’aide du plug-in XenCenter. Par exemple, vous pouvez effectuer cette action en tant que fournisseur de logiciels indépendants pour intégrer votre propre produit à XenCenter, ou en tant qu’utilisateur final pour intégrer la gestion des stocks existante de votre entreprise. Un élément de menu peut exécuter un script Microsoft PowerShell ou même un exécutable arbitraire sur la machine cliente. Les onglets sont remplis avec une page Web et peuvent appeler d’autres services de votre réseau ou vos machines virtuelles.

Composants enfichables

Le plug-in XenCenter comprend les composants suivants :

  • Un fichier de configuration XML.
  • Une DLL de ressources pour chaque paramètre régional pris en charge.
  • L’application et toutes les ressources dont elle a besoin.

Placez les composants du plug-in dans un sous-dossier de plug-ins de votre dossier d’installation XenCenter. Les composants sont chargés au démarrage de XenCenter. Par exemple, dans une installation par défaut de XenCenter, vos plug-ins seraient situés ici :

C:\Program Files\Citrix\XenCenter\plugins <your_organization_name><your_plugin_name>
<!--NeedCopy-->

Par défaut : Désactivé

Afficher les plug-ins disponibles

Pour afficher la liste des plug-ins actuellement disponibles dans XenCenter et pour activer ou désactiver des plug-ins individuels, dans le menu Outils, sélectionnez Options. La boîte de dialogue Options s’affiche. Dans la liste des options du volet gauche, sélectionnez Plugins.

Par défaut : Activé

Création de plug-ins

Pour savoir comment créer des plug-ins pour XenCenter, consultez les exemples et la documentation qui l’accompagne dans le référentiel XenCenter Plug-in Specification and Examples . Vous pouvez accéder à cette page Web à tout moment depuis XenCenter en cliquant sur Plugins XenCenter en ligne dans le menu Aide.

Le Guide de spécification du plug-in Citrix XenCenter est disponible sur le site de documentation du développeur.

Paramètres de confirmation

Utilisez les paramètres de cet onglet pour configurer l’affichage ou non d’une boîte de dialogue de confirmation dans les cas suivants :

  • Lorsque vous rejetez une alerte
  • Lorsque vous rejetez une mise à jour
  • Lorsque vous rejetez un événement
Modification des options XenCenter