Citrix ADC

クラスタ内のルーティング

クラスター内のルーティングは、スタンドアロンシステムでのルーティングとほぼ同じように機能します。注意すべきいくつかのポイント:

  • すべてのルーティング構成はクラスタ IP アドレスから実行する必要があり、構成は他のクラスタノードに伝播されます。

  • ルートは、アップストリームルータでサポートされる ECMP ルートの最大数に制限されます。

  • ノード固有のルーティング設定は、次のように owner-node 引数を使用して実行する必要があります。

  router ospf
    owner-node 0
      ospf router-id 97.131.0.1
    exit-owner-node
  !

次のコマンドは、VTYSH 内のすべてのノードの統合クラスタ構成を表示します。

show cluster-config

次のコマンドは、各ノードのクラスターステータスを表示します。

show cluser node

L2 クラスタでの IPv4 ルーティング

ここでは、L2 クラスタでの IPv4 OSPF および BGP ルーティングの設定に役立つ設定例を示します。

スポッティング SNIP アドレスの追加と動的ルーティングの有効化

次の設定では、OSPF および BGP ルーティングが有効になっています。また、スポッティング SNIP アドレスが追加され、これらの SNIP アドレスでダイナミックルーティングが有効になります。

en ns fea ospf bgp
add vlan 10
add ns ip 10.10.10.1 255.255.255.0 -dynamicrouting enabled -ownernode 1
add ns ip 10.10.10.2 255.255.255.0 -dynamicrouting enabled -ownernode 2
add ns ip 10.10.10.3 255.255.255.0 -dynamicrouting enabled -ownernode 3
bind vlan 10 -ipaddress 10.10.10.1 255.255.255.0

VTYSH IPv4 OSPF構成

L2 クラスタで IPv4 OSPF を設定するには、

  • プライオリティを 0 に設定します。
  • ルータ ID をスポット設定として設定します。

L2 クラスタの OSPF 設定ガイドラインは、OSPFv3 にも適用されます。

次の設定例では、IPv4 OSPF が設定されています。

      interface vlan10
       IP OSPF PRIORITY 0
       !
      router ospf
          owner-node 1
            ospf router-id 97.131.0.1
          exit-owner-node
          owner-node 2
            ospf router-id 97.131.0.2
          exit-owner-node
          owner-node 3
            ospf router-id 97.131.0.3
          exit-owner-node
      network 10.10.10.0/24 area 0
      redistribute kernel
       !

VTYSH IPv4 BGP 構成

次の VTYSH 設定例では、IPv4 BGP が設定されています。

    router bgp 100
      neighbor 10.10.10.10 remote-as 200
     owner-node 1
      neighbor 10.10.10.10 update-source 10.10.10.1
     exit-owner-node
     owner-node 2
      neighbor 10.10.10.10 update-source 10.10.10.2
     exit-owner-node
     owner-node 3
      neighbor 10.10.10.10 update-source 10.10.10.3
     exit-owner-node
    redistribute kernel
    !

update-source コマンドは、適切な送信元 IP で接続するために、次の構成で owner-node 引数を持つネイバーごとに使用されます。

L2 クラスタでの IPv6 ルーティング

ここでは、L2 クラスタでの IPv6 OSPF および BGP ルーティングの設定に役立つ設定例を示します。

IPv6 ルーティングを有効にする

L2 クラスタで IPv6 ルーティングを設定する前に、IPv6 機能を有効にする必要があります。

CLI を使用して IPv6 ルーティングを有効にするには、

コマンドプロンプトで、次のように入力します。

  • enable ns fea ipv6pt

スポッティング SNIP6 アドレスの追加と動的ルーティングの有効化

次の設定では、OSPF および BGP ルーティングが有効になっています。また、スポッティング SNIP6 アドレスが追加され、これらの SNIP6 アドレスでダイナミックルーティングが有効になります。

add ns ip6 3ffa::1/64 -dynamicrouting enabled -ownernode 1
add ns ip6 3ffa::2/64 -dynamicrouting enabled -ownernode 2
add ns ip6 3ffa::3/64 -dynamicrouting enabled -ownernode 3
add vlan 10
bind vlan 10 -ipaddress 3ffa::1/64

IPv6 BGP 構成

次の VTYSH 設定例では、IPv6 BGP が設定されています。

  router bgp 100
   neighbor 3ffa::10 remote-as 200
     owner-node 1
      neighbor 3ffa::10 update-source 3ffa::1
     exit-owner-node
     owner-node-2
      neighbor 3ffa::10 update-source 3ffa::2
     exit-owner-node
     owner-node-3
      neighbor 3ffa::10 update-source 3ffa::3
     exit-owner-node
   no neighbor 3ffa::10 activate
   address-family ipv6
    redistribute kernel
    neighbor 3ffa::10 activate
   exit-address-family
  !

IPv6 学習ルートのインストール

Citrix ADCクラスタは、Citrix ADCクラスタのルーティングテーブルにルートをインストールした後、さまざまなルーティングプロトコルで学習したルートを使用できます。

CLI を使用して IPv6 学習ルートを内部ルーティングテーブルにインストールするには、次の手順を実行します。

コマンドプロンプトで、次のように入力します。

  • ns route-install ipv6 bgp

  • ns route-install ipv6 ospf

  • ns route-install default

  • IPv6 ネイバー上で IPv4 ルートを交換する必要がある場合は、以前の設定からno neighbor 3ffa::10 active VTYSH コマンドを削除する必要があります。

  • update-source VTYSH コマンドは、BPG IPv4 構成で与えられた BGP ピアへの接続中に、正しい IPv6 ソース IP を指定するために、各所有者ノードで使用する必要があります。

L3 クラスタでのルーティング

L3クラスタでのルーティングは、Citrix ADCアプライアンスで次の構成が行われた場合にのみ機能します。

  • VLAN のダイナミックルーティングを有効にします。

     set vlan <id> -dynamicrouting enabled
    
  • すべてのクラスタノードに到達するには、VIP、CLIP、およびCitrix ADC IP(NSIP)を、set vlan コマンドとともにルーティングプロトコルによってアドバタイズする必要があります。

L3 クラスタでの BGP の展開シナリオ

たとえば、すべてのクラスタノードが AS 100 ネットワークにグループ化され、アップストリームルータが異なる AS 200 にあるとします。

次の図は、クラスタ設定における AS 100 および AS 200 の配置を示しています。

ローカライズされた画像

この展開では、CLIP はアップストリームルータに CCO をアドバタイズします。AS ループが検出されると、一部のクラスタノードはアドバタイズされたトラフィックをドロップします。

この問題を解決するには、ネイバーごとに vtysh BGP ルータモードで次のコマンドを設定します。

VTYSHコマンドプロンプトで、次のように入力します。

neighbor <peer_ip> allowas-in 1

ベストプラクティスとして、以下のいずれかを構成することをお勧めします。

  • ルートマップを設定して、クラスタノード上のデフォルトルート、Citrix ADC IP(NSIP)、NSIPサブネットなど、必要なネットワークのみを学習します。

  • クラスタ内のCLIPやCitrix ADC IP(NSIP)など、必要なネットワークのみをアドバタイズするようにアップストリームルートを設定します。

クラスタ内のルーティング