ネットワーク

ISIS の設定

Citrix ADCアプライアンスは、中間システム間システム(IS-ISまたはISIS)の動的ルーティングプロトコルをサポートしています。このプロトコルは IPv4 と IPv6 のルート交換をサポートします。IS‑IS はリンクステートプロトコルであるため、ルーティングループが発生しにくくなります。より高速なコンバージェンスと大規模なネットワークをサポートできるという利点により、ISIS は Internet Service Provider(ISP; インターネットサービスプロバイダー)ネットワークで非常に役立ちます。

ISIS の設定の前提条件

ISIS の設定を開始する前に、次の手順を実行します。

  • ISIS プロトコルを理解していることを確認してください。
  • IPV6 ルートでは、以下を有効にします。
    • IPv6 プロトコル変換機能
    • ISIS プロトコルを実行する VLAN の IPv6 ダイナミックルーティングオプション

ISIS の有効化

次の手順のいずれかを使用して、Citrix ADCアプライアンス上でISISルーティング機能を有効にします。

CLI を使用して ISIS ルーティングを有効にするには、次の手順を実行します。

コマンドプロンプトで、次のように入力します。

enable ns feature ISIS

GUI を使用して ISIS ルーティングを有効にするには、次の手順を実行します。

  1. [システム] > [設定] に移動し、[モードと機能] で [高度な機能の変更] をクリックします。
  2. [ISIS ルーティング] オプションをオンまたはオフにします。

ISIS ルーティングプロセスの作成と VLAN 上での開始

ISIS ルーティングプロセスを作成するには、VTYSH コマンドラインを使用する必要があります。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSH コマンドプロンプトを表示します。
configure terminal グローバル構成モードに移行します。
router ISIS [tag] ルーティングプロセスの ISIS ルーティングプロセスおよび構成モードを作成します。
net XX….XXXX.YYYY.YYYY.YYYY.00 ルーティングプロセスの NET 値を指定します。 ·XX… .XX XX はエリアアドレス (1 ~ 13 バイト)、 ·YYYY.YYY.YYY.YYY.YYYY.YYY.Y はシステム ID (6 バイト)、 ·00 は N セレクタ (1 バイト) です。
is-type (level-1|level-1-2|level-2-only) ISIS ルーティングプロセスを指定されたルーティングレベルに設定します。デフォルト:レベル1-2です。
ns IPv6-routing IPv6 ダイナミックルーティングデーモンを起動します。
interface <vlan_name> VLAN 構成モードを開始します。
ip router ISIS IPv4 ルート交換用の VLAN 上で ISIS ルーティングプロセスを有効にします。
ipv6 router ISIS IPv6 ルート交換用の VLAN 上で ISIS ルーティングプロセスを有効にします。

例:

> VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# net 15.aabb.ccdd.0097.00
NS(config-router)# is-type level-1
NS(config-router)# exit
NS(config)# ns IPv6-routing
NS(config)# interface vlan0
NS(config-if)#  ip router isis 11
NS(config-if)# ipv6 router isis 11

アドバタイズルート

ルートアドバタイズメントを使用すると、アップストリームルーターはCitrix ADCアプライアンスの背後にあるネットワークエンティティを追跡できます。

VTYSH コマンドラインを使用してルートをアドバタイズするように ISIS を設定するには、次の手順を実行します。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSH コマンドプロンプトを表示します。
configure terminal グローバル構成モードに移行します。
router ISIS [tag] ISIS ルーティングインスタンスを起動し、ルーティングプロセスの構成モードを開始します。
redistribute connected (level-1 or level-1-2 or level-2) 接続ルートを再配布します。ここで、 レベル 1: 接続ルートをレベル 1 に再配布し、 レベル 1-2: 接続ルートをレベル 1 およびレベル 2 に再配布し、 レベル 2: 接続ルートをレベル 2 に再配布します。
redistribute kernel (level-1 or level-1-2 or level-2) カーネルルートを再配布します。ここで、 level-1: カーネルルートをレベル 1 に再配布し、 level-1-2: カーネルルートをレベル 1 およびレベル 2 に再配布し、 level-2: カーネルルートをレベル 2 に再配布します。

例:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# redistribute connected level-1
NS(config-router)# redistribute kernel level-1

ISIS 伝播の制限

設定をトラブルシューティングする必要がある場合は、任意の VLAN でリスニング専用モードを設定できます。

VTYSH コマンドラインを使用して ISIS 伝播を制限するには、次の手順を実行します。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSH コマンドプロンプトを表示します。
configure terminal グローバル構成モードに移行します。
router isis [tag] ルーティングプロセスの構成モードを開始します。
passive-interface <vlan_name> 指定された VLAN にバインドされたインターフェイスのルーティングアップデートを抑制します。

例:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# passive-interface VLAN0

ISIS 設定の確認

VTYSH を使用すると、指定した VLAN の ISIS ルーティングテーブルおよび ISIS 情報を表示できます。

VTYSH コマンドラインを使用して ISIS 設定を表示するには、次の手順を実行します。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSH コマンドプロンプトを表示します。
show ip isis route 更新された IPv4 ISIS ルーティングテーブルを表示します。
show ipv6 isis route 更新された IPv6 ISIS ルーティングテーブルを表示します。
sh isis interface <vlan_name> 指定された VLAN の IPv6 ISIS 情報を表示します。

例:

NS# VTYSH
NS#  show ip isis route
NS#  show ipv6 isis route
NS# sh isis interface VLAN0
ISIS の設定