Citrix ADC

ルーティングプロトコルを使用した Cisco Nexus 7000 スイッチを使用したクラスタ ECMP の設定

クラスタ構成上のECMPを使用すると、Citrix ADCアプライアンスはルーティングプロトコルを介してトラフィックを処理できます。ECMP メカニズムは、すべてのアクティブなクラスタノードを介して仮想サーバの IP アドレスをアドバタイズするのに役立ちます。

ECMP を使用するには、まずクラスタ IP アドレスで BGP プロトコルを有効にする必要があります。インターフェイスとスポッティング IP アドレス(ダイナミックルーティングが有効の場合)を VLAN にバインドします。選択したルーティングプロトコルを構成し、VTYSHシェルを使用してZebOSでカーネルルートを再配布します。

ユースケース:Cisco Nexus 7000 スイッチとルーティングプロトコルを使用したクラスタ ECMP

Cisco Nexus7000スイッチを使用したクラスタ展開の例を考えてみましょう。

  • Nexusスイッチ(アップストリーム)に接続された2つのCitrix ADCアプライアンス(ノード1とノード2)
  • 2 つのCisco Nexus 7000 スイッチ.
  • クライアントとサーバ(Nexus スイッチ経由の HTTP トラフィックの描画)クライアント側でホットスタンバイルータプロトコル(HSRP)が有効になっている場合。

Citrix Cisco Nexus 7000

前提条件

Citrix ADCアプライアンスでクラスタノードを構成する前に、次の点を考慮してください。

  1. すべてのアプライアンスは、同じプラットフォームタイプである必要があります。
  2. クラスタノードでボーダーゲートウェイプロトコル(BGP)を有効にする必要があります。

Citrix ADCアプライアンスでCLIを使用して構成する

  1. アプライアンス(NSIPアドレス1.1.1.1のアプライアンスなど)にログオンします。

  2. クラスターノードを追加します。

    add cluster node 0 1.1.1.2 –state ACTIVE –backplane 0/10/8
    
  3. クラスター IP アドレスを追加するには

    add ns ip 1.1.1.10 255.255.255.254 –type clip
    
  4. 構成を保存します

    save ns config
    
  5. アプライアンスのウォームリブート

    reboot -warm
    
  6. クリップ (CLIP) を使用してノード 1 を追加するには

    add cluster node 1 2.2.2.2 –state ACTIVE –backplane 1/10/8
    
  7. ノードをクラスタに参加するには

    join cluster –clip 1.1.1.10 –password nsroot
    
  8. CLIP で次の設定を行います。

    • enable ns feature bgp ospf DYNAMICROUTING

    • add ns ip 11.1.1.3 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.7 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.5 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

    • add ns ip 11.1.1.9 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

Cisco Nexusルーター(11.1.1.2/31および11.1.1.4/31)で、コマンドラインを使用して次の構成を実行する必要があります:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

    >  interface vlan100
    no shutdown
    ip address 50.1.1.1/8
    hsrp 50
    ip 50.50.50.50
    
    >  interface Ethernet 4/15
    ip address 11.1.1.2/31
    no shutdown
    
    >  interface Ethernet 4/19
    ip address 11.1.1.4/31
    no shutdown
    
    >  interface Ethernet 4/22
    switchport
    switchport access vlan 100
    

Cisco Nexusルーター(11.1.1.6/31および11.1.1.8/31)で、コマンドラインを使用して次の構成を実行する必要があります:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

    >  interface vlan100
    no shutdown
    no ip redirects
    ip address 50.1.1.2/8
    hsrp 50
    ip 50.50.50.50
    
    >  interface Ethernet 4/13
    ip address 11.1.1.6/31
    no shutdown
    
    >  interface Ethernet 4/15
    ip address 11.1.1.8/31
    no shutdown
    
    >  interface Ethernet 4/22
    switchport
    switchport access vlan 100
    

BGPプロトコルの場合、Citrix ADCアプライアンスのCLIPで次の構成を実行する必要があります。

>  vtysh
ns# router bgp 1
redistribute kernel
owner-node 0
neighbor 11.1.1.2 remote-as 2
neighbor 11.1.1.2 as-origination-interval 1
neighbor 11.1.1.2 advertisement-interval 0
neighbor 11.1.1.6 remote-as 2
neighbor 11.1.1.6 as-origination-interval 1
neighbor 11.1.1.6 advertisement-interval 0
owner-node 1
neighbor 11.1.1.4 remote-as 2
neighbor 11.1.1.4 as-origination-interval 1
neighbor 11.1.1.4 advertisement-interval 0
neighbor 11.1.1.8 remote-as 2
neighbor 11.1.1.8 as-origination-interval 1
neighbor 11.1.1.8 advertisement-interval 0
exit-owner-node

Cisco Nexusルータ(11.1.1.3および11.1.1.5)で次の設定を実行します。

> ip access-list acl1
10 permit ip 50.0.0.0/8 any
route-map test permit
match ip address acl1
router bgp 2
address-family ipv4 unicast
redistribute direct route-map test
maximum-paths 2
neighbor 11.1.1.3 remote-as 1
address-family ipv4 unicast
neighbor 11.1.1.5 remote-as 1
アドレスファミリipv4ユニキャスト

Cisco Nexusルータ(11.1.1.7および11.1.1.9)で次の設定を実行します。

> ip access-list acl1
10 permit ip 50.0.0.0/8 any
route-map test permit 1
match ip address acl1
router bgp 2
address-family ipv4 unicast
redistribute direct route-map test
maximum-paths 2
neighbor 11.1.1.7 remote-as 1
address-family ipv4 unicast
neighbor 11.1.1.9 remote-as 1
address-family ipv4 unicast

OSPFプロトコルの場合、Citrix ADCアプライアンスのCLIPで次の構成を実行する必要があります。

> vtysh
ns# router osfp 1
redistribute kernel
owner-node 0
network 15.1.1.2/31 area 0
network 15.1.1.6/31 area 0
exit-owner-node

owner-node 1
network 15.1.1.4/31 area 0
network 15.1.1.8/31 area 0
exit-owner-node

route-map map2 permit 1
set metric 10

Cisco Nexusルーター(11.1.1.2/31および11.1.1.4/31)で、コマンドラインを使用して次の構成を実行する必要があります:

> route-map- map2 permit 1
set metric 10

interface Ethernet4/15
ip address 15.1.1.2/31
ip router ospf 1 area 0.0.0.0
no shutdown

interface Ethernet4/19
ip address 15.1.1.4/31
ip router ospf 1 area 0.0.0.0
no shutdown

router ospf 1
router-id 1.1.1.1
redistribute direct route-map map2

Cisco Nexus ルータ(11.1.1.7/31 および 11.1.1.9/31)では、コマンドラインを使用して次の設定を実行する必要があります。

> route-map- map2 permit 1
set metric 10

interface Ethernet4/13
ip address 15.1.1.6/31
ip router ospf 1 area 0.0.0.0
no shutdown

interface Ethernet4/15
ip address 15.1.1.8/31
ip router ospf 1 area 0.0.0.0
no shutdown

router ospf 1
router-id 1.1.1.2
redistribute direct route-map map2
ルーティングプロトコルを使用した Cisco Nexus 7000 スイッチを使用したクラスタ ECMP の設定