Citrix ADC

ISIS の設定

Citrix ADCアプライアンスは、Intermediate System-to-Intermediate System(IS-ISまたはISIS)動的ルーティングプロトコルをサポートします。このプロトコルは、IPv4およびIPv6ルート交換をサポートします。IS‑ISはリンクステートプロトコルであるため、ルーティングループが発生しにくくなっています。より高速なコンバージェンスとより大規模なネットワークをサポートする機能の利点により、ISISはインターネットサービスプロバイダー(ISP)ネットワークで非常に役立ちます。

ISISを構成するための前提条件

ISISの構成を開始する前に、次のことを行ってください。

  • ISISプロトコルを理解していることを確認してください。
  • IPV6 ルートでは、以下を有効にします。
    • IPv6プロトコル変換機能。
    • ISISプロトコルを実行するVLANのIPv6動的ルーティングオプション。

ISIS の有効化

次のいずれかの手順を使用して、Citrix ADCアプライアンスでISISルーティング機能を有効にします。

CLI を使用して ISIS ルーティングを有効にするには、次の手順を実行します。

コマンドプロンプトで入力します。

enable ns feature ISIS

GUI を使用して ISIS ルーティングを有効にするには、次の手順を実行します。

  1. [システム] > [設定] に移動し、[モードと機能] で [高度な機能の変更] をクリックします。
  2. ISISルーティングオプションを選択またはクリアします。

ISISルーティングプロセスを作成し、VLANで開始する

ISISルーティングプロセスを作成するには、VTYSHコマンドラインを使用する必要があります。

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSH コマンドプロンプトを表示します。
configure terminal グローバル構成モードに移行します。
router ISIS [tag] ルーティングプロセスの ISIS ルーティングプロセスおよび構成モードを作成します。
net XX….XXXX.YYYY.YYYY.YYYY.00 ルーティングプロセスのNET値を指定します。ここで、 ・XX。 .. .XXXX はエリアアドレス(1〜13バイト)、 ・YYYY.YYYY.YYYY はシステムID(6バイト)、 ・00 はNセレクター(1バイト)です。
is-type (level-1|level-1-2|level-2-only) ISISルーティングプロセスを指定されたルーティングレベルに設定します。デフォルト:レベル1-2。
ns IPv6-routing IPv6動的ルーティングデーモンを開始します。
interface <vlan_name> VLAN 構成モードを開始します。
ip router ISIS IPv4 ルート交換用の VLAN 上で ISIS ルーティングプロセスを有効にします。
ipv6 router ISIS IPv6 ルート交換用の VLAN 上で ISIS ルーティングプロセスを有効にします。

例:

> VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# net 15.aabb.ccdd.0097.00
NS(config-router)# is-type level-1
NS(config-router)# exit
NS(config)# ns IPv6-routing
NS(config)# interface vlan0
NS(config-if)#  ip router isis 11
NS(config-if)# ipv6 router isis 11
<!--NeedCopy-->

アドバタイズルート

ルートアドバタイズメントにより、アップストリームルーターはCitrix ADCアプライアンスの背後にあるネットワークエンティティを追跡できます。

VTYSHコマンドラインを使用してルートをアドバタイズするようにISISを設定するには:

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードに移行します。
router ISIS [tag] ISIS ルーティングインスタンスを起動し、ルーティングプロセスの構成モードを開始します。
redistribute connected (level-1 or level-1-2 or level-2) 接続されたルートを再配布します。ここで、 レベル1: 接続されたルートをレベル1、 レベル1-2に再配布します : 接続されたルートをレベル1とレベル2、 レベル2に再配布します : 接続されたルートをレベル2に再配布します。
redistribute kernel (level-1 or level-1-2 or level-2) カーネルルートを再配布します。ここで、 レベル1: カーネルルートをレベル1、 レベル1-2に再配布します : カーネルルートをレベル1とレベル2、 レベル2に再配布します : カーネルルートをレベル2に再配布します。

例:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# redistribute connected level-1
NS(config-router)# redistribute kernel level-1
<!--NeedCopy-->

ISISの伝播を制限する

設定のトラブルシューティングが必要な場合は、任意のVLANでリッスン専用モードを設定できます。

VTYSHコマンドラインを使用してISISの伝播を制限するには:

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSHコマンドプロンプトを表示します。
configure terminal グローバル構成モードに移行します。
router isis [tag] ルーティングプロセスの構成モードを開始します。
passive-interface <vlan_name> 指定されたVLANにバインドされたインターフェイスでのルーティング更新を抑制します。

例:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# passive-interface VLAN0
<!--NeedCopy-->

ISIS構成の確認

VTYSHを使用して、指定したVLANのISISルーティングテーブルとISIS情報を表示できます。

VTYSHコマンドラインを使用してISIS設定を表示するには:

コマンドプロンプトで、次のコマンドを次の順序で入力します。

コマンド 説明
VTYSH VTYSHコマンドプロンプトを表示します。
show ip isis route 更新されたIPv4ISISルーティングテーブルを表示します。
show ipv6 isis route 更新されたIPv6ISISルーティングテーブルを表示します。
sh isis interface <vlan_name> 指定されたVLANのIPv6ISIS情報を表示します。

例:

NS# VTYSH
NS#  show ip isis route
NS#  show ipv6 isis route
NS# sh isis interface VLAN0
<!--NeedCopy-->
ISIS の設定