録画を開いて再生する

録画を開く

セッション録画は、Session Recording Playerで次の3つの方法で開くことができます。

  • Session Recording Playerを使用して検索を実行します。検索条件を満たす録画セッションが検索結果領域に表示されます。
  • ローカルディスクドライブまたは共有ドライブから録画セッションファイルに直接アクセスします。
  • お気に入りフォルダーから録画セッションファイルにアクセスします。

デジタル署名なしで録画されたファイルを開くと、警告メッセージが表示されます。このメッセージは、ファイルの出所と整合性が検証されていないことを示します。ファイルの整合性に問題がないと確信できる場合は、警告ウィンドウではいをクリックしてファイルを開きます。

再生理由のログ記録が有効になっている場合、録画を再生するたびに、再生理由の入力を求めるダイアログボックスが表示されます。詳しくは、「再生ログ」を参照してください。

Session Recording Playerは、録画セッションを再生する前にCitrix Workspace™アプリのバージョンを確認します。プレーヤーがCitrix Workspaceアプリのバージョンをサポートしていない場合、エラーが返されます。このエラーを解消するには、Session Recording ServerのプロパティでCitrix Workspaceアプリのバージョンチェックをスキップを選択します。

Citrix Workspaceアプリのバージョンチェックをスキップ

注:

Session Recordingの管理者ログ機能を使用すると、Session Recording Playerでの録画のダウンロードをログに記録できます。詳しくは、「管理者ログ」を参照してください。

検索結果領域で録画を開く

  1. Session Recording Playerがインストールされているマシンにログオンします。
  2. スタートメニューから、セッション レコーディング プレイヤーを選択します。
  3. 検索を実行します。
  4. 検索結果領域が表示されていない場合は、ワークスペースペインで 検索結果 を選択します。
  5. 検索結果領域で、再生したいセッションを選択します。
  6. 次のいずれかを実行します。
    • セッションをダブルクリックします。
    • 右クリックして 再生 を選択します。
    • Session Recording Player メニューバーから、再生 > 再生 を選択します。

ファイルにアクセスして録画を開く

録画ファイルの名前は i_ で始まり、その後に一意の英数字ファイルID、そして .icl または .icle 拡張子が続きます。.icl 拡張子は再生保護が適用されていない録画を示します。.icle 拡張子は再生保護が適用されている録画を示します。録画されたセッションファイルは、セッションが録画された日付を含むフォルダーに保存されます。たとえば、2014年12月22日に録画されたセッションのファイルは、フォルダーパス 2014\12\22 に保存されます。

  1. Session Recording Player がインストールされているワークステーションにログオンします。
  2. スタートメニューから、セッション レコーディング プレイヤーを選択します。
  3. 次のいずれかを実行します。
    • Session Recording Player メニューバーから、ファイル > 開く を選択し、ファイルを検索します。
    • Windows エクスプローラーを使用してファイルに移動し、そのファイルを プレーヤー ウィンドウにドラッグします。
    • Windows エクスプローラーを使用してファイルに移動し、ファイルをダブルクリックします。
    • 「ワークスペース」ペインで「お気に入り」を作成した場合は、「お気に入り」を選択し、検索結果領域からファイルを開くのと同じ方法で、「お気に入り」領域からファイルを開きます。

お気に入りを使用する

「お気に入り」フォルダーを作成すると、頻繁に表示する録画にすばやくアクセスできます。これらの「お気に入り」フォルダーは、ワークステーションまたはネットワークドライブに保存されている録画セッションファイルを参照します。これらのファイルを他のワークステーションにインポートおよびエクスポートしたり、これらのフォルダーを他のSession Recording Playerユーザーと共有したりできます。

注:

Session Recording Playerへのアクセス権を持つユーザーのみが、「お気に入り」フォルダーに関連付けられている録画セッションファイルをダウンロードできます。アクセス権については、Session Recording管理者にお問い合わせください。

「お気に入り」サブフォルダーを作成するには:

  1. Session Recording Playerがインストールされているワークステーションにログオンします。
  2. 「スタート」メニューから、「セッションレコーディングプレーヤー」を選択します。
  3. Session Recording Playerウィンドウで、「ワークスペース」ペインの「お気に入り」フォルダーを選択します。
  4. メニューバーから、ファイル > フォルダー > 新しいフォルダーを選択します。「お気に入り」フォルダーの下に新しいフォルダーが表示されます。
  5. フォルダー名を入力し、Enterキーを押すか、任意の場所をクリックして新しい名前を確定します。

ファイル > フォルダーメニューに表示されるその他のオプションを使用して、フォルダーの削除、名前の変更、移動、コピー、インポート、およびエクスポートを行います。

録画を再生する

Session Recording Playerで録画セッションを開いた後、次の方法で録画セッションを移動できます。

  • プレーヤーコントロールを使用して、再生、停止、一時停止、および再生速度の増減を行います。
  • シークスライダーを使用して、前後に移動します。

挿入されたマーカーやカスタムイベントに移動して、記録されたセッションをナビゲートすることもできます。

注:

  • 記録されたセッションの再生中に、2つ目のマウスポインターが表示されることがあります。2つ目のポインターは、ユーザーがInternet Explorer内でナビゲートし、元々は画面よりも大きかったがInternet Explorerによって自動的に縮小された画像をクリックした記録の時点で表示されます。セッション中はポインターが1つしか表示されませんが、再生中は2つ表示されることがあります。
  • このバージョンのSession Recordingは、SpeedScreen Multimedia AccelerationおよびFlash品質調整ポリシー設定をサポートしていません。このオプションが有効になっている場合、再生時に黒い四角が表示されます。
  • 4096 x 4096以上の解像度でセッションを記録すると、記録の表示に断片が生じる場合があります。

プレーヤーコントロールを使用する

プレーヤーウィンドウの下部にあるプレーヤーコントロールをクリックするか、Session Recording Playerメニューバーから再生を選択してアクセスできます。

プレーヤーコントロール 機能
再生ボタン 選択したセッションファイルを再生します。
一時停止ボタン 再生を一時停止します。
停止ボタン 再生を停止します。停止をクリックしてから再生をクリックすると、録画はファイルの最初から再開されます。
再生速度を遅くする 現在の再生速度を半分にし、通常速度の4分の1まで遅くします。
再生速度を速くする 現在の再生速度を2倍にし、通常速度の最大32倍まで速くします。

シークスライダーを使用する

プレーヤーウィンドウの下部にあるシークスライダーを使用して、記録されたセッション内の別の位置に移動します。シークスライダーを、表示したい録画のポイントまでドラッグするか、スライダーバーの任意の場所をクリックしてその位置に移動できます。

シークスライダーを制御するために、以下のキーボードキーも使用できます。

キーボードキー 機能
ホーム 先頭に移動します。
End 末尾に移動します。
右矢印 5秒早送りします。
左矢印キー 5秒巻き戻します。
マウスホイールを1ノッチ下に動かす 15秒早送りします。
マウスホイールを1ノッチ上に動かす 15秒巻き戻します。
Ctrl + 右矢印キー 30秒早送りします。
Ctrl + 左矢印キー 30秒巻き戻します。
ページダウン 1分早送りします。
ページアップ 1分巻き戻します。
Ctrl + マウスホイールを1ノッチ下に動かす 90秒早送りします。
Ctrl + マウスホイールを1ノッチ上に動かす 90秒巻き戻します。
コントロール + ページダウン 6分早送りします。
コントロール + ページアップ 6分巻き戻します。

シークスライダーの速度を調整するには、Session Recording Playerメニューバーから、ツール > オプション > プレーヤーを選択し、スライダーをドラッグしてシーク応答時間を増減させます。応答時間が速いほど、より多くのメモリが必要になります。応答は、録画のサイズやマシンのハードウェアによって遅くなる場合があります。

再生速度を変更する

通常の再生速度の4分の1から32倍まで、指数関数的な増分で再生速度を設定できます。

  1. Session Recording Playerがインストールされているワークステーションにログオンします。
  2. スタートメニューから、セッションレコーディングプレーヤーを選択します。
  3. Session Recording Playerメニューバーから、再生 > 再生速度を選択します。
  4. 速度オプションを選択します。

速度はすぐに調整されます。指数関数的な速度を示すテキストが、プレーヤーウィンドウの下部に緑色で短時間表示されます。

記録されたセッションのアイドル期間を強調表示する

記録されたセッションのアイドル期間とは、何もアクションが行われない部分のことです。Session Recordingプレーヤーは、再生中に記録されたセッションのアイドル期間を強調表示できます。このオプションはデフォルトでオンになっています。詳細については、「アイドル期間の強調表示」を参照してください。

アクションが発生しなかったスペースをスキップする

高速レビューモードでは、アクションが発生しなかった記録セッションの部分をスキップするようにプレーヤーを設定できます。この設定により、再生の視聴時間を節約できます。ただし、アニメーション化されたマウスカーソル、点滅するカーソル、秒針が動く時計などのアニメーションシーケンスはスキップされません。

  1. Session Recordingプレーヤーがインストールされているワークステーションにログオンします。
  2. スタートメニューから、セッションレコーディングプレイヤーを選択します。
  3. Session Recording Playerメニューバーから、再生 > 高速レビューモードを選択します。

このオプションはオンとオフを切り替えます。選択するたびに、そのステータスがプレーヤーウィンドウに緑色で短時間表示されます。

再生表示を変更する

プレーヤーウィンドウに記録されたセッションが表示される方法を変更するには、次の操作を実行できます。

  • 画像をパンおよび拡大縮小する。
  • 全画面で再生を表示する
  • プレーヤーウィンドウを別のウィンドウに表示する
  • 記録されたセッションの周囲に赤い枠線を表示して、プレーヤーウィンドウの背景と区別する。

プレイヤーウィンドウを全画面で表示する

  1. Session Recording playerがインストールされているワークステーションにログオンします。
  2. スタートメニューから、セッションレコーディングプレイヤーを選択します。
  3. Session Recording Playerのメニューバーから、表示 > プレイヤーの全画面表示を選択します。
  4. 元のサイズに戻すには、EscまたはF11を押します。

プレイヤーウィンドウを別のウィンドウで表示する

  1. Session Recording playerがインストールされているワークステーションにログオンします。
  2. スタートメニューから、セッション レコーディング プレイヤーを選択します。
  3. Session Recording Playerのメニューバーから、表示 > プレイヤーを別のウィンドウで表示を選択します。プレイヤーウィンドウを含む新しいウィンドウが表示されます。このウィンドウはドラッグしてサイズを変更できます。
  4. プレイヤーウィンドウをメインウィンドウに埋め込むには、表示 > プレイヤーを別のウィンドウで表示を選択するか、F10を押します。

セッションの再生をプレイヤーウィンドウに合わせて拡大縮小する

  1. Session Recording playerがインストールされているワークステーションにログオンします。
  2. スタートメニューから、セッション レコーディング プレイヤーを選択します。
  3. Session Recording Playerのメニューバーから、再生 > パンと拡大縮小 > 画面に合わせるを選択します。
    • 画面に合わせる (高速レンダリング) は、画質を維持しながら画像を縮小します。画像は高品質オプションを使用するよりも速く描画されますが、画像やテキストは鮮明ではありません。高品質モードを使用しているときにパフォーマンスの問題が発生する場合は、このオプションを使用してください。
    • 画面に合わせて拡大/縮小 (高品質) は、画像を縮小しつつ高品質を提供します。このオプションを使用すると、高速レンダリングオプションよりも画像の描画が遅くなる可能性があります。

画像をパンする

  1. Session Recording Playerがインストールされているワークステーションにログオンします。
  2. 「スタート」メニューから、「セッションレコーディングプレイヤー」を選択します。
  3. 「Session Recording Player」メニューバーから、「再生 > パンと拡大縮小 > パン」を選択します。ポインターが手の形に変わり、プレーヤーウィンドウの右上隅に画面の小さな表示が現れます。
  4. 画像をドラッグします。小さな表示は、画像内の現在位置を示します。
  5. パンを停止するには、拡大縮小オプションのいずれかを選択します。

Session Recordingの周囲に赤い枠線を表示する

  1. Session Recording Playerがインストールされているワークステーションにログオンします。
  2. 「スタート」メニューから、「セッションレコーディングプレイヤー」を選択します。
  3. 「Session Recording Player」メニューバーから、「ツール > オプション > プレーヤー」を選択します。
  4. 「セッション記録の周囲に枠線を表示」チェックボックスをオンにします。 「セッション記録の周囲に枠線を表示」チェックボックスが選択されていない場合、ポインターがプレーヤーウィンドウ内にあるときに、マウスの左ボタンをクリックしたままにすると、一時的に赤い枠線を表示できます。