Product Documentation

Configuring ISIS

Sep 01, 2016

The NetScaler appliance supports the Intermediate System-to-Intermediate System (IS-IS or ISIS) dynamic routing protocol. This protocol supports IPv4 as well as IPv6 route exchanges. IS‑IS is a link state protocol and is therefore less prone to routing loops. With the advantages of faster convergence and the ability to support larger networks, ISIS can be very useful in Internet Service Provider (ISP) networks.

Prerequisites for configuring ISIS

Before you begin configuring ISIS, do the following:
  • Make sure that you understand the ISIS protocol.
  • For IPV6 routes, enable:
    • IPv6 protocol translation feature.
    • IPv6 Dynamic Routing option on the VLANs on which you want to run ISIS protocol. 

Enabling ISIS

Updated: 2013-08-30

Use either of the following procedures to enable the ISIS routing feature on the NetScaler appliance.

To enable ISIS routing by using the command line interface

At the command prompt, type:

enable ns feature ISIS

To enable ISIS routing by using the configuration utility

  1. Navigate to System > Settings, in Modes and Features group, click Change advanced features.
  2. Select or clear the ISIS Routing option.

Creating an ISIS Routing Process and Starting It on a VLAN

Updated: 2013-08-30

To create an ISIS routing process, you must use the VTYSH command line.

At the command prompt, type the following commands, in the order shown:
Command Description
VTYSH Displays VTYSH command prompt.
configure terminal Enters the global configuration mode.
router ISIS [tag] Creates an ISIS routing process and configuration mode for the routing process.
net XX....XXXX.YYYY.YYYY.YYYY.00 Specifies a NET value for the routing process, where:
  • · XX. .. .XXXX is the Area Address (can be 1-13 bytes)
  • · YYYY.YYYY.YYYY is the System ID (6 bytes)
  • · 00 is the N-selector (1 byte)
A NET value can be 8 to 20 bytes in length. The last byte is always the n-selector, and must be zero. The n-selector indicates that there is no transport entity and means that the packet is for the routing software of the appliance. The six bytes directly preceding the n-selector are the system ID. The system ID length is fixed and cannot be changed. The system ID must be unique throughout each area (Level 1) and throughout the backbone (Level 2). The bytes preceding the system ID are the area ID, which can be from 1 to 13 bytes in length. A maximum of three NETs per routing process are allowed with different area ID, but the system ID should be the same for all NETs.
is-type (level-1|level-1-2|level-2-only) Sets the ISIS routing process to the specified level of routing. Default: level-1-2.
ns IPv6-routing Starts the IPv6 dynamic routing daemon.
interface <vlan_name> Enters the VLAN configuration mode.
ip router ISIS Enables the ISIS routing process on the VLAN for IPv4 route exchanges.
ipv6 router ISIS Enables the ISIS routing process on the VLAN for IPv6 route exchanges.
Example
> VTYSH 
NS# configure terminal 
NS(config)# router isis 11 
NS(config-router)# net 15.aabb.ccdd.0097.00 
NS(config-router)# is-type level-1 
NS(config-router)# exit 
NS(config)# ns IPv6-routing 
NS(config)# interface vlan0 
NS(config-if)#  ip router isis 11 
NS(config-if)# ipv6 router isis 11

Advertising Routes

Updated: 2013-08-30

Route advertisement enables an upstream router to track network entities located behind the NetScaler appliance.

To configure ISIS to advertise routes by using the VTYSH command line

At the command prompt, type the following commands, in the order shown:
Command Description
VTYSH Displays the VTYSH command prompt.
configure terminal Enters the global configuration mode.
router ISIS [tag] Starts the ISIS routing instance and enter configuration mode for the routing process.
redistribute connected (level-1|level-1-2|level-2) Redistributes connected routes, where
  • level-1 : Redistribute connected routes into Level-1.
  • level-1-2 : Redistribute connected routes into Level-1 and Level-2.
  • level-2 : Redistribute connected routes into Level-2.
redistribute kernel(level-1|level-1-2|level-2) Redistributes kernel routes, where:
  • level-1 : Redistribute kernel routes into Level-1.
  • level-1-2 : Redistribute kernel routes into Level-1 and Level-2.
  • level-2 : Redistribute kernel routes into Level-2.

Example

>VTYSH 
NS# configure terminal 
NS(config)# router isis 11 
NS(config-router)# redistribute connected level-1 
NS(config-router)# redistribute kernel level-1

Limiting ISIS Propagations

Updated: 2013-08-30

If you need to troubleshoot your configuration, you can configure the listen-only mode on any given VLAN.

To limit ISIS propagation by using the VTYSH command line

At the command prompt, type the following commands, in the order shown:
Command Description
VTYSH Displays the VTYSH command prompt.
configure terminal Enters the global configuration mode.
router isis [tag] Enters the configuration mode for the routing process.
passive-interface <vlan_name> Suppresses routing updates on interfaces bound to the specified VLAN.

Example

>VTYSH 
NS# configure terminal 
NS(config)# router isis 11 
NS(config-router)# passive-interface VLAN0

Verifying the ISIS Configuration

Updated: 2013-08-30

You can use VTYSH to display the ISIS routing table and ISIS information for a specified VLAN.

To view the ISIS settings by using the VTYSH command line

At the command prompt, type the following commands, in the order shown:
Commands Description
VTYSH Displays the VTYSH command prompt.
show ip isis route Displays updated IPv4 ISIS routing table.
show ipv6 isis route Displays updated IPv6 ISIS routing table.
sh isis interface <vlan_name> Displays IPv6 ISIS information for the specified VLAN.
Example
NS# VTYSH 
NS#  show ip isis route 
NS#  show ipv6 isis route 
NS# sh isis interface VLAN0