Product Documentation

System Requirements for Worx Apps

Feb 05, 2015

This topic describes the operating systems and XenMobile component versions that are supported for Worx apps. The topic also lists the requirements for uploading WorxMail and WorxWeb to App Controller, for enabling remote connections through NetScaler Gateway, and for running the Worx apps on iOS and Android mobile devices.

  • You can upload WorxMail and WorxWeb wrapped mobile apps to AppController 2.6, App Controller 2.8, App Controller 2.9, and App Controller 2.10.
    Important: Android apps (.apk files) are limited to 20 MB. You must wrap larger apps in multiple parts.
  • Remote users can connect through NetScaler Gateway 10.1.
  • To allow users to connect from an Android device through NetScaler Gateway, the Android device must be running a minimum of Version 4.0.
  • To allow users to connect from an iOS device through NetScaler Gateway, the iOS device must be running a minimum of Version 5.1.
App type iOS Android App Controller NetScaler Gateway Device Manager
Device Manager only 5.1 2.3 N/A 10.1 9.0
Enterprise 6.0 4.0 2.6, 2.8, 2.9, and 2.10 10.1 9.0

WorxMail Requirements

WorxMail supports mail from the following mail servers on iOS, Android, and Windows Phone devices:

  • Exchange Server 2013
  • Exchange Server 2010 SP3
  • Exchange Server 2010 SP2
  • Exchange Server 2007 SP1 (iOS and Android only)
  • Microsoft Office 365
  • iOS only: IBM Notes Traveler 9.0.0.1 or 9.0.1

Device Requirements

You can run Worx apps on iOS and Android devices with the following minimum operating systems:

iOS devices

  • Worx Home, minimum iOS 5.1
  • WorxWeb, minimum iOS 6
  • WorxMail, minimum iOS 6

    Includes all devices

Android devices

  • Worx Home, minimum Android 2.3
  • WorxWeb, minimum Android 2.3
    Note: In a configuration with Device Manager only, WorxHome and WorxWeb are supported only on Android 2.3.
  • WorxMail, minimum Android 4.0

    Includes phones, 7-inch and 10-inch tablets