Citrix ADC

群集中的路由

群集中的路由工作方式与独立系统中的路由方式大致相同。需要注意的几点:

  • 所有路由配置必须从群集 IP 地址执行,并将配置传播到其他群集节点。

  • 路由限制为上游路由器支持的最大 ECMP 路由数。

  • 必须使用 owner-node 参数执行节点特定的路由配置,如下所示:

  router ospf
    owner-node 0
      ospf router-id 97.131.0.1
    exit-owner-node
  !

以下命令显示 VTYSH 中所有节点的统一群集配置。

show cluster-config

以下命令显示每个节点上的群集状态。

show cluser node

L2 群集中的 IPv4 路由

以下部分包含可帮助您在 L2 群集中配置 IPv4 OSPF 和 BGP 路由的示例配置。

添加斑点 SNIP 地址并启用动态路由

在以下配置中,启用 OSPF 和 BGP 路由。此外,还会添加斑点 SNIP 地址,并在这些 SNIP 地址上启用动态路由。

en ns fea ospf bgp
add vlan 10
add ns ip 10.10.10.1 255.255.255.0 -dynamicrouting enabled -ownernode 1
add ns ip 10.10.10.2 255.255.255.0 -dynamicrouting enabled -ownernode 2
add ns ip 10.10.10.3 255.255.255.0 -dynamicrouting enabled -ownernode 3
bind vlan 10 -ipaddress 10.10.10.1 255.255.255.0

VTYSH IPv4 OSPF 配置

要在 L2 群集中配置 IPv4 OSPF,您必须

  • 将优先级设置为零。
  • 将路由器 ID 配置为斑点配置。

注意

L2 群集的 OSPF 配置准则也适用于 OSPFv3。

在以下示例配置中配置了 IPv4 OSPF。

      interface vlan10
       IP OSPF PRIORITY 0
       !
      router ospf
          owner-node 1
            ospf router-id 97.131.0.1
          exit-owner-node
          owner-node 2
            ospf router-id 97.131.0.2
          exit-owner-node
          owner-node 3
            ospf router-id 97.131.0.3
          exit-owner-node
      network 10.10.10.0/24 area 0
      redistribute kernel
       !

VTYSH IPv4 BGP 配置

在以下 VTYSH 示例配置中,配置了 IPv4 BGP。

    router bgp 100
      neighbor 10.10.10.10 remote-as 200
     owner-node 1
      neighbor 10.10.10.10 update-source 10.10.10.1
     exit-owner-node
     owner-node 2
      neighbor 10.10.10.10 update-source 10.10.10.2
     exit-owner-node
     owner-node 3
      neighbor 10.10.10.10 update-source 10.10.10.3
     exit-owner-node
    redistribute kernel
    !

注意

更新源命令用于在以下配置中具有 owner-node 参数的每个邻居,以便与正确的源 IP 进行连接。

L2 群集中的 IPv6 路由

以下部分包含可帮助您在 L2 群集中配置 IPv6 OSPF 和 BGP 路由的示例配置。

启用 IPv6 路由

在 L2 群集中配置 IPv6 路由之前,必须启用 IPv6 功能。

要使用 CLE 启用 IPv6 路由,请

在命令提示窗口中,键入:

  • enable ns fea ipv6pt

添加斑点 SNIP6 地址并启用动态路由

在以下配置中,启用 OSPF 和 BGP 路由。此外,添加了斑点 SNIP6 地址,并在这些 SNIP6 地址上启用了动态路由。

add ns ip6 3ffa::1/64 -dynamicrouting enabled -ownernode 1
add ns ip6 3ffa::2/64 -dynamicrouting enabled -ownernode 2
add ns ip6 3ffa::3/64 -dynamicrouting enabled -ownernode 3
add vlan 10
bind vlan 10 -ipaddress 3ffa::1/64

VTYSH IPv6 BGP 配置

在以下 VTYSH 示例配置中,IPv6 BGP 已配置。

  router bgp 100
   neighbor 3ffa::10 remote-as 200
     owner-node 1
      neighbor 3ffa::10 update-source 3ffa::1
     exit-owner-node
     owner-node-2
      neighbor 3ffa::10 update-source 3ffa::2
     exit-owner-node
     owner-node-3
      neighbor 3ffa::10 update-source 3ffa::3
     exit-owner-node
   no neighbor 3ffa::10 activate
   address-family ipv6
    redistribute kernel
    neighbor 3ffa::10 activate
   exit-address-family
  !

安装 IPv6 学习路由

在 Citrix ADC 群集路由表中安装路由后,Citrix ADC 群集可以使用各种路由协议学习的路由。

使用 CLI 将 IPv6 学习路由安装到内部路由表:

在命令提示窗口中,键入:

  • ns route-install ipv6 bgp

  • ns route-install ipv6 ospf

  • ns route-install default

注意

  • 如果您必须在 IPv6 邻居上交换 IPv4 路由,则必须从早期配置中删除no neighbor 3ffa::10 active VTYSH 命令。

  • 必须为每个所有者节点使用update-source VTYSH 命令,以便在连接到 BPG IPv4 配置中给出的 BGP 对等方时指定正确的 IPv6 源 IP。

L3 群集中的路由

只有在 Citrix ADC 设备上完成以下配置时,L3 群集中的路由才有效。

  • 为 VLAN 启用动态路由。

     set vlan <id> -dynamicrouting enabled
    
  • 要访问所有群集节点,必须通过路由协议和set vlan 命令来播发 VIP、CLIP 和 Citrix ADC IP (NSIP)。

L3 群集中 BGP 的部署方案

考虑一个示例,其中所有群集节点都分组在一个为 100 的网络中,而上游路由器位于不同的亚斯 200 中。

下图描述了群集安装程序中的“A 100”和“A 200”部署。

本地化后的图片

在此部署中,CLIP 向上游路由器发布 CCO。某些群集节点会删除播发流量,因为检测到了 as 循环。

要解决此问题,请在 vtysh BGP 路由器模式中为每个邻居配置以下命令。

在 VTYSH 命令提示符下,键入:

neighbor <peer_ip> allowas-in 1

作为最佳做法,Citrix 建议您配置以下任一项:

  • 配置路由映射以仅了解群集节点上的所需网络,例如:默认路由、Citrix ADC IP (NSIP) 和 NSIP 子网。

  • 配置上游路由,以便仅公布群集中所需的网络,如 CLIP 和 Citrix ADC IP (NSIP)。

群集中的路由