配置 ISIS

Citrix ADC 设备支持中间系统到中间系统 (IS-IS 或 ISIS) 动态路由协议。此协议支持 IPv4 以及 IPv6 路由交换。IS‑S 是一种链路状态协议,因此不太容易进行路由循环。ISIS 在 Internet 服务提供商 (ISP) 网络中具有更快的融合和支持更大的网络的优势。

配置 ISIS 的必备条件

在开始配置 ISIS 之前,请执行以下操作:

  • 请确保您了解 ISIS 协议。
  • 对于 IPv6 路由,启用:
    • IPv6 协议转换功能。
    • 要运行 ISIS 协议的 VLAN 上的 IPv6 动态路由选项。

启用 ISIS

使用以下过程之一在 Citrix ADC 设备上启用 ISIS 路由功能。

要使用 CLI 启用 ISIS 路由,请执行以下操作:

在命令提示窗口中,键入:

enable ns feature ISIS

要使用 GUI 启用 ISIS 路由,请执行以下操作:

  1. 导航到“系统”>“设置”,在“模式和功能”组中,单击“更改高级功能”。
  2. 选择或清除 ISIS 路由选项。

创建 ISIS 路由进程并在 VLAN 上启动它

要创建 ISIS 路由过程,您必须使用 VTYSH 命令行。

在命令提示符下,按所示顺序键入以下命令:

命令 说明
VTYSH 显示 VTYSH 命令提示符。
configure terminal 进入全局配置模式。
路由器 ISIS[标签] 为路由过程创建 ISIS 路由流程和配置模式。
net XX….XXXX.YYYY.YYYY.YYYY.00 指定路由过程的一个 NET 值,其中: ·XX… .XXXX 是区域地址(可以是 1-13 字节), ·YYYYYYYYYYYYY 是系统 ID(6 字节), ·00 是 N 选择器(1 字节)。
is-type (level-1|level-1-2|level-2-only) 将 ISIS 路由过程设置为指定的路由级别。默认值:level-1-2。
ns IPv6-routing 启动 IPv6 动态路由守护进程。
<vlan_name>介面 进入 VLAN 配置模式。
ip router ISIS 在 VLAN 上启用 IPv4 路由交换的 ISIS 路由流程。
IPv6 路由器 ISIS 在 VLAN 上启用 IPv6 路由交换的 ISIS 路由过程。

示例:

> VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# net 15.aabb.ccdd.0097.00
NS(config-router)# is-type level-1
NS(config-router)# exit
NS(config)# ns IPv6-routing
NS(config)# interface vlan0
NS(config-if)#  ip router isis 11
NS(config-if)# ipv6 router isis 11

广告路线

路由播发使上游路由器能够跟踪位于 Citrix ADC 设备后面的网络实体。

要使用 VTYSH 命令行将 ISIS 配置为通告路由,请执行以下操作:

在命令提示符下,按所示顺序键入以下命令:

命令 说明
VTYSH 显示 VTYSH 命令提示符。
configure terminal 进入全局配置模式。
路由器 ISIS[标签] 启动 ISIS 路由实例并进入路由过程的配置模式。
重新分配连接(level-1、level-1-2 或 level-2) 重新分配连接的路由,其中:level-1:将连接的路由重新分配到 Level-1,level-1-2:将连接的路由重新分配到 Level-1 和 Level-2,level-2:将连接的路由重新分配到 Level-2。
重新分发内核(level-1、level-1-2 或 level-2) 重新分配内核路由,其中:level-1:将内核路由重新分配到 Level-1,level-1-2:将内核路由重新分配到 Level-1 和 Level-2,level-2:将内核路由重新分配到 Level-2。

示例:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# redistribute connected level-1
NS(config-router)# redistribute kernel level-1

限制 ISIS 的传播

如果您需要对配置进行故障排除,可以在任何给定 VLAN 上配置只听模式。

要使用 VTYSH 命令行限制 ISIS 传播,请执行以下操作:

在命令提示符下,按所示顺序键入以下命令:

命令 说明
VTYSH 显示 VTYSH 命令提示符。
configure terminal 进入全局配置模式。
router isis [标签] 进入路由过程的配置模式。
passive-interface <vlan_name> 禁止绑定到指定 VLAN 的接口上的路由更新。

示例:

>VTYSH
NS# configure terminal
NS(config)# router isis 11
NS(config-router)# passive-interface VLAN0

验证 ISIS 配置

您可以使用 VTYSH 显示指定 VLAN 的 ISIS 路由表和 ISIS 信息。

要使用 VTYSH 命令行查看 ISIS 设置,请执行以下操作:

在命令提示符下,按所示顺序键入以下命令:

命令 说明
VTYSH 显示 VTYSH 命令提示符。
show ip isis route 显示更新的 IPv4 ISIS 路由表。
show ipv6 isis route 显示更新的 IPv6 ISIS 路由表。
sh isis interface <vlan_name> 显示指定 VLAN 的 IPv6 ISIS 信息。

示例:

NS# VTYSH
NS#  show ip isis route
NS#  show ipv6 isis route
NS# sh isis interface VLAN0