Citrix ADC

Citrix ADC 中的任意广播支持

任意广播是一种网络,其中一组服务器共享相同的 IP 地址。根据客户端的路由表将客户端请求定向到地形上最近的服务器。此路由可减少延迟问题,确保高可用性,并最大限度地缩短停机时间。

Citrix ADC 支持具有全局服务器负载平衡 (GSLB) 和 DNS 功能的任意广播网络。

下图说明了 Citrix ADC 中的任意广播的拓扑图。

本地化后的图片

任意广播 GSLB

Citrix ADC GSLB 功能提供跨全球分布的站点的负载平衡以及灾难恢复,确保应用程序的持续可用性。

在停机期间,GSLB 通过将流量路由到最近或性能最佳的数据中心,提供即时灾难恢复。但是,GSLB 无法控制以下情况:

  • DNS 流量如何路由到位于不同地理位置的 GSLB 节点。
  • DNS 查询路由到 GSLB 节点时会增加多少延迟。

在典型的 GSLB 设置中,每个数据中心都有一个 GSLB 节点,配置了特定于站点的权威域名服务器 (ADNS) 以接收 DNS 查询。每个站点的 ADNS 都配置为 DNS 解析器中的名称服务器。随着 GSLB 节点数量的增加,名称服务器记录的数量也会增加。在这种情况下,如果数据中心出现故障,LDNS 必须使用不同的名称服务器重试解析,这将增加 DNS 解析中的延迟。 此外,每次添加 GSLB 节点时,必须更新名称服务器记录。

要克服这些缺点,您可以使用任意广播 ADNS。在任意广播 ADNS 中,单个 ADNS IP 地址用于所有 GSLB 节点,并且 DNS 流量通过动态路由路由到 GSLB 节点。

例如,如果 GSLB 站点设置为“DOWN”(关闭),则会更新路由表并移除到此站点的路由。因此,DNS 查询不会发送到已关闭的站点。因此,没有重试。

此外,如果添加了新的 GSLB 节点,则将为新节点分配相同的 ADNS IP 地址。动态路由会根据路由算法自动使用到新站点的路由更新路由表。因此,您不必更新 DNS 名称服务器记录。使用任意广播,新的 GSLB 站点的推出变得更加简单,速度更快。

如何在任意广播模式下配置 ADNS IP 地址

必须在 Citrix ADC 中的 ADNS IP 上启用主机路由,并设置相应的路由运行状况注入 (Route Health Injection, RHI) 级别。大多数情况下,ADNS IP 上不会有任何虚拟服务器,因此必须选择 RHI 级别为“NONE”(无)。在 ADNS IP 上启用主机路由使其成为内核路由。然后,您可以启用选择的动态路由,并配置路由协议以重新分发内核路由。

ADNS IP 配置 - 示例

在命令提示窗口中,键入:

add service adns_public 5.5.5.5 ADNS 53

set ip 5.5.5.5 -hostRoute ENABLED -vserverRHILevel ALL_VSERVERS

GSLB 站点中的 BGP 配置 - 示例

Site1#sh run
!
hostname Site1
!
log syslog
log record-priority
!
ns route-install bgp
!
interface lo0
 ip address 127.0.0.1/8
 ipv6 address fe80::1/64
 ipv6 address ::1/128
!
interface vlan0
 ip address 10.102.148.94/25
 ipv6 address fe80::e84c:f4ff:fe74:4588/64
!
interface vlan2
 ip address 172.18.30.15/24
!
router bgp 5
 redistribute kernel -----> redistributing the kernel routes
 neighbor 172.18.30.30 remote-as 4
 neighbor 172.18.30.30 advertisement-interval 1
 neighbor 172.18.30.30 timers 4 16
!
End

Site1#

GSLB 站点路由表 - 示例

Site1#sh ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
       O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, I - Intranet
       * - candidate default

K       5.5.5.5/32 via 0.0.0.0 ---------------------------------------> Kernel Route for ADNS
C       10.102.148.0/25 is directly connected, vlan0
C       127.0.0.0/8 is directly connected, lo0
B       172.18.10.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       172.18.20.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
C       172.18.30.0/24 is directly connected, vlan2
B       192.168.3.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       192.168.5.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h
B       192.168.10.0/24 [20/0] via 172.18.30.30, vlan2, 01w5d22h

Gateway of last resort is not set
Site1#

任意广播 DNS

可以将任意广播 DNS 用于 Citrix ADC 上的 DNS 代理虚拟服务器。配置了多个 DNS 名称服务器时,DNS 解析器将根据轮询方法进行响应。例如,如果解析器没有收到来自第一台服务器的任何响应,则在配置的超时值过期后将切换到第二台服务器,依此类推。从第一台服务器切换到第二台服务器会增加 DNS 解析的延迟。如果 DNS 解析器配置了任意广播,则可以消除此延迟。

DNS 配置 — 示例

在命令提示窗口中,键入:

add lb vserver dns DNS 5.5.5.50 53

set ip 5.5.5.50 -hostRoute ENABLED -vserverRHILevel ALL_VSERVERS

Citrix ADC 中的任意广播支持