Citrix ADC

通过使用带有路由协议的 Cisco Nexus 7000 交换机配置群集 ECMP

通过群集设置 ECMP,Citrix ADC 设备能够通过路由协议处理流量。ECMP 机制有助于通过所有活动群集节点通告虚拟服务器 IP 地址。

要使用 ECMP,必须首先在群集 IP 地址上启用 BGP 协议。将接口和已发现的 IP 地址(启用动态路由)绑定到 VLAN。使用 VTYSH shell 配置选定的路由协议并在 ZeBOS 上重新分配内核路由。

用例:通过使用带有路由协议的 Cisco Nexus 7000 交换机设置 ECMP 群集

考虑使用 Cisco Nexus 7000 交换机进行群集部署的示例:

  • 两个 Citrix ADC 设备(节点 1 和节点 2),连接到 Nexus 交换机(上游)。
  • 两个 Cisco Nexus 7000 交换机。
  • 客户端和服务器(通过 Nexus 交换机绘制 HTTP 流量)。在客户端启用热备用路由器协议 (HSRP) 的情况下。

Citrix Cisco Nexus 7000

必备条件

在 Citrix ADC 设备上配置群集节点之前,请考虑以下几点。

  1. 所有设备必须具有相同的平台类型。
  2. 必须在群集节点上启用边界网关协议 (BGP)。

通过在 Citrix ADC 设备上使用 CLI 进行配置

  1. 登录到设备(例如,具有 NSIP 地址 1.1.1.1 的设备)

  2. 添加群集节点。

    add cluster node 0 1.1.1.2 –state ACTIVE –backplane 0/10/8
    
  3. 添加群集 IP 地址

    add ns ip 1.1.1.10 255.255.255.254 –type clip
    
  4. 保存配置

    save ns config
    
  5. 热重启设备

    reboot -warm
    
  6. 使用剪辑添加节点 1

    add cluster node 1 2.2.2.2 –state ACTIVE –backplane 1/10/8
    
  7. 将节点加入群集

    join cluster –clip 1.1.1.10 –password nsroot
    
  8. 在 CLIP 上执行以下配置

    • enable ns feature bgp ospf DYNAMICROUTING

    • add ns ip 11.1.1.3 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.7 255.255.255.254 –dynamicRouting ENABLED –ownerNode 0

    • add ns ip 11.1.1.5 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

    • add ns ip 11.1.1.9 255.255.255.254 –dynamicRouting ENABLED –ownerNode 1

在 Cisco Nexus 路由器(11.1.1.2/31 和 11.1.1.4/31)上,必须使用命令行执行以下配置:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

    >  interface vlan100
        no shutdown
        ip address 50.1.1.1/8
         hsrp 50
          ip 50.50.50.50
    
    >  interface Ethernet 4/15
         ip address 11.1.1.2/31
         no shutdown
    
    >  interface Ethernet 4/19
         ip address 11.1.1.4/31
         no shutdown
    
    >  interface Ethernet 4/22
         switchport
          switchport access vlan 100
    

在 Cisco Nexus 路由器(11.1.1.6/31 和 11.1.1.8/31)上,必须使用命令行执行以下配置:

  • feature ospf
  • feature bgp
  • feature interface-vlan
  • feature hsrp

     >  interface vlan100
         no shutdown
         no ip redirects
         ip address 50.1.1.2/8
          hsrp 50
          ip 50.50.50.50
    
     >  interface Ethernet 4/13
         ip address 11.1.1.6/31
         no shutdown
    
     >  interface Ethernet 4/15
         ip address 11.1.1.8/31
         no shutdown
    
     >  interface Ethernet 4/22
         switchport
         switchport access vlan 100
    

对于 BGP 协议,必须在 Citrix ADC 设备的 CLIP 上执行以下配置:

>  vtysh
ns# router bgp 1
 redistribute kernel
 owner-node 0
 neighbor 11.1.1.2 remote-as 2
 neighbor 11.1.1.2 as-origination-interval 1
 neighbor 11.1.1.2 advertisement-interval 0
 neighbor 11.1.1.6 remote-as 2
 neighbor 11.1.1.6 as-origination-interval 1
 neighbor 11.1.1.6 advertisement-interval 0
owner-node 1
 neighbor 11.1.1.4 remote-as 2
 neighbor 11.1.1.4 as-origination-interval 1
 neighbor 11.1.1.4 advertisement-interval 0
 neighbor 11.1.1.8 remote-as 2
 neighbor 11.1.1.8 as-origination-interval 1
 neighbor 11.1.1.8 advertisement-interval 0
exit-owner-node

在 Cisco Nexus 路由器上执行以下配置(11.1.1.3 和 11.1.1.5)

> ip access-list acl1
  10 permit ip 50.0.0.0/8 any
  route-map test permit
  match ip address acl1
 router bgp 2
  address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
 neighbor 11.1.1.3 remote-as 1
  address-family ipv4 unicast
  neighbor 11.1.1.5 remote-as 1
 address-family ipv4 unicast

在 Cisco Nexus 路由器上执行以下配置(11.1.1.7 和 11.1.1.9)

> ip access-list acl1
   10 permit ip 50.0.0.0/8 any
  route-map test permit 1
   match ip address acl1
  router bgp 2
   address-family ipv4 unicast
   redistribute direct route-map test
   maximum-paths 2
  neighbor 11.1.1.7 remote-as 1
   address-family ipv4 unicast
  neighbor 11.1.1.9 remote-as 1
   address-family ipv4 unicast

对于 OSPF 协议,必须在 Citrix ADC 设备的 CLIP 上执行以下配置:

> vtysh
ns# router osfp 1
redistribute kernel
owner-node 0
 network 15.1.1.2/31 area 0
 network 15.1.1.6/31 area 0
exit-owner-node

owner-node 1
 network 15.1.1.4/31 area 0
 network 15.1.1.8/31 area 0
exit-owner-node

route-map map2 permit 1
set metric 10

在 Cisco Nexus 路由器(11.1.1.2/31 和 11.1.1.4/31)上,必须使用命令行执行以下配置:

> route-map- map2 permit 1
   set metric 10

   interface Ethernet4/15
     ip address 15.1.1.2/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   interface Ethernet4/19
     ip address 15.1.1.4/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

   router ospf 1
    router-id 1.1.1.1
    redistribute direct route-map map2

在 Cisco Nexus 路由器(11.1.1.7/31 和 11.1.1.9/31)上,必须使用命令行执行以下配置:

> route-map- map2 permit 1
    set metric 10

   interface Ethernet4/13
     ip address 15.1.1.6/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    interface Ethernet4/15
     ip address 15.1.1.8/31
     ip router ospf 1 area 0.0.0.0
     no shutdown

    router ospf 1
      router-id 1.1.1.2
      redistribute direct route-map map2
通过使用带有路由协议的 Cisco Nexus 7000 交换机配置群集 ECMP