Citrix 网关插件升级控制

概述

系统管理员控制 Citrix ADC 插件的版本与 Citrix 网关修订版本不匹配时的执行方式。新选项控制 Mac、Windows 或操作系统的插件升级行为。

对于 VPN 插件,升级选项可以在 Citrix ADC 用户界面的两个位置设置:

  • 在全局设置
  • 在会话配置文件级别

插件行为

对于每种客户端类型,Citrix Gateway 允许以下三个选项来控制插件升级行为:

a.始终如一

当最终用户的插件版本与 Citrix ADC 附带的插件不匹配时,插件始终会升级。这是默认行为。如果您不希望在企业中运行多个插件版本,请选择此选项。

b. 基本 (和安全)

只有在认为必要时才会升级插件。在以下两种情况下认为有必要升级

  • 已安装的插件与当前 Citrix ADC 版本不兼容。

  • 安装的插件需要更新以便进行必要的安全修复。

如果希望尽量减少插件升级次数,但不希望错过任何插件安全更新,则应选择此选项

c.从来没有

插件不会升级。

用于控制 VPN 插件升级的 CLI 参数

思杰网关支持两种类型的插件(EPA 和 VPN)适用于 Windows 和 Mac 操作系统。若要在会话级别支持 VPN 插件升级控制,Citrix 网关支持两个会话配置文件参数,名为 “窗口插件升级” 和 “MacPluginUpgrade”。

这些参数在全局、虚拟服务器、组和用户级别可用。每个参数的值都可以为 “始终”、“基本” 或 “从不”。有关这些参数的说明,请参阅插件行为

控制 EPA 插件升级的 CLI 参数

思杰网关支持适用于 Windows 和 Mac 操作系统的 EPA 插件。为了在虚拟服务器级别支持 EPA 插件升级控制,Citrix 网关支持两个名为 “窗口插件升级” 和 “麦当插件升级” 的虚拟服务器参数。

这些参数在虚拟服务器级别可用。每个参数的值都可以为 “始终”、“基本” 或 “从不”。有关这些参数的说明,请参阅插件行为

VPN 配置

请按照以下步骤进行 Windows、Linux 和 Mac 插件的 VPN 配置。

  1. 转到 Citrix 网络扩展器 > 策略 > 会话。

    本地化后的图片

  2. 选择所需的会话策略,然后单击 编辑

    本地化后的图片

  3. 点击 + 图标。

    本地化后的图片

  4. 选择 客户体验 选项卡。

    本地化后的图片

  5. 这些对话框选项会影响升级行为。

    • 总是这样

    • 必不可少

    • 从来没有

默认值为 “始终”。

  1. 选中每个选项右侧的复选框。选择要应用升级行为的频率。

    本地化后的图片

EPA 配置

按照以下步骤进行 Windows、Linux 和苹果插件的 EPA 配置。

       1. 转到 Citrix 网关 > 虚拟服务器。

本地化后的图片

       2. 选择一个服务器,然后单击 编辑 按钮。

本地化后的图片

      3. 点击 铅笔 图标。

本地化后的图片

      4. 点击 更多

本地化后的图片

       5. 出现的对话框会影响升级行为。可用的选项包括:

  • 总是这样
  • 必不可少
  • 从来没有

本地化后的图片

要求

  • 视窗 EPA 和 VPN 插件版本应大于 11.0.0.0

  • Mac EPA 插件版本应大于 3.0.31

  • Mac VPN 插件版本应大于 3.1.4 (357)

注意: 如果 Citrix ADC 升级到 11.0 版本,则无论升级控制配置如何,以前的所有 VPN(和 EPA)插件都将升级到最新版本。对于后续升级,他们将遵守上述升级控制配置。