Citrix Gateway

客户端软件要求

Citrix Gateway 通过使用 Citrix Secure Access 代理支持用户连接。当用户使用插件登录时,它会建立完整的 VPN 通道。使用 Citrix Secure Access 代理,用户可以连接到您允许访问的网络资源。

如果在 Citrix Gateway 上配置了端点策略,Citrix Gateway 将在用户登录时自动下载 Endpoint Analysis 插件并在用户设备上安装。

Citrix Secure Access 代理系统要求

Citrix Secure Access 代理建立从客户端计算机到 Citrix Gateway 设备的安全连接。

该插件作为桌面应用程序分发,适用于 Microsoft Windows、macOS X 和 Linux 操作系统。使用 Web 浏览器对 Citrix Gateway 设备的安全 URL 进行身份验证后,该插件将自动下载并安装到您的计算机上。

该插件作为适用于 Android 和 iOS 设备的移动应用程序预配。

注意:

  • 要安装该插件,操作系统需要管理员/root 用户权限。

  • 支持 Citrix Secure Access 代理的浏览器也支持无客户端 VPN。

以下操作系统和 Web 浏览器支持 Citrix Secure Access 代理作为桌面应用程序。

操作系统 支持的浏览器
macOS X(10.9 及更高版本) Safari 7.1 或更高版本;Google Chrome 30 或更高版本;Mozilla Firefox 版本 30 或更高版本
Windows 11 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows 10(x86 和 x64) Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows 8.1 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows 8 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Linux;Ubuntu 20.04 LTS、18.04 LTS、16.04 LTS、14.04 LTS 和 12.04 LTS。支持 32 位和 64 位操作系统。 Mozilla Firefox 版本 44 及更高版本;Google Chrome 50 及更高版本

重要: 由于 Ubuntu 16.04 LTS 中存在缺陷 (1573408),VPN 插件安装失败。下面列出了相同问题的解决方法。

使用命令行界面键入以下命令:

sudo dpkg -i nsgclient*.deb
<!--NeedCopy-->

如果缺少所需的依赖项软件,该命令将列出这些软件包,插件安装失败。这些依赖项软件包必须手动安装。管理员可以通过使用命令行界面键入以下命令来安装缺失的软件包。

apt-get install <dependency package>
<!--NeedCopy-->

以下操作系统支持 Citrix Secure Access 代理作为移动应用程序。

VPN 应用程序 支持的操作系统
Android Android 7.0 及更高版本
iOS iOS 12.0 及更高版本

Endpoint Analysis 要求

Citrix Gateway 在用户设备上安装 Endpoint Analysis 插件。Endpoint Analysis 插件会扫描用户设备以查找您在 Citrix Gateway 上配置的端点安全要求。要求包括操作系统、防病毒或 Web 浏览器版本等信息。

当 Windows 用户首次使用浏览器连接到 Citrix Gateway 时,门户会请求安装 Endpoint Analysis 插件。在后续尝试登录时,该插件会检查升级控制配置,以检查是否需要升级客户端 Endpoint Analysis 插件。如果有必要,系统会提示用户下载并安装较新的 Endpoint Analysis 插件。适用于 Windows 的 Endpoint Analysis 插件作为 Windows 32 位应用程序安装。安装或使用该插件不需要任何特殊权限。

对于 macOS,用户需要安装 Endpoint Analysis 插件。适用于 macOS 的插件作为 64 位应用程序安装。安装该插件不需要任何特殊权限。在后续尝试登录时,如果插件版本不匹配,系统将提示用户下载并安装该插件。

管理员 UI 控制台上的工具提示详细解释了扫描。有关 EPA 库的详细信息,请参阅 https://www.citrix.com/en-in/downloads/citrix-gateway/epa-libraries/

重要:

  • 支持 EPA 的浏览器也支持无客户端 VPN。

  • 在预身份验证端点分析中,如果用户未安装 Endpoint Analysis 插件或者跳过扫描,用户将无法使用 Citrix Secure Access 代理登录。

  • 在身份验证后端点分析中,用户可以通过使用无客户端访问或者使用 Citrix Workspace 应用程序访问不需要扫描的资源。

  • 对于与 OPSWAT 相关的扫描,则必须在客户端计算机上安装二进制软件包 epaPackage.exe

要使用 Endpoint Analysis 插件,用户设备上需要以下软件:

操作系统 支持的浏览器
macOS(10.9 及更高版本) Safari 7.1 或更高版本;Google Chrome 30 或更高版本;Mozilla Firefox 版本 30 或更高版本
Windows 11 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows 10 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows 8.1 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows 8 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows 7 Google Chrome 30 或更高版本;Mozilla Firefox 发行版 24 或更高版本;Edge Chromium
Windows Vista Mozilla Firefox 版本 9 和 10
Linux;Ubuntu 12.04 LTS、14.04 LTS、16.04 LTS、18.04 LTS 和 20.04 LTS。32 位和 64 位操作系统均受支持。 Mozilla Firefox 版本 44 及更高版本;Google Chrome 50 及更高版本

注意:

  • 支持前面提到的所有版本的操作系统变体。

  • 对于 Windows 版本,必须安装所有服务包和关键更新。

  • 对于 Mozilla Firefox 版本,Endpoint Analysis 必须启用插件。所需的最低版本为 3.0。

客户端软件要求