新增功能

关于此版本

Citrix Hypervisor 是一款专为虚拟应用程序和桌面工作负载而优化的高性能虚拟机管理程序,基于 Xen 项目虚拟机管理程序。

Citrix Hypervisor 8.2 是一个长期服务版本,旨在最大限度地提高功能集的稳定性。

Citrix Hypervisor 8.2 提供以下版本:

  • Premium Edition
  • Standard Edition
  • Express Edition

有关每个版本中可用的功能的信息,请参阅 Citrix Hypervisor 功能列表

Citrix Hypervisor 8.2 中的新增功能和改进功能

Citrix Hypervisor 8.2 引入了面向应用程序、桌面和服务器虚拟化用例的增强特性和功能。获得 Citrix Virtual Apps and Desktops 许可的所有客户都可以使用 Citrix Hypervisor 8.2 的所有功能。

增加了配置限制

提高了以下配置限制:

  • 最大主机 RAM 现在为 6 TB
  • 现在,每个主机的最大逻辑处理器数量为 448 个 CPU

有关详细信息,请参阅配置限制

在 XenCenter 中启用和禁用读取缓存

读取缓存功能可提高托管从同一来源克隆的多个 VM 的 NFS、EXT 或 CIF/SMB SR 上的性能。现在可以从 XenCenter 控制台为每个单独的 SR 启用和禁用此功能。在以下情况下,您可能希望禁用读取缓存:

  • 您没有基于文件的 SR
  • 您没有任何克隆的 VM
  • 您没有足够的内存可分配给 dom0 以获得任何性能优势

有关详细信息,请参阅更改 SR 属性

更改了来宾操作系统支持

更新了 Citrix Hypervisor 支持的来宾操作系统的集合。有关详细信息,请参阅来宾操作系统支持

增加的功能

Citrix Hypervisor 现在支持以下额外的来宾操作系统:

  • SUSE Linux Enterprise Server 12 SP5(64 位)
  • Ubuntu 20.04(64 位)

删除的功能

  • Windows 7
  • Windows Server 2008
  • Windows Server 2008 SP1

安全性增强功能

在 Citrix Hypervisor 服务器上安装 TLS 证书

Citrix Hypervisor 现在可以轻松安装服务器 TLS 证书。

Citrix Hypervisor 服务器附带安装了一个默认 TLS 证书。但是,必须安装新证书,才能使用 HTTPS 保护 Citrix Hypervisor 与 Citrix Virtual Apps and Desktops 之间的通信安全。Citrix Virtual Apps and Desktops 安装必须信任颁发证书的证书颁发机构。

此功能提供了一种机制,用于更新不需要用户访问 Citrix Hypervisor 服务器文件系统的主机证书。它还验证证书和密钥文件是否有效且格式正确。

可以使用以下方法之一在 Citrix Hypervisor 服务器上安装 TLS 证书:

此功能还会在服务器 TLS 证书即将过期时提供 XenCenter 警报。有关详细信息,请参阅 XenCenter 文档中的系统警报

强制使用 TLS 1.2 协议

Citrix Hypervisor 现在强制对 Citrix Hypervisor 与外部网络之间的任何 HTTPS 通信使用 TLS 1.2 协议。所有 Citrix Hypervisor 组件在相互通信时都使用 TLS 1.2 协议。

作为此功能的一部分,旧版 SSL 模式和对 TLS 1.0/1.1 协议的支持已删除。在将池升级或更新到 Citrix Hypervisor 8.2 之前,请务必在池中禁用旧版 SSL 模式。如果您有任何依赖于不同协议的自定义脚本或客户端,请更新这些组件以使用 TLS 1.2。

Citrix VM Tools 的分类

Citrix VM Tools 现在作为两个单独的组件在 Citrix Hypervisor 下载页面 上提供:

  • 适用于 Windows 的 Citrix VM Tools
  • 适用于 Linux 的 Citrix VM Tools

因此,guest-tools.iso 文件已从 Citrix Hypervisor 安装中删除。

将这些工具作为单独的组件提供,无需修补程序即可将更新应用到 Citrix Hypervisor 服务器上存储的工具 ISO。

有关详细信息,请参阅Linux VMWindows VM

Workload Balancing 设备和 Conversion Manager 设备的更新

其中两个附加组件现在都包括以下改进功能:

  • 平台更新为 CentOS 7.7
  • 通过使用 JSON-RPC 与 Citrix Hypervisor 进行通信提高了性能
  • OpenSSL 更新到版本 1.1.1
  • 为改进安全性和性能更新了其他第三方库
  • TLS 1.2 现已强制实施,以确保安全性

安装选项

可以从 Citrix Hypervisor 产品下载页面 下载在以下软件包中提供的Citrix Hypervisor 8.2:

  • Citrix Hypervisor 8.2 更新 ISO。使用此文件可以将 Citrix Hypervisor 8.2 作为 Citrix Hypervisor 8.1 或 8.0 的更新进行应用。

  • Citrix Hypervisor 8.2 基本安装 ISO。使用此文件可创建 Citrix Hypervisor 8.2 的全新安装或从 XenServer 7.1 CU2 或 7.0 进行升级。

重要:

  • 如果使用 XenCenter 升级您的主机,则必须在开始操作之前先将 XenCenter 安装更新到 Citrix Hypervisor 8.2 下载页面上提供的最新版本。
  • 请始终在升级池中的任何其他主机之前升级池主服务器。
  • 请务必先将您的 XenServer 7.1 更新到累积更新 2, 然后再尝试升级到 Citrix Hypervisor 8.2。
  • 不再支持传统 SSL 模式。在尝试升级到 Citrix Hypervisor 的最新版本之前,在池中的所有主机上禁用此模式。要禁用旧版 SSL 模式,请在开始升级之前在池主服务器上运行以下命令:xe pool-disable-ssl-legacy uuid=<pool_uuid>
  • 不再支持 vSwitch Controller。在尝试更新或升级到 Citrix Hypervisor 的最新版本之前,请先断开 vSwitch Controller 与池的连接。更新或升级完成后,将发生以下配置更改:
    • 跨服务器专用网络还原为主机内部专用网络。
    • 不再应用通过 DVSC 控制台进行的任何服务质量设置。不再强制执行网络速率限制。
    • ACL 规则已删除。允许来自 VM 的所有流量。
    • 端口镜像 (RSPAN) 已禁用。

    更新或升级完成后,如果在池中发现与 vSwitch Controller 有关的任何剩余状态,请使用以下 CLI 命令清除该状态:xe pool-set-vswitch-controller address=

准备工作

在开始安装或从较旧的版本迁移之前,请查看以下文章:

有关安装、升级或更新过程的信息,请参阅安装

许可

客户必须将其 Citrix 许可证服务器升级到版本 11.16 或更高版本,才能使用 Citrix Hypervisor 8.2 的所有许可功能。

有关 Citrix Hypervisor 8.2 许可的详细信息,请参阅许可

硬件兼容性

有关最新添加的内容以及针对所有硬件兼容性问题的建议,请参阅 Citrix Hypervisor 硬件兼容性列表

如果您的 VM 连接了虚拟 GPU,请确保在升级到最新版本的 Citrix Hypervisor 之前受支持的驱动程序可用。有关详细信息,请参阅硬件兼容性列表和 GPU 供应商文档。

与 Citrix 产品的互操作性

Citrix Hypervisor 8.2 可与 Citrix Virtual Apps and Desktops 7.15 LTSR、1912 LTSR 和 2006 进行互操作。

Citrix Hypervisor 8.2 可与 Citrix Provisioning 7.15 LTSR、1912 LTSR 和 2006 进行互操作。

Citrix Hypervisor 8.2 能够与 Citrix Cloud 互操作。

有关与其他 Citrix 产品的互操作性的详细信息,请参阅Citrix 升级指南

本地化支持

此版本中也包含 XenCenter 的本地化版本(简体中文和日语)。在早期版本中,XenCenter 的本地化版本作为单独的组件提供。在 Citrix Hypervisor 8.2 及更高版本中,所有本地化版本的 XenCenter 都包含在与英文本本相同的 .msi 安装文件中。

产品文档

要访问 Citrix Hypervisor 8.2 产品文档,请参阅 Citrix Hypervisor 8.2 产品文档

在此初始版本发行后,本文档可能会有更新或更改。我们建议您订阅 文档历史记录 RSS 源以了解更新。