Product Documentation

Receiver for Android 3.8 的系统要求

Jun 13, 2016

设备要求

Citrix Receiver for Android 3.8 支持 Android 4.0 (Ice Cream Sandwich)、4.1/4.2/4.3 (Jelly Bean)、4.4 (KitKat)、5.0/5.1 (Lollipop) 和 6.0 (Marshmallow)

为获得最佳结果,请将 Android 设备更新到最新的 Android 软件。

Receiver for Android 支持从 Receiver for Web 启动会话,前提是 Web 浏览器可用于 Receiver for Web。如果无法启动,请直接通过 Receiver for Android 配置您的帐户。

如果已安装 Citrix Receiver 的技术预览版,请先卸载该版本,然后再安装新版本。

有关安全连接到 Citrix 环境的信息,请参阅“连接”部分。

服务器要求

StoreFront:

  • StoreFront 3.0(推荐)和 2.6

    用于直接访问 StoreFront 应用商店。Receiver 还支持早期版本的 StoreFront。

  • 配置有 Receiver for Web 站点的 StoreFront

    用于从 Web 浏览器访问 StoreFront 应用商店。有关此部署的限制,请参阅 StoreFront 文档。

Web Interface(在 XenDesktop 7 部署中不受支持):

  • 配置了 Web Interface 站点的 Web Interface 5.4
  • 配置了 XenApp Services 站点的 Web Interface 5.4

NetScaler 上的 Web Interface:

必须启用 NetScaler 提供的重写策略。

XenApp 和 XenDesktop(以下任意产品):

  • XenApp 7.x
  • XenApp 6.5 for Windows Server 2008 R2
  • XenApp 6 for Windows Server 2008 R2
  • XenApp 基础版6.0 (Windows Server 2008 R2 版)
  • XenApp 5 for Windows Server 2008
  • XenApp 5 for Windows Server 2003
  • Citrix Presentation Server 4.5
  • XenDesktop 7.x
  • XenDesktop 7
  • XenDesktop 5、5.5 和 5.6

连接

Citrix Receiver 支持通过以下任一配置与 XenApp 服务器场之间进行的 HTTP、HTTPS 和 ICA-over-TLS 连接。

Citrix Receiver 支持通过以下任一配置与 XenApp 服务器场之间进行的 HTTP、HTTPS 和 ICA-over-TLS 连接。

对于 LAN 连接:

StoreFront 2 或 3(推荐使用)、Web Interface 5.4 或 XenApp Services(以前称为 Program Neighborhood Agent)站点。

对于安全远程连接(以下任一产品):

Citrix NetScaler Gateway 10 和 11(包括 VPX、MPX 和 SDX 版本)

只有版本 9 和 10 支持 XenMobile.

关于安全连接和 TLS 证书

使用 TLS 保护远程连接的安全时,移动设备会对照受信根证书颁发机构的本地存储验证远程网关的 TLS 证书的可靠性。如果本地密钥库中存在证书颁发机构的根证书,该设备会自动识别针对商业用途而颁发的证书(例如 VeriSign 和 Thawte)。

专用(自签名)证书

如果远程网关上安装了专用证书,该移动设备上必须安装组织的证书颁发机构颁发的根证书,才能使用 Receiver 成功访问 Citrix 资源。

注意:如果连接时无法验证远程网关的证书(因为本地密钥库中不包含根证书),系统会显示一条警告,指出该证书不受信任。如果用户选择忽略该警告而继续进行操作,系统会显示应用程序列表,但应用程序无法启动。

在 Android 设备上导入根证书

Android 4.x 设备支持导入根证书,而无需获取对设备的根访问权限。4.0 版之前的 Android 设备不支持自动导入根证书。

通配符证书

通配符证书用于代替同一域内任意服务器的各个服务器证书。Citrix Receiver for Android 支持通配符证书。

中间证书与 NetScaler Gateway

如果您的证书链中包含中间证书,必须将该中间证书附加到 Access Gateway 服务器证书。请参阅与您的 Access Gateway 版本相符的知识库文章:

CTX114146:How to Install an Intermediate Certificate on NetScaler Gateway(CTX114146:如何在 NetScaler Gateway 上安装中间证书)

除 eDocs 的这一部分中包含的配置主题外,另请参阅:

CTX124937: How to Configure NetScaler Gateway for Use with Citrix Receiver for Mobile Devices(CTX124937“如何配置 NetScaler Gateway,使其与适用于移动设备的 Citrix Receiver 结合使用)

身份验证

注意:Secure Gateway 配置不支持 RSA SecurID 身份验证。要使用 RSA SecurID,请使用 NetScaler Gateway。
Citrix Receiver 支持通过 NetScaler Gateway 使用以下方法进行身份验证(取决于您的版本):
  • 无身份验证(仅限 Standard Edition 和 Enterprise Edition)
  • 域身份验证
  • RSA SecurID,包括 WiFi 和非 WiFi 设备的软件令牌
  • 与 RSA SecurID 配对的域身份验证
  • SMS 通行码 (OTP) 身份验证
  • 智能卡身份验证*
* Receiver for Android 现在支持以下产品和配置。
注意:不支持在 Web Interface 站点上执行智能卡身份验证。
支持的智能卡读卡器:
  • BaiMobile 3000MP Bluetooth 智能卡读卡器
支持的智能卡:
  • PIV 卡
  • 通用访问卡
支持的配置:
  • 通过智能卡身份验证登录配置了 StoreFront 2 或 3 的 NetScaler Gateway 以及 XenDesktop 5.6 和更高版本或 XenApp 6.5 和更高版本
  • 通过智能卡身份验证登录配置了 Web Interface 5.4.2 的 NetScaler Gateway 以及 XenDesktop 5.6 和更高版本或 XenApp 6.5 和更高版本
注意:可使用 RADIUS 对其他基于令牌的身份验证解决方案进行配置。有关 SafeWord 令牌身份验证的信息,请在 eDocs 中搜索“Configuring SafeWord Authentication”(配置 SafeWord 身份验证),并参阅与您使用的相应 NetScaler Gateway 版本相符的说明。