Product Documentation

系统要求

Nov 02, 2016

设备

操作系统

以下必备项列表仅指定了提供有限支持的环境中使用的版本或 Service Pack。

  • 仅限 Receiver for Windows 4.1:Windows 8.1,32 和 64 位版本(包括 Embedded Edition)
  • Windows 8,32 位和 64 位版本(包括 Embedded Edition)
  • Windows 7,32 位和 64 位版本(包括 Embedded Edition)
  • Windows XP Professional SP3,32 位版本和 Windows XP Professional SP2,64 位版本(包括 Embedded Edition)

    Microsoft 将于 2013 年 4 月 8 日终止对 Windows XP 提供支持,届时将不再支持 Windows XP。继续支持 Windows XP Embedded。

  • Windows Vista,32 位和 64 位版本
  • Windows Thin PC

    不支持自助服务插件。有关详细信息,请参阅使用命令行参数配置和安装 Receiver for Windows

  • 仅限 Receiver for Windows 4.1:Windows Server 2012 R2,64 位版本
  • Windows Server 2012(64 位版本)
  • Windows Server 2008 R2(64 位版本)
  • Windows Server 2008(32 位和 64 位版本)
  • Windows Server 2003(32 位和 64 位版本)

硬件

  • 适用于彩色监视器的 VGA 或 SVGA 视频适配器
  • 用于提供声音支持的 Windows 兼容声卡(可选)
  • 要实现与服务器场的网络连接,需要网络接口卡 (NIC) 和相应的网络传输软件

服务器

  • XenApp(以下任意产品):
    • Citrix XenApp 7.5
    • Citrix XenApp 6.5 Feature Pack 2 Windows Server 2008 R2
    • Citrix XenApp 6.5 Feature Pack 1 Windows Server 2008 R2
    • Citrix XenApp 6.5 for Windows Server 2008 R2
    • 适用于 UNIX 操作系统的 Citrix XenApp 4, Feature Pack 1 或 2
  • XenDesktop(以下任意产品):
    • XenDesktop 7.5
    • XenDesktop 7.1
    • XenDesktop 7.0
    • XenDesktop 5.6 Feature Pack 1
    • XenDesktop 5.6
    • XenDesktop 5.5
    • XenDesktop 5
    • XenDesktop 4
  • Citrix VDI-in-a-Box
    • VDI-in-a-Box 5.3
    • VDI-in-a-Box 5.2
    • VDI-in-a-Box 5.1
  • Citrix Receiver 可以使用 StoreFront、App Controller 和 Web Interface 访问虚拟桌面和应用程序。
    StoreFront:
    • StoreFront 2.6(推荐)、2.5 或 2.1

      用于直接访问 StoreFront 应用商店。

    • 配置有 Receiver for Web 站点的 StoreFront

      用于从 Web 浏览器访问 StoreFront 应用商店。 有关此部署的限制,请参阅 Receiver for Web sites(Receiver for Web 站点)上的“Important considerations”(重要注意事项)。

    App Controller 9.0 和 2.10:

    用于直接访问 Web 和软件即服务 (SaaS) 应用程序。 还提供 ShareFile 帐户置备和 Single Sign-On。 App Controller 是 XenMobile App Edition 的一个组件。

    Web Interface 与 NetScaler VPN 客户端结合使用:
    • Web Interface 5.4 for Windows Web 站点。

      提供从 Web 浏览器访问虚拟桌面和应用程序的功能。

    • Web Interface 5.4 for Windows、旧版 XenApp Services 或 XenDesktop Services 站点。
  • 部署 Receiver:
    • Citrix Receiver for Web 站点(使用 StoreFront 配置)
    • Citrix Merchandising Server 2.x
    • Citrix Web Interface 5.4
    • Microsoft System Center 2012 Configuration Manager

浏览器

  • Internet Explorer

    与 Receiver forWeb或 Web Interface 的连接支持 32 模式的 Internet Explorer。有关支持的 Internet Explorer 版本,请参阅 StoreFront 系统要求Web Interface 系统要求

  • Mozilla Firefox 18.x(支持的最低版本)
  • Google Chrome 21 或 20(需要 StoreFront)

连接

Citrix Receiver for Windows 支持通过以下任一配置的 HTTPS 和 ICA-over-SSL 连接。

  • 对于 LAN 连接:
    • 使用 StoreFront Services 或 Receiver for Web 站点的 StoreFront

      借助 Single Sign-On 登录到通过 App Controller 发布的 Web 和 SaaS 应用程序需要 Storefront。

    • 使用 Web Interface 站点或旧版 XenApp Services/XenDesktop Services 站点的 Web Interface 5.4 for Windows

    有关已加入域和未加入域的设备的信息,请参阅 XenDesktop 7 文档。

  • 对于安全的远程连接或本地连接:
    • Citrix NetScaler Gateway 10.1
    • Citrix Access Gateway Enterprise Edition 10
    • Citrix Access Gateway Enterprise Edition 9.x
    • Citrix Access Gateway VPX
    • Citrix Secure Gateway 5.0(仅与 Web Interface 结合使用)
    • Citrix Secure Gateway 3.x(仅与 Web Interface 结合使用)

    支持已加入域的托管 Windows 设备(本地及远程,使用或不使用 VPN 皆可)以及未加入域的设备(使用或不使用 VPN 皆可)。

    有关 StoreFront 支持的 NetScaler Gateway 和 Access Gateway 版本的信息,请参阅 StoreFront 系统要求

注意:除非另有指定,否则本主题中 NetScaler Gateway 的参考资料也适用于 Access Gateway。

关于安全连接和 SSL 证书

注意:有关安全证书的其他信息,请参阅安全连接安全通信下的主题。

使用 SSL 保护远程连接的安全时,Receiver 会对照受信根证书颁发机构的本地存储验证远程网关的 SSL 证书的可靠性。如果本地密钥库中存在证书颁发机构的根证书,Receiver 会自动识别针对商业用途而颁发的证书(例如 VeriSign 和 Thawte)。

私有(自签名)证书

如果远程网关上安装了专用证书,用户设备上必须安装组织的证书颁发机构颁发的根证书,才能使用 Receiver 成功访问 Citrix 资源。

注意:如果连接时无法验证远程网关的证书(因为本地密钥库中不包含根证书),系统会显示一条警告,指出该证书不受信任。如果用户选择忽略警告继续,则会显示一个应用程序列表,但应用程序不会启动。

在用户设备上安装根证书

有关在用户设备上安装根证书以及配置 Web Interface 以供证书使用的信息,请参阅配置并启用 Receivers for SSL 和 TLS

通配符证书

通配符证书用于代替同一域内任意服务器的各个服务器证书。Receiver for Windows 支持通配符证书。

中间证书与 NetScaler Gateway

如果您的证书链中包含中间证书,必须将该中间证书附加到 NetScaler Gateway 服务器证书。有关信息,请参阅 Configuring Intermediate Certificates(配置中间证书)。

身份验证

对于到 StoreFront 的连接,Receiver 支持以下身份验证方法:
  • 域(不适用于从 NetScaler Gateway 建立的连接)
  • 域直通

    Receiver for Web 站点不支持域传递身份验证。不适用于从 NetScaler Gateway 建立的连接。

  • 安全令牌*
  • 双因素(域 + 安全令牌)*
  • SMS*
  • 智能卡(需要 StoreFront 2.1 或 2.0)
  • 客户端证书*(可以单独使用,也可以与其他身份验证方法结合使用)

* 仅在 Receiver for Web 站点以及包含 NetScaler Gateway 的部署中可用,而无论设备上是否已安装关联的插件。

对于到 App Controller 的连接,Receiver 支持以下身份验证方法:
  • 安全令牌*
  • 双因素(域 + 安全令牌)*
  • SMS*

* 仅在包含 NetScaler Gateway 的部署中可用,而无论设备上是否已安装关联的插件。

对于到 Web Interface 5.4 的连接,Receiver 支持以下身份验证方法。(Web Interface 为域和安全令牌身份验证使用术语“显式”。)
  • 域直通(仅适用于通过 Web 浏览器建立的连接)
  • 安全令牌*
  • 双因素(域 + 安全令牌)*
  • SMS*
  • 智能卡
  • 客户端证书*(可以单独使用,也可以与其他身份验证方法结合使用)

* 仅在包含 NetScaler Gateway 的部署中可用,而无论设备上是否已安装关联的插件。

有关身份验证的信息,请参阅 NetScaler Gateway 文档中的配置身份验证和授权以及 StoreFront 文档中的管理主题。有关 Web Interface 支持的身份验证方法的信息,请参阅 Configuring Authentication for the Web Interface(为 Web Interface 配置身份验证)。

升级

仅支持对 Citrix 联机插件 12.x 和 Receiver for Windows 3.x 进行升级。

Receiver for Windows 4.0 功能的可用性

仅当连接到较新版本的 XenApp 和 XenDesktop 时 Receiver 的某些功能才可用,并且可能需要安装最新的修补程序。

其他

  • 兼容的插件

    有关兼容的插件列表,请参阅 To manage Citrix Receiver updates(管理 Citrix Receiver 更新)。

  • .NET Framework 要求
    • 自助服务插件需要 .NET 3.5 Service Pack 1,才能允许用户从 Receiver 窗口或命令行订阅和启动桌面和应用程序。有关详细信息,请参阅使用命令行参数配置和安装 Receiver for Windows
    • 需要安装 .NET 2.0 Service Pack 1 和 Microsoft Visual C++ 2005 Service Pack 1 可再发行组件包,以确保正确显示 Receiver 图标。Microsoft Visual C++ 2005 Service Pack 1 软件包包含在 .NET 2.0 Service Pack 1、.NET 3.5 和 .NET 3.5 Service Pack 1 中;也可单独获取此软件包。
    • 对于 XenDesktop 连接:要使用 Desktop Viewer,必需安装 .NET 2.0 Service Pack 1 或更高版本。要求此版本是因为,如果 Internet 访问不可用,证书吊销校验会放慢连接启动的时间。使用此版本的 Framework 而非 .NET 2.0 可以关闭校验并改善启动时间。
  • 有关将 Receiver 与 Microsoft Lync Server 2013 和 Microsoft Lync 2013 VDI Plug-in for Windows 结合使用的信息,请参阅 XenDesktop 7、XenApp 6.x 和 Citrix Receiver 4.0 对 Microsoft Lync 2013 VDI 插件的支持
  • 支持的连接方法和网络传输协议:
    • TCP/IP+HTTP
      重要:如果在 StoreFront 中将应用商店的传输类型配置为 HTTP,则必须将以下注册表项值添加到注册表项 HKLM\Software\[Wow6432Node\]Citrix\AuthManager 中:ConnectionSecurityMode=Any
      警告:注册表编辑器如果使用不当,会导致可能需要重新安装操作系统的严重问题。Citrix 无法保证因“注册表编辑器”使用不当导致出现的问题能够得以解决。使用“注册表编辑器”需自担风险。请确保在编辑注册表之前进行备份。
    • SSL/TLS+HTTPS
  • 早期版本的 Presentation Server 客户端/联机插件与最新的 icaclient.adm 文件。早期版本的 Presentation Server Client 和联机插件与 Receiver for Windows 4.0 的 icaclient.adm 文件不兼容。