打开和播放录制件

打开录制件

可以通过三种方式打开 Session Recording Player 中的会话录制件:

  • 使用 Session Recording Player 执行搜索。满足搜索条件的录制的会话将显示在搜索结果区域中。
  • 直接从本地磁盘驱动器或共享驱动器访问录制的会话文件。
  • 从“收藏夹”文件夹访问录制的会话文件。

打开未使用数字签名录制的文件时,系统会显示一条警告消息,指出未验证该文件的来源和完整性。如果您确信该文件的完整性,请在警告窗口中单击以打开该文件。  

注意:

借助 Session Recording 的管理员日志记录功能,您可以记录 Session Recording Player 中的录制的下载情况。有关详细信息,请参阅管理员日志记录

打开搜索结果区域中的录制件

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. 执行搜索。
  4. 如果搜索结果区域不可见,请在“工作区”窗格中选择搜索结果
  5. 在搜索结果区域中,选择要播放的会话。
  6. 执行以下任意操作:
    • 双击会话。
    • 单击鼠标右键并选择播放
    • Session Recording Player 菜单栏中,选择播放 > 播放

通过访问文件打开录制件

录制的会话文件的名称以 i_ 开头,依次后跟唯一的字母数字文件 ID 和 .icl 或 .icle 文件扩展名。.icl 扩展名表示录制件未应用播放保护。.icle 扩展名表示录制件应用了播放保护。录制的会话文件保存在一个包含会话的录制日期的文件夹中。例如,在 2014 年 12 月 22 日录制的会话文件,保存在文件夹路径 2014\12\22 下。

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. 执行以下任意操作:
    • Session Recording Player 菜单栏中,依次选择文件 > 打开,并浏览文件。
    • 使用 Windows 资源管理器,导航至文件,并将文件拖动到播放器窗口中。
    • 使用 Windows 资源管理器,导航至文件并双击该文件。
    • 如果您在“工作区”窗格中创建了“收藏夹”,请选择收藏夹并从“收藏夹”区域中打开该文件,方式与通过从搜索结果区域中打开文件的方式相同。

使用收藏夹

通过创建“收藏夹”文件夹,您可以快速访问经常查看的录制件。这些“收藏夹”文件夹引用存储在工作站或网络驱动器上的录制的会话文件。可以将这些文件导入及导出到其他工作站,并且可以与其他 Session Recording Player 用户共享这些文件夹。

注意:

只有对 Session Recording Player 具有访问权限的用户才能下载与“收藏夹”文件夹相关联的录制的会话文件。请与您的 Session Recording 管理员联系获取访问权限。

创建“收藏夹”子文件夹:

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 窗口中,选择“工作区”窗格中的收藏夹文件夹。
  4. 从菜单栏中,依次选择文件 > 文件夹 > 新建文件夹收藏夹文件夹下将显示一个新文件夹。
  5. 键入文件夹名称,然后按 Enter 键,或者单击任意位置以接受新名称。

使用文件 > 文件夹菜单中显示的其他选项可删除、重命名、移动、复制、导入和导出文件夹。

播放录制件

在 Session Recording Player 中打开录制的会话之后,可以使用以下方法浏览录制的会话:

  • 使用播放器控件可播放、停止、暂停以及提高或降低播放速度。
  • 使用搜寻滑块可前进或后退。

如果您在录制件中插入了标记,或者录制的会话中包含自定义事件,也可以通过转到这些标记和事件来浏览录制的会话。  

注意:

  • 在播放录制的会话期间,可能会显示第二个鼠标指针。如果用户在 Internet Explorer 中浏览时单击了一个图像,而该图像的原始大小比屏幕大,但自动被 Internet Explorer 缩小,则会在录制件中显示第二个指针。虽然会话期间仅显示一个指针,但播放过程中可能会显示两个。
  • 此 Session Recording 版本不支持 SpeedScreen Multimedia Acceleration 和 Flash 质量调整策略设置。如果启用了此选项,播放将显示一个黑色方块。
  • 使用高于或等于 4096 x 4096 的分辨率录制会话时,录制件中可能会出现片段。

使用播放器控件

可以单击播放器窗口下方的播放器控件,也可以从 Session Recording Player 菜单栏中选择播放来访问这些控件。

播放器控件 功能
 播放所选会话文件。
 暂停播放。
 停止播放。如果单击停止,然后单击播放,录制件将在该文件的开头重新启动。
 将当前播放速度减半,最多可减至正常播放速度的四分之一。
 将当前播放速度加倍,最多可增加到正常播放速度的 32 倍。

使用搜寻滑块

使用播放器窗口下方的定位滑块可跳至录制的会话中的不同位置。可以将搜寻滑块拖动到录制件中要查看的点,也可以单击滚动条的任意位置以移动到该位置。

还可以使用以下键盘快捷键来控制搜寻滑块:

键盘键 功能
Home 搜寻到开头。
End 搜寻到结尾。
向右键 向前搜寻 5 秒。
左箭头键 向后搜寻 5 秒。
将鼠标滚轮向下滚动一格 向前搜寻 15 秒。
将鼠标滚轮向上滚动一格 向后搜寻 15 秒。
Ctrl + 右箭头键 向前搜寻 30 秒。
Ctrl +左箭头键 向后搜寻 30 秒。
PgDn 向前搜寻 1 分钟。
PgUp 向后搜寻 1 分钟。
Ctrl + 将鼠标滚轮向下滚动一格 向前搜寻 90 秒。
Ctrl + 将鼠标滚轮向上滚动一格 向后搜寻 90 秒。
Ctrl + Page Down 向前搜寻 6 分钟。
Ctrl + Page Up 向后搜寻 6 分钟。

调整搜寻滑块的速度:从 Session Recording Player 菜单栏中,依次选择工具 > 选项 > 播放器,并拖动滑块以增加或减少搜寻响应时间。响应时间越快,所需内存越多。响应速度可能会很慢,具体取决于录制内容的大小和计算机的硬件。

更改播放速度

可以对 Session Recording Player 进行设置,使其能够以正常播放速度的 1/4 到 32 倍逐渐增加的顺序来播放录制的会话。

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 菜单栏中,选择播放 > 播放速度
  4. 选择一个速度选项。

速度会立即调整。指示指数率的文本在播放器窗口的下面部分会短暂显示为绿色。

突出显示录制的会话的空闲时间段

录制的会话的空闲时间段是其中没有执行任何操作的部分。Session Recording Player 可以在播放过程中突出显示录制的会话的空闲时间段。选项默认为。有关详细信息,请参阅突出显示空闲时间段

跳过没有操作的空白部分

在快速查看模式下,可以将 Session Recording Player 设置为跳过录制的会话中没有发生操作的部分。此设置可节省观看播放的时间。但是,它不会跳过连续动画,例如连续移动的鼠标指针、闪烁的光标或显示的包含秒针移动的时钟。

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 菜单栏中,依次选择播放 > 快速查看模式。  

该选项将打开或关闭。每次选择该选项时,其状态在播放器窗口中会暂时显示为绿色。

更改播放显示

通过“选项”,您可以更改录制的会话在播放器窗口中的显示方式。可以平移和缩放图像、全屏显示播放、在单独的窗口中显示播放器窗口,以及在录制的会话周围显示红色边框以与播放器窗口背景进行区分。

全屏显示播放器窗口

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 菜单栏中,依次选择查看 > 全屏播放
  4. 要返回原始大小,请按 EscF11

在单独的窗口中显示播放器窗口

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 菜单栏中,依次选择查看 > 播放器在单独窗口中。将显示一个包含播放器窗口的新窗口。可以拖动窗口以及调整窗口大小。
  4. 要将播放器窗口嵌入到主窗口中,请依次选择查看 > 播放器在单独窗口中,或按 F10

缩放会话播放使其适应播放器窗口

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 菜单栏中,依次选择播放 > 平移和缩放 > 缩放以适应窗口
    • 缩放以适应窗口(快速呈现) 在提供良好质量的同时会缩小图像。与使用“高质量”选项相比,图像的绘制速度更快,但图像和文本不清晰。如果在使用“高质量”模式时遇到性能问题,请使用此选项。
    • 缩放以适应窗口(高质量) 在提供高质量的同时会缩小图像。使用此选项可能会导致图像的绘制速度比使用“快速呈现”选项慢。

平移图像

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 菜单栏中,依次选择播放 > 平移和缩放 > 平移。指针变为手形。播放器窗口的右上角会显示屏幕的小图示。
  4. 拖动图像。小图示指示您在图像中的位置。
  5. 要停止平移,请选择其中一个缩放选项。

在 Session Recording 周围显示红色边框

  1. 登录到安装了 Session Recording Player 的工作站。
  2. 开始菜单中选择 Session Recording Player
  3. Session Recording Player 菜单栏中,依次选择工具 > 选项 > 播放器
  4. 选中在会话录制周围显示边框复选框。
    如果未选中在会话录制周围显示边框复选框,可以在指针位于播放器窗口中时,通过单击并按住鼠标左键暂时显示红色边框。

打开和播放录制件