长期服务版本 (Long Term Service Release, LTSR)

发布日期:2016 年 1 月 11 日

安装和升级 LTSR 组件

要满足 XenApp 和 XenDesktop 7.6 长期服务版本 (LTSR) 的要求,必须升级属于 LTSR 的一部分以及 LTSR 版本部署的一部分的 XenApp 和 XenDesktop 7.6 的组件。例如:如果 Provisioning Services 属于您的部署的一部分,则必须将 Provisioning Services 组件升级到其 LTSR 版本。如果 Provisioning Services 不属于您的部署的一部分,则不需要安装或升级该组件。

根据 LTSR 条款,为使您的部署有资格享有各项优势,必须升级到 LTSR 版本。

此外,Citrix 还建议您使用特定版本的 Citrix Receiver 及其他组件。升级到这些组件的当前版本可确保进一步简化维护过程以及确保您的部署中最新修复的可用性,但这并非是 LTSR 合规性的必需条件。

有用链接:

LTSR 基础组件和必需版本

注意

下面是 LTSR 基础版本特定的信息。有关 CU1CU2 的此类信息,请参阅各自的文档。

虽然 LTSR 合规性不要求在您的部署中安装以下组件,但您必须将部署中的每个组件都升级到下文指示的版本。

LTSR 基础组件 版本 注意
VDA for Desktop OS 7.6.300 适用于 Windows 10 的特殊规则。请参阅 兼容组件和平台
VDA for Server OS 7.6.300  
Delivery Controller 7.6 Update 3  
Citrix Studio 7.6 Update 3  
Citrix Director 7.6.300  
组策略管理体验 7.6.300 (2.5)  
StoreFront 3.0.1  
Provisioning Services 7.6 Update 1 适用于 Windows 10 的特殊规则。请参阅 兼容组件和平台
通用打印服务器 7.6.300 仅支持 Windows 2008 R2 SP1、Windows 2012、Windows 2012 R2
Session Recording 7.6.100 仅限 Platinum Edition

兼容组件和平台

建议您在 7.6 LTSR 环境中使用以下组件。这些组件无权享有 LTSR 的优势(扩展的生命周期以及仅用于修复的累积更新)。Citrix 可能会要求您在 7.6 LTSR 环境中升级到这些组件的较新版本。

Windows 10 注意事项:可以通过当前版本路径获取对 Windows 10 的常规支持。Windows 10 无法享有 7.6 LTSR 的所有优势。对于包括 Windows 10 计算机的部署,Citrix 建议您使用 VDA for Desktop OS 7.9 和 Provisioning Services 7.9。

有关详细信息,请参阅将 Windows 10 兼容性添加到 XenApp 和 XenDesktop 7.6 LTSRXenApp 和 XenDesktop 服务选项 (LTSR) 常见问题解答

LTSR 兼容的组件和平台 版本
Profile Management 5.4
AppDNA 7.6.5
许可证服务器 11.12.1
HDX RealTime Optimization Pack 2.0
Windows 10 VDA:版本 7.9;Provisioning Services:版本 7.9

Citrix Receiver 的兼容版本

为简化维护过程以及确保实现最佳性能,Citrix 建议您在最新版本的 Citrix Receiver 可用时随时升级到相应版本。可以从 https://www.citrix.com/downloads/citrix-receiver.html 下载最新版本。为方便起见,请考虑订阅 Citrix Receiver RSS 源以在新版本的 Citrix Receiver 可用时接收通知。

请注意,Citrix Receiver 无法享有 XenApp 和 XenDesktop LTSR 的优势(扩展的生命周期和仅用于修复的累积更新)。Citrix 可能会要求您在 7.6 LTSR 环境中升级到 Citrix Receiver 的较新版本。如果使用的是 Citrix Receiver for Windows,Citrix 已公布特殊的 LTSR 计划。可以从 Citrix Receiver 的生命周期里程碑页面获取有关该计划的详细信息。

特别需要指出的是,LTSR 支持以下版本的 Citrix Receiver 以及之后的所有版本:

Citrix Receiver 的 LTSR 兼容版本 版本
Citrix Receiver for Windows 4.4 或更高版本
Citrix Receiver for Linux 13.2.1 或更高版本
Citrix Receiver for Mac 12.1 或更高版本
Citrix Receiver for Chrome 1.8 或更高版本
Citrix Receiver for HTML5 1.8 或更高版本
Citrix Receiver for iOS 6.1.1 或更高版本
Citrix Receiver for Android 3.8 或更高版本

需要注意的例外

以下功能、组件和平台无法享有 LTSR 的生命周期里程碑和优势。需要特别指出的是,累积更新和扩展生命周期优势被排除在外。可以通过常规的最新版本获取扩展功能和组件的更新。

排除的功能:本地应用程序访问、Framehawk 排除的组件:Linux VDA、Personal vDisk 排除的 Windows 平台*:Windows 2008 32 位(面向通用打印服务器)

* Citrix 保留根据第三方供应商的生命周期里程碑更新平台支持的权利。

升级到 XenApp 和 XenDesktop 7.6 LTSR

可以直接从 XenApp 和 XenDesktop 7.6 升级到 LTSR 以及从三个 7.6 Feature Pack 之一进行升级。

下载位置:

好消息:多个组件的 LTSR 版本已经发布了一段时间,主要作为 Feature Pack 3 的一部分提供。这意味着,如果您已将部署升级到 Feature Pack 3,多个组件已符合 LTSR。在这些情况下,您不需要进一步执行任何操作。请注意,本版本最初是在下文中列出的各种组件的相应章节中发布的,以确认您是否需要越过 Feature Pack 3 进行升级。

升级 Controller 之前的注意事项:升级到 Controller 的 LTSR 版本会修改您的站点数据存储的一个或多个 DbSchema。这些修改具有永久性和不可逆转性,即,不能自动还原这些修改。因此,升级 Controller 之前,请务必阅读并理解有关升级到 Controller 的 LTSR 版本的相关章节。

Virtual Delivery Agent (VDA) for Desktop OS 7.6.300

LTSR 版本:VDA for Desktop OS 7.6.300

本版本最初是在 2015 年 9 月 30 日作为 Feature Pack 3 的一部分发布的 (VDAWorkstationSetup_7.6.300.exe)

系统要求

已修复的问题

安装/升级

在要安装 VDA 的计算机上下载并运行 VDAWorkstationSetup_7.6.300.exe。请使用图形界面或命令行。

有关详细信息,请参阅 使用独立的软件包安装 VDA

Virtual Delivery Agent (VDA) for Server OS 7.6.300

LTSR 版本:VDA for Server OS 7.6.300

本版本最初是在 2015 年 9 月 30 日作为 Feature Pack 3 的一部分发布的 (VDAServerSetup_7.6.300.exe)

系统要求 已修复的问题

安装/升级

在要安装 VDA 的计算机上下载并运行 VDAServerSetup_7.6.300.exe。请使用图形界面或命令行。

VDA for Windows Server OS 安装会自动部署 Microsoft Visual C++ 2013 Runtime(32 位和 64 位)以及 2008 和 2010 Runtime(32 位和 64 位)。不再部署 Microsoft Visual C++ 2005。这些必备项将启动服务器重新启动,并且 VDA 安装将在重新启动后继续运行。

有关详细信息,请参阅 使用独立的软件包安装 VDA

Delivery Controller 7.6.3 (Controller Hotfixes Update 3)

LTSR 版本:Delivery Controller 7.6.3

本版本最初是在 2015 年 11 月 12 日作为 Delivery Controller 7.6.3 (Controller Hotfixes Update 3) 的一部分发布的

系统要求

已修复的问题(32 位)

已修复的问题(64 位)

安装/升级

如果您的 Controller 的版本为 7.6.3:

Controller 7.6.3 (Controller Hotfixes Update 3) 为 LTSR 版本。如果您之前已升级到版本 7.6.3,则 Controller 符合 LTSR,不需要进行升级,可以跳至 Citrix Studio 部分。重要:请务必安装版本 7.6.3 的所有组件;否则,您的 Controller 可能会保留在不稳定状态。

如果您的 Controller 的版本为 7.6、7.6.1 或 7.6.2:

要符合 LTSR,需要将您的 Controller 升级到 LTSR 版本。为此,请将 LTSR 版本下载到您的 Controller 并按照下面的升级说明进行操作。

警告:不支持从各个 Controller 组件降级(又称为回滚),并且降级可能会将您的系统保留在不稳定状态。Controller 组件不修补现有安装,每个组件都会使用新安装完全替换原始组件。因此,卸载某个组件会从 Controller 中删除整个组件。如果需要还原到早期版本的 Controller,则必须卸载每个组件,然后重新安装每个组件的早期版本。还原到早期版本的组件可能会导致丢失您在安装此升级时配置的设置。

重要:必须安装 LTSR 版本的所有组件;否则,您的 Controller 可能会保留在不稳定状态。

如果要从 7.6 Controller 的基础版本 (RTM) 进行升级,请安装 LTSR Controller 的所有组件。

如果要从 Delivery Controller 7.6.1 (Controller Hotfixes Update 1) 或 Delivery Controller 7.6.2 (Controller Hotfixes Update 2) 进行升级,请仅安装 LTSR 版本中的新组件(与已安装的早期版本相比)。不需要按照特定顺序安装各个组件。

  • 要成功升级,服务器不得设置注册表修改限制。
  • 有关安装 XenDesktop/XenApp 7.x Controller 更新的补充信息,请参阅 CTX201988

从 Delivery Controller 7.6.2 (Controller Hotfixes Update 2) 进行升级

警告。根据设计,Broker Service (BrokerSrvc760WX64003.msi) 组件会修改您的站点数据存储的 Broker DbSchema。这些修改具有永久性和不可逆转性。如果您因任何原因决定稍后卸载 Broker Service 组件,这些修改不会自动还原。以防万一,Citrix 强烈建议您先备份站点数据存储,然后再安装 Broker Service 组件。这样将允许您将站点数据存储手动还原到备份的版本。即使这样,您在备份和还原站点数据存储期间对其所做的所有更改都将丢失。有关备份和还原数据存储的信息,请参阅 CTX135207。 仅当至少创建了一个站点时,才能成功更新 DbSchema。如果尚未创建站点,请先至少创建一个站点,然后再安装此更新。否则,安装将无法更新现有 DbSchema,并且您需要重新构建 XenDesktop。

注意:升级到本版本后,系统将显示一条针对 Citrix Studio 中的许可证服务器兼容性检查的提示,用于确保您的许可证服务器为所需版本。如果使用的是随 XenDesktop 7.6 发布的许可证服务器或更新版本中的许可证服务器,则不需要升级许可证服务器。单击继续以继续升级 DBschema。

  1. 务必确认从 7.6.2 Controller 进行升级。否则,请参阅下文“从 Delivery Controller 7.6.1 或 7.6 进行升级”。
  2. 确保至少存在一个站点。
  3. 备份您的站点数据存储。
  4. 将发行包复制到网络上的共享文件夹。
  5. 保存要更新的 Delivery Controller 上的组件 msi 文件。
  6. 运行 .msi 文件。
  7. 重新启动 Delivery Controller(即使系统未提示也需要重新启动)。
  8. 要升级到本版本安装的最新 DbSchema,请转至 Citrix Studio 的“控制板”,然后单击“升级”。

从 Delivery Controller 7.6.1 或 7.6 进行升级

注意。本部分不适用于从 Controller 7.6.2 进行升级。

警告。根据设计,Broker Service (BrokerSrvc760WX64003.msi) 和 Host Service (HostSrvc760WX64003.msi) 组件会分别修改您的站点数据存储的 Broker 和主机 DbSchema。这些修改具有永久性和不可逆转性。如果您因任何原因决定稍后卸载 Broker Service 或 Host Service 组件,这些修改不会自动还原。以防万一,Citrix 强烈建议您先备份站点数据存储,然后再安装 Broker Service 和 Host Service 组件。这样将允许您将站点数据存储手动还原到备份的版本。即使这样,您在备份和还原站点数据存储期间对其所做的所有更改都将丢失。有关备份和还原您的数据存储的信息,请参阅 CTX135207。 仅当至少创建了一个站点时,才能成功更新 DbSchema。如果尚未创建站点,请先至少创建一个站点,然后再安装此更新。否则,安装将无法更新现有 DbSchema,并且您需要重新构建 XenDesktop。

注意。升级到本版本后,系统将显示一条针对 Citrix Studio 中的许可证服务器兼容性检查的提示,用于确保您的许可证服务器为所需版本。如果使用的是随 XenDesktop 7.6 发布的许可证服务器或更新版本中的许可证服务器,则不需要升级许可证服务器。单击继续以继续升级 DBschema。

  1. 确保至少存在一个站点。
  2. 备份您的站点数据存储。
  3. 将发行包复制到网络上的共享文件夹。
  4. 保存要更新的 Delivery Controller 上的组件 msi 文件。
  5. 运行 .msi 文件。
  6. 重新启动 Delivery Controller(即使系统未提示也需要重新启动)。
  7. 要升级到本版本安装的最新 DbSchema,请转至 Citrix Studio 的“控制板”,然后单击“升级”。

卸载 Delivery Controller 组件以及还原到早期版本的组件和站点数据存储

  1. 从“ARP”/“程序和功能”中卸载组件。
  2. CTX135207 中所述还原数据存储。
  3. 安装所需的组件版本(基础版本或更高版本)。
  4. 重新启动 Controller(即使系统未提示也需要重新启动)。

Citrix Studio 7.6 Update 3

LTSR 版本:Citrix Studio 7.6 Update 3

本版本最初是在 2015 年 10 月 29 日作为修补程序 DStudio760WX64003 发布的;修补程序 DStudio760WX86003

系统要求

已修复的问题

已知问题

如果升级过程中 Citrix Studio 处于打开状态,并且您在此修补程序的安装向导的“正在使用的文件”页面上选择设置“关闭应用程序并尝试重新启动”,则可能会显示以下消息: “Setup was unable to automatically close all requested applications. Please ensure that the applications holding files in use are closed before continuing with the installation.(安装程序无法自动关闭所有请求的应用程序。请务必先关闭正在使用文件的应用程序,然后再继续安装。) 如果显示此消息,您可以安全地将其关闭并单击“确定”以继续安装。

安装/升级

下载 Citrix Studio 的 LTSR 版本并按照 CTX201572 中提供的安装说明进行操作。

Citrix Director 7.6.300

LTSR 版本:Director 7.6.300

本版本最初是在 9 月 30 日作为 Feature Pack 3 的一部分发布的 (Director_7.6.300.zip)

系统要求

请确保您已在 IIS 中选中所有必需的功能。有关完整列表,请参阅 CTX142260。安装 Citrix Group Policy Management 组件(如果尚未安装)。

已修复的问题

安装/升级

将 Citrix Director 的 LTSR 版本下载到运行 Director 的服务器并按照 Director 上的说明进行操作。

Group Policy Management 7.6.300 (2.5)

LTSR 版本:Group Policy Management 7.6.300

本版本最初是在 9 月 30 日作为 Feature Pack 3 的一部分发布的 (CitrixGroupPolicyManagement_7.6.300.zip)

系统要求:

运行 Windows 7、Windows 8、Windows 8.1、Server 2008 R2、Server 2012 或 Server 2012 R2 的计算机

VDA 中新增和增强的 HDX 技术功能使用更新后的 Group Policy Management 软件包进行管理。注意:安装后,此组件在“程序和功能”中显示为版本 2.5.0.0。

安装/升级

需要在安装了 Director 的系统中安装 Citrix Group Policy Management,以使策略在“用户详细信息”视图中显示。在运行 Director 的服务器上下载并安装 Citrix Group Policy Management (Citrix Policy) 的 LTSR 版本。下一步,请启动 Studio 或 GPMC,此时将显示新的以及更新后的策略。

有关更新后的策略的详细信息,请参阅视频显示策略设置,了解增强的 Thinwire 兼容模式;参阅 USB 设备策略设置,了解签名设备和绘图平板电脑支持;参阅 Flash 重定向多媒体策略设置,了解视频回退防护。

StoreFront 3.0.1

LTSR 版本:3.0.1

本版本最初是在 2015 年 9 月 30 日作为 Feature Pack 3 的一部分发布的 (CitrixStoreFront-x64.exe)

系统要求

已修复的问题

已知问题

安装/升级

将 StoreFront 的 LTSR 版本下载到 StoreFront 服务器并按照升级说明进行操作。

Provisioning Services 7.6 Update 1

LTSR 版本:Provisioning Services 7.6 Update 1(面向服务器和控制台的 Provisioning Services 7.6 累积更新 1);PVS760TargetDeviceWX64001.zip、PVS760TargetDeviceWX86001.zip

本版本最初是在 2015 年 9 月 15 日作为 PVS760ConsoleServerWX86001.zip 发布的;PVS760ConsoleServerWX64001.zip

Provisioning Services 7.6 Update 1 中包含在基础 7.6 版本中发现的 40 多个问题的修复。

系统要求

已修复的问题

安装/升级

下载 Provisioning Services 的 LTSR 版本并按照安装 Provisioning Services 控制台软件(控制台)、安装 Provisioning Services 服务器软件(服务器)和 CTX135746(目标设备)中的安装说明进行操作。

Session Recording 7.6.100

LTSR 版本:7.6.100

本版本最初是在 2015 年 6 月 30 日作为 Feature Pack 2 的一部分发布的 (SessionRecording7.6.100.zip)

作为 Feature Pack 2 的一部分发布的 Session Recording 7.6.100 包括以下新增功能和增强功能。

  • 可以在安装 Session Recording 数据库组件时指定数据库的连接凭据。
  • 可以在安装 Session Recording 数据库和 Session Recording Server 组件时测试数据库的连接性,在安装 Session Recording Agent 组件时测试 Session Recording Server 的连接性。
  • 安装 Session Recording 数据库无需具备 Microsoft Shared Management Objects。
  • Citrix 体验改善计划 (CEIP) 集成到 Session Recording 中。有关详细信息,请参阅关于 Citrix 客户体验改善计划。升级过程中保留现有设置。

系统要求

安装/升级

下载 LTSR 版本,然后按照升级说明进行操作。

在 LTSR 部署中使用时 Session Recording 7.6.100 的已知问题:

  • Microsoft 画图会话的录制件无法在 Session Recording Player 中正确播放。 [0604700]
  • 播放在多显示器用户设备上录制的会话时出现错误。 [0605129]

通用打印服务器 7.6.300

LTSR 版本:7.6.300

本版本最初是在 2015 年 9 月 30 日作为 Feature Pack 3 的一部分发布的 (UpsServer_7.6.300.zip)

注意:通用打印服务器由客户端和服务器组件组成。客户端组件作为 VDA 的一部分进行安装;因此,LTSR 版本中不包含任何客户端安装文件。在服务器端,LTSR 不支持在 32 位 Windows 操作系统中安装通用打印服务器;因此,仅包含 64 位服务器安装程序。

系统要求

已修复的问题

安装/升级

通用打印服务器包中包含更新版本的独立 UPS 服务器组件 (UpsServer_x64.msi) 和必备的 vcredist_x64.exe、vcredist_x86.exe 和 cdf_x64.msi 文件。

  1. 将 LTSR 版本下载到 Windows 2008 R2 SP1、Windows Server 2012 或 Windows Server 2012 R2 打印服务器。

  2. 安装必备的 vcredist_x64.exe、vcredist_x86.exe 和 cdf_x64.msi 文件。

  3. 安装通用打印服务器组件 UpsServer_x64.msi。

  4. 安装通用打印服务器组件后重新启动服务器。

通用打印客户端组件属于 VDA 安装的一部分。因此,不需要手动安装客户端组件,并且客户端组件不作为 LTSR 版本的独立组件包括在内。

有关详细信息,请参阅 预配打印机

HDX Flash 重定向

HDX Flash 重定向功能可将大部分 Adobe Flash 内容(包括动画、视频和应用程序)处理工作转移到连接至 LAN 和 WAN 的用户 Windows 设备,从而降低服务器和网络的工作负载。这样将提供更高的可扩展性,同时确保获得高清晰度用户体验。

客户端组件作为桌面和服务器操作系统 VDA 的一部分进行安装。因此,升级到 VDA 的 LTSR 版本会将您的部署升级到最新版本的 HDX Flash 重定向。

不需要安装任何服务器端组件。但是,配置 Flash 重定向时,必须同时设置服务器端和客户端。有关配置 Flash 重定向的信息,请参阅 Flash 重定向。有关 HDX Flash 最新更新的兼容性,请参阅 CTX136588