Product Documentation

系统要求

Feb 23, 2016

简介

本文档中的系统要求在发布此产品版本时有效;将定期发布更新。 本文档中未涉及的组件(例如 StoreFront、主机系统、Citrix Receiver 和插件以及 Provisioning Services)的系统要求在其各自的文档中进行说明。

重要:请在开始安装之前阅读准备安装

除非另有说明,否则组件安装程序将自动部署必备软件(如果未在计算机上检测到),例如 .NET 和 C++ 软件包。 Citrix 安装介质还包含部分必备软件。

安装介质包含多个第三方组件。 使用 Citrix 软件之前,请检查是否存在第三方安全更新并进行安装。

磁盘空间值 仅为 估计值,且是除产品映像、操作系统和其他软件所需空间以外的额外空间。

如果在单个服务器上安装所有核心组件(包括 Controller、SQL Server Express、Studio、Director、StoreFront 和 Licensing),最低需要 4 GB RAM 才能评估产品;建议为用户运行环境时使用更多 RAM。 性能 会因为您的具体配置而有所不同,包括用户数量、应用程序、桌面以及其他因素。

重要:在 Windows Server 2012 R2 系统上安装 XenApp 后,使用 Kerberos Enable Tool (XASsonKerb.exe) 以确保 Citrix Kerberos 身份验证正确运行。 此工具位于安装介质上的“Support”(支持)>“Tools”(工具)>“XASsonKerb”文件夹中;必须具有本地管理员权限才能使用此工具。 要确保 Kerberos 正确运行,请从服务器上的命令提示窗口运行 xassonkerb.exe -install。 如果稍后应用更改注册表位置 HKLM\System\CurrentControlSet\Control\LSA\OSConfig 的更新,请重新运行命令。 要查看所有可用工具选项,请运行带有 –help 参数的命令。

Delivery Controller

支持的操作系统:
  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition
  • Windows Server 2012 Standard Edition 和 Datacenter Edition
  • Windows Server 2008 R2 SP1 Standard Edition、Enterprise Edition 和 Datacenter Edition
要求:
  • 磁盘空间:100 MB。 连接租用(默认情况下启用)包含在此要求内;具体大小取决于用户和应用程序的数量以及模式(RDS 或 VDI))。 例如,100,000 个 RDS 用户和 100 个最近使用的应用程序需要大约 3 GB 的空间用于连接租用;具有更多应用程序的部署可能需要更大的空间。 对于专用 VDI 桌面,40,000 个桌面至少需要 400-500 MB。 建议在任何情况下都提供多个 GB 级额外空间。
  • Microsoft .NET Framework 3.5.1(仅限 Windows Server 2008 R2)。
  • Microsoft .NET Framework 4.5.1(也支持 4.5.2 和 4.6)。
  • Windows PowerShell 2.0(随 Windows Server 2008 R2 提供)或 3.0(随 Windows Server 2012 R2 和 Windows Server 2012 提供)。
  • Visual C++ 2008 SP1 可再发行组件包。

数据库

站点配置数据库、配置日志记录数据库和监视数据库支持的 Microsoft SQL Server 版本如下:

  • SQL Server 2014 Express Edition、Standard Edition 和 Enterprise Edition。
  • SQL Server 2012 SP1 和 SP2、Express Edition、Standard Edition 和 Enterprise Edition。 默认情况下,如果未检测到支持的现有 SQL Server 安装,安装 Controller 时将安装 SQL Server 2012 SP2 Express。
  • SQL Server 2008 R2 SP2 Express Edition、Standard Edition、Enterprise Edition 和 Datacenter Edition。

支持下列数据库功能(SQL Server Express 除外,此版本仅支持独立模式):

  • SQL Server 群集实例
  • SQL Server 镜像
  • SQL Server 2012 AlwaysOn 可用性组

Controller 与 SQL Server 数据库之间的连接需要 Windows 身份验证。

有关详细信息,请参阅数据库一文。

Citrix Studio

支持的操作系统:

  • Windows 10 Pro Edition、Enterprise Edition 和 Educational Edition
  • Windows 8.1 Professional Edition 和 Enteprise Edition
  • Windows 8 Professional Edition 和 Enteprise Edition
  • Windows 7 Professional Edition、Enterprise Edition 和 Ultimate Edition
  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition
  • Windows Server 2012 Standard Edition 和 Datacenter Edition
  • Windows Server 2008 R2 SP1 Standard Edition、Enterprise Edition 和 Datacenter Edition

要求:

  • 磁盘空间:75 MB
  • Microsoft .NET Framework 4.5.1(也支持 4.5.2 和 4.6)
  • Microsoft .NET Framework 3.5 SP1(仅限 Windows Server 2008 R2 和 Windows 7)
  • Microsoft Management Console 3.0(随所有支持的操作系统提供)
  • Windows PowerShell 2.0(随 Windows 7 和 Windows Server 2008 R2 提供)或 3.0(随 Windows 10、Windows 8.1、Windows 8、Windows Server 2012 R2 和 Windows Server 2012 提供)

Citrix Director

支持的操作系统:

  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition。
  • Windows Server 2012 Standard Edition 和 Datacenter Edition
  • Windows Server 2008 R2 SP1 Standard Edition、Enterprise Edition 和 Datacenter Edition

System Center Operations Manager (SCOM) 集成需要:

  • Windows Server 2012 R2
  • System Center 2012 R2 Operations Manager

要求:

  • 磁盘空间:140 MB。
  • Microsoft .NET Framework 4.5.1(也支持 4.5.2 和 4.6)。
  • Microsoft .NET Framework 3.5 SP1(仅限 Windows Server 2008 R2)
  • Microsoft Internet Information Services (IIS) 7.0 和 ASP.NET 2.0。 确保 IIS 服务器角色安装了静态内容角色服务。 如果尚未安装这些项,系统会提示您插入 Windows Server 安装介质并进行安装。
  • 支持查看 Director 的浏览器:
    • Internet Explorer 11 或 10。 Internet Explorer 不支持兼容模式。 您必须使用建议的浏览器设置访问 Director。 安装 Internet Explorer 时,接受默认设置以使用建议的安全性和兼容性设置。 如果已经安装了浏览器并选择不使用建议的设置,请转到“工具 > Internet 选项 > 高级 > 重置”并按照说明进行操作。
    • Microsoft Edge。
    • Firefox ESR(扩展支持版本)。
    • Chrome。

有关 Director 控制台的最佳分辨率的信息,请参阅此博客文章

Virtual Delivery Agent (VDA) for Windows Desktop OS

支持的操作系统:

  • Windows 10 Pro、Enterprise 和 Educational Edition Windows 10 不支持以下功能:
    • HDX 3D Pro
    • GPU 加速
    • 桌面组合重定向
    • 旧图形模式
    • 安全启动
    • 使用 VM 托管应用程序发布通用 Windows 应用程序
  • Windows 8.1 Professional Edition 和 Enteprise Edition
  • Windows 8 Professional Edition 和 Enteprise Edition
  • Windows 7 SP1 Professional Edition、Enterprise Edition 和 Ultimate Edition

要使用服务器 VDI 功能,可以在受支持的服务器操作系统上使用命令行界面安装 VDA for Windows Desktop OS;有关指南,请参阅服务器 VDI 一文。

  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition。
  • Windows Server 2012 Standard Edition 和 Datacenter Edition
  • Windows Server 2008 R2 SP1 Standard Edition、Enterprise Edition 和 Datacenter Edition

要求:

  • Microsoft .NET Framework 4.5.1(也支持 4.5.2 和 4.6)
  • Microsoft .NET Framework 3.5.1(仅限 Windows 7)
  • Microsoft Visual C++ 2008 SP1、2010 SP1 和 2013 Runtime(32 位和 64 位)

Remote PC Access 使用此 VDA(您可将其安装在办公室物理 PC 上)。

多种多媒体加速功能(如 HDX MediaStream Windows Media 重定向)要求在安装 VDA 的计算机上安装 Microsoft 媒体基础。 如果该计算机未安装媒体基础,将无法安装和使用多媒体加速功能。 请勿在安装 Citrix 软件后从计算机上删除媒体基础;否则,用户将无法登录到此计算机。 在大多数受支持的 Windows 桌面操作系统版本上,已经安装了媒体基础支持,不能将其删除。 但是,N 版本不包括某些与媒体相关的技术;您可以从 Microsoft 或第三方获取该软件。

在 VDA 安装期间,可以选择安装 HDX 3D Pro 版的 VDA for Windows Desktop OS。 此版本特别适合与 DirectX 和 OpenGL 驱动的应用程序以及视频等富媒体结合使用。 请注意,Windows 10 不支持该功能。

无法在运行 Windows XP 或 Windows Vista 的计算机上安装当前版本的 VDA;但是,如果需要,您可以在这些操作系统上安装早期版本的 Virtual Desktop Agent。 有关详细信息,请参阅 CTX140941。 此版本中的 Remote PC Access 版本在 Windows Vista 操作系统上不受支持。

Virtual Delivery Agent (VDA) for Windows Server OS

支持的操作系统:

  • Windows Server 2012 R2 Standard Edition 和 Datacenter Edition。
  • Windows Server 2012 Standard Edition 和 Datacenter Edition
  • Windows Server 2008 R2 SP1 Standard Edition、Enterprise Edition 和 Datacenter Edition

安装程序将自动部署以下必要的组件,这些组件也可以在 Citrix 安装介质上的 Support 文件夹中找到:

  • Microsoft .NET Framework 4.5.1(也支持 4.5.2 和 4.6)
  • Microsoft .NET Framework 3.5.1(仅限 Windows Server 2008 R2)
  • Microsoft Visual C++ 2008 SP1、2010 SP1 和 2013 Runtime(32 位和 64 位)

如果尚未安装并启用远程桌面服务角色服务,安装程序会自动安装并启用。

多种多媒体加速功能(如 HDX MediaStream Windows Media 重定向)要求在安装 VDA 的计算机上安装 Microsoft 媒体基础。 如果该计算机未安装媒体基础,将无法安装和使用多媒体加速功能。 请勿在安装 Citrix 软件后从计算机上删除媒体基础;否则,用户将无法登录到此计算机。 在大多数 Windows Server 2012 R2、Windows Server 2012 和 Windows Server 2008 R2 版本中,媒体基础功能通过服务器管理器进行安装(对于 Windows Server 2012 R2 和 Windows Server 2012:ServerMediaFoundation;对于 Windows Server 2008 R2:DesktopExperience)。 但是,N 版本不包括某些与媒体相关的技术;您可以从 Microsoft 或第三方获取该软件。

主机/虚拟化资源

支持的平台:

  • XenServer。
    • XenServer 6.5 和 SP1
    • XenServer 6.2 SP1 加上修补程序(必须应用 SP1 才能应用将来的修补程序)
    • XenServer 6.1
  • VMware vSphere。 不支持 vSphere vCenter“链接模式”操作。
    • VMware vSphere 6.0 和 Update 1
    • VMware vSphere 5.5 和 Update 1 到 Update 3
    • VMware vSphere 5.1 Update 2 和 Update 3
    • VMware vSphere 5.0 Update 2 和 Update 3
    • VMware vCenter 5.5/6 设备
  • System Center Virtual Machine Manager - 包括可以注册到受支持的 System Center Virtual Machine Manager 版本的任意 Hyper-V 版本。
    • System Center Virtual Machine Manager 2012 R2
    • System Center Virtual Machine Manager 2012 SP1
    • System Center Virtual Machine Manager 2012
  • Nutanix Acropolis 4.5。 使用此平台时,多项 XenApp 和 XenDesktop 功能不可用;有关详细信息,请参阅 CTX202032。 有关结合使用此产品与 Acropolis 的详细信息,请参阅 https://portal.nutanix.com/#/page/docs

您还可以在以下云环境中部署此产品:

  • Amazon Web Services (AWS)
    • 可以在支持的 Windows 服务器操作系统上置备应用程序和桌面。
    • SQL Server 2012 Enterprise 在 AWS 上不可用。
    • AWS 不提供桌面操作系统实例。
    • 不支持 Amazon Relational Database Service (RDS)。
    • 有关其他信息,请参阅 AWS 文档和 CTX140631
  • Citrix CloudPlatform
    • 支持的最低版本为含修补程序 4.2.1-4 的 4.2.1 版。
    • 部署经过 XenServer 6.2(具有 Service Pack 1 和修补程序 XS62ESP1003)和 vSphere 5.1 虚拟机管理程序的测试。
    • CloudPlatform 不支持 Hyper-V 虚拟机管理程序。
    • CloudPlatform 4.3.0.1 支持 VMware vSphere 5.5。
    • 有关其他支持信息和基于 Linux 的系统要求信息,请参阅 CloudPlatform 文档(包括您的 CloudPlatform 版本的发行说明)和 CTX140636
  • Microsoft Azure

Machine Creation Services 以及面向 VM 的运行时 Active Directory 帐户注入功能支持以下虚拟化资源和存储技术的组合。 标有星号 (*) 的组合为推荐组合。

虚拟化资源本地磁盘NFS分块存储存储链接
XenServer是*
VMware是(不支持 vMotion 或动态放置)是*
Hyper-V是*(需要群集共享卷)

 

Remote PC Access 局域网唤醒功能需要 Microsoft System Center Configuration Manager 2012。 

Active Directory 功能级别

支持以下 Active Directory 林和域功能级别:

  • Windows 2000 本机(不支持域控制器)
  • Windows Server 2003
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2

HDX

Receiver for Windows 和 Citrix Receiver for Linux 13 支持多流 ICA 的 UDP 音频。

Citrix Receiver for Windows 支持回声消除。

请参阅下文具体的 HDX 功能支持和要求。

HDX 桌面组合重定向

Windows 用户设备或瘦客户端必须支持或包含:

  • DirectX 9
  • Pixel Shader 2.0(硬件支持)
  • 32 位/像素
  • 1.5 GHz 32 位或 64 位处理器
  • 1 GB RAM
  • 图形卡或集成图形处理器上具有 128 MB 视频内存

    HDX 将查询 Windows 设备,以验证设备是否具备所需的 GPU 功能,如果不具备所需功能,则自动恢复为服务器端桌面组合。 具有所需 GPU 功能、但不符合处理器速度或 RAM 规格要求的设备将列在从桌面组合重定向中排除的设备 GPO 组中。

最小可用带宽为 1.5 Mbps;建议带宽为 5 Mbps。 这些值包含了端到端延迟。

HDX Windows Media 交付

以下客户端支持 Windows Media 客户端内容提取、Windows Media 重定向和实时 Windows Media 多媒体代码转换功能:Citrix Receiver for Windows、Citrix Receiver for iOS 和 Citrix Receiver for Linux。

要在 Windows 8 设备上使用 Windows Media 客户端内容提取,请将 Citrix Multimedia Redirector 设置为默认程序:在控制面板 > 程序 > 默认程序 > 设置默认程序中,选择 Citrix Multimedia Redirector,然后单击将此程序设置为默认程序选择此程序的默认值

执行 GPU 代码转换需使用具有 Compute Capability 1.1 或更高版本且支持 NVIDIA CUDA 的 GPU;请参阅 http://developer.nvidia.com/cuda/cuda-gpus

HDX Flash 重定向

支持以下客户端和 Adobe Flash Player:

  • Citrix Receiver for Windows(支持第二代 Flash 重定向功能)- 第二代 Flash 重定向功能要求安装适用于其他浏览器的 Adobe Flash Player(有时称为 NPAPI(Netscape 插件应用程序编程接口)Flash Player)
  • Citrix Receiver for Linux(支持第二代 Flash 重定向功能)- 第二代 Flash 重定向功能需要安装适用于其他 Linux 的 Adobe Flash Player 或 Adobe Flash Player for Ubuntu。
  • Citrix 联机插件 12.1(支持旧的 Flash 重定向功能)- 旧的 Flash 重定向功能要求安装 Adobe Flash Player for Windows Internet Explorer(有时称为 ActiveX 播放器)。

用户设备上的 Flash Player 主版本号必须大于或等于服务器上的 Flash Player 主版本号。 如果用户设备上安装了早期版本的 Flash Player,或者用户设备上无法安装 Flash Player,则 Flash 内容将在服务器上呈现。

运行 VDA 的计算机需要:

  • Adobe Flash Player for Windows Internet Explorer(ActiveX 播放器)
  • Internet Explorer 版本 7、8、9、10 和 11(非 Metro UI 模式)。 Flash 重定向要求在服务器上安装 Internet Explorer;对于其他浏览器,Flash 内容将在服务器上呈现。
  • 在 Internet Explorer 中禁用保护模式(不要选中“工具”>“Internet 选项”>“安全”选项卡>“启用保护模式”复选框)。 重新启动 Internet Explorer 以使更改生效。

HDX 3D Pro

安装 VDA for Windows Desktop OS 时,可以选择安装 HDX 3D Pro 版本(例外:运行 Windows 10 的计算机)。

托管应用程序的物理机或虚拟机可以使用 GPU 直通或虚拟 GPU (vGPU) 功能:

  • Citrix XenServer 中提供了 GPU 直通功能。 GPU 直通也可随 VMware vSphere 和 VMware ESX 获得,此时它称为虚拟直接图形加速 (vDGA)。
  • Citrix XenServer 和 VMware vSphere 中提供了 vGPU 功能;请访问 www.citrix.com/go/vGPU(需要提供 Citrix 我的账户凭据)。

Citrix 建议的主机计算机规格如下:至少 4 GB RAM,4 个时钟速度至少为 2.3 GHz 的虚拟 CPU。

图形处理器 (GPU):

  • 对于基于 CPU 的压缩(包括无损压缩),HDX 3D Pro 支持主机计算机上与要交付的应用程序兼容的任何显示适配器。
  • 为通过 NVIDIA GRID API 实现优化的 GPU 帧缓冲问访问,HDX 3D Pro 要求安装具有最新 NVIDIA 驱动程序的 NVIDIA Quadron 图形卡。 NVIDIA GRID 将提供较高的帧速率,从而实现高度互动的用户体验。
  • 对于使用 XenServer 的 vGPU,HDX 3D Pro 的要求包括 NVIDIA GRID K1 和 K2 卡。

用户设备:

  • HDX 3D Pro 支持主机计算机上的 GPU 支持的所有显示器分辨率。 但是,要在建议的最低用户设备和 GPU 规格条件下实现最佳性能,Citrix 提出了以下建议:对于 LAN 连接,建议为用户设备将显示器最大分辨率设置为 1920 x 1200 像素,对于 WAN 连接,建议将其设置为 1280 x 1024 像素。
  • Citrix 建议的用户设备规格如下:至少 1 GB RAM,1 个时钟速度至少为 1.6 GHz 的 CPU。 要使用适用于低带宽连接的默认的深度压缩编解码器,需要功能更强大的 CPU,除非解码在硬件上完成。 要获得最佳性能,Citrix 建议用户设备至少配有一个 2 GB 的 RAM 以及一个时钟速度至少为 3 GHz 的双核 CPU。
  • 对于多监视器访问,Citrix 建议在用户设备中配备四核 CPU。
  • 用户设备无需配备专用 GPU 即可访问通过 HDX 3D Pro 交付的桌面或应用程序。
  • 必须安装 Citrix Receiver。

HDX 视频会议对网络摄像机视频压缩的要求

支持的客户端:Citrix Receiver for Windows、Citrix Receiver for Mac 和 Citrix Receiver for Linux。

支持的视频会议应用程序:

  • Cirix GoToMeeting HDFaces
  • Adobe Connect
  • Cisco WebEx
  • IBM Sametime
  • Microsoft Lync 2010 和 2013
  • Microsoft Office Communicator
  • Google+ Hangouts
  • Windows 8.x、Windows Server 2012 和 Windows Server 2012 R2 上基于 Media Foundation 的视频应用程序
  • Skype 6.7

要在 Windows 客户端上使用 Skype,请在客户端和服务器上编辑注册表:

  • 客户端注册表项 HKEY_CURRENT_USER\Software\Citrix\HdxRealTime

    名称:DefaultHeight 类型:REG_DWORD 值:240
    名称:DefaultWidth 类型:REG_DWORD 值:320

  • 服务器注册表项 HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Vd3d\Compatibility

    名称:skype.exe,类型:REG_DWORD,数据:设置为 0

其他用户设备要求:

  • 产生声音的相应硬件。
  • 与 DirectShow 兼容的网络摄像机(使用网络摄像机默认设置)。 支持硬件编码的网络摄像机可降低客户端的 CPU 使用率。
  • 如有可能,应安装网络摄像机制造商提供的网络摄像机驱动程序。

Session Recording

Session Recording Administration 组件

Session Recording Administration 组件(Session Recording 数据库、Session Recording Server、Session Recording 策略控制台)可以安装在单台服务器或不同服务器上。

支持的操作系统:

  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2 SP1

Session Recording 数据库

支持的 Microsoft SQL Server 版本:

  • Microsoft SQL Server 2014(Enterprise Edition 和 Express Edition)
  • Microsoft SQL Server 2012 SP2(Enterprise Edition 和 Express Edition)
  • Microsoft SQL Server 2008 R2 SP3(Enterprise Edition 和 Express Edition)

要求:.NET Framework 3.5 SP1(仅限 Windows Server 2008 R2)或 .NET Framework 4.5.1 或 4.6。

Session Recording Server

必须先安装必备项,然后再安装 Session Recording Server。 在服务器管理器中,添加 IIS 角色并选择以下选项:

  • 应用程序开发 > ASP.NET 4.5(在 Server 2012 和 Server 2012 R2 上) 或 ASP.NET(在 Server 2008 R2 上)。 其他组件将自动选择;单击添加接受所需角色。
  • 安全性 > Windows 身份验证
  • 管理工具 > IIS 6 管理兼容性
    • IIS 6 元数据库兼容性
    • IIS 6 WMI 兼容性
    • IIS 6 脚本工具
    • IIS 6 管理控制台

其他要求:

  • .NET Framework 3.5 SP1(仅限 Windows Server 2008 R2)或 .NET Framework 4.5.1 或 4.6。
  • 如果 Session Recording Server 使用 HTTPS 作为其通信协议,请添加有效证书。 默认情况下,Session Recording 使用 HTTPS(Citrix 推荐)。
  • Microsoft 消息队列 (MSMQ),Active Directory 集成处于禁用状态,MSMQ HTTP 支持处于启用状态。

Session Recording 策略控制台

要求:.NET Framework 3.5 SP1(仅限 Windows Server 2008 R2)或 .NET Framework 4.5.1 或 4.6。

Session Recording Agent

在要录制会话的每台 XenApp 和 XenDesktop 服务器上安装 Session Recording Agent。

支持的操作系统:

  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2 SP1

要求:

  • XenApp 或 XenDesktop,最低版本 7.6 FP1
  • .NET Framework 3.5 SP1、4.5.1 或 4.6(应该已安装)
  • Microsoft 消息队列 (MSMQ),Active Directory 集成处于禁用状态,MSMQ HTTP 支持处于启用状态

Session Recording Player

支持的操作系统:

  • Microsoft Windows 8.1
  • Microsoft Windows 8
  • Microsoft Windows 7 SP1

要求:.NET Framework 3.5 SP1、4.5.1 或 4.6。

要获得最佳结果,在以下工作站上安装 Session Recording Player:

  • 屏幕分辨率为 1024 x 768
  • 颜色深度至少为 32 位
  • 1 GB RAM(最低);更多 RAM 和 CPU/GPU 资源可提高播放图形密集型录制件时的性能,特别是当录制件中有大量动画时

搜寻响应时间取决于录制件的大小和计算机的硬件规格。

Session Recording 语言

Session Recording 提供英语、法语、德语、日语、西班牙语和简体中文版本。 所有互相连接的 Session Recording 组件必须是同一个语言版本;不支持混合语言的安装。

英语版本的 Session Recording 在英语、俄语、繁体中文和韩语的操作系统上受支持。 法语、德语、日语、西班牙语和简体中文版本的 Session Recording 在其各自语言的操作系统上受支持。

通用打印服务器

通用打印服务器由客户端和服务器组件组成。 UpsClient 组件包含在 VDA 安装中。 UPServer 组件安装在每台打印服务器上,在用户会话中通过 Citrix 通用打印驱动程序置备的共享打印机驻留在这些打印服务器上。

以下操作系统支持 UpsServer 组件:

  • Windows Server 2012 R2 和 2012
  • Windows Server 2008 R2 SP1
  • Windows Server 2008(32 位)

要求:Microsoft Visual C++ 2013 Runtime

对于 VDA for Windows Server OS,打印操作期间的用户身份验证要求通用打印服务器加入与 VDA 相同的域。 

也可以下载独立的客户端和服务器组件软件包。

有关详细信息,请参阅置备打印机一文。

其他

  • Citrix 建议安装或升级到在安装介质中为此版本提供的组件软件版本。
    • StoreFront 需要 2 GB 内存。 有关系统要求,请参阅 StoreFront 文档。 StoreFront 2.6 是此版本所支持的最低版本。
    • 将 Provisioning Services 与此版本结合使用时,支持的最低 Provisioning Services 版本是 7.0。
    • Citrix 许可证服务器需要 40 MB 磁盘空间。 有关系统要求,请参阅许可文档。 仅支持 Citrix License Server for Windows。 支持的最低版本是 11.13.1。
  • 如果您将 Citrix 策略信息存储在 Active Directory 而非站点配置数据库中,则需要 Microsoft 组策略管理控制台 (GPMC)。 有关详细信息,请参阅 Microsoft 文档。
  • 支持多个网络接口卡。
  • 默认情况下,安装 VDA 时将安装 Citrix Receiver for Windows。 有关详细信息,请参阅 Citrix Receiver for Windows 文档。
  • 将 Access Gateway 10.0 之前的版本与此版本结合使用时,不支持高于 Windows 7 的 Windows 客户端。
  • 有关受支持的版本,请参阅 App-V 文章。
  • 客户端文件夹重定向 - 支持的操作系统:
    • 服务器:Windows Server 2008 R2 SP1、Windows Server 2012 和 Windows Server 2012 R2
    • 客户端(具有最新的 Citrix Receiver for Windows):Windows 7、Windows 8 和 Windows 8.1