Product Documentation

打开和播放录制件

Sep 15, 2015

可以通过以下方式在 SmartAuditor 播放器中打开会话录制件:

  • 使用 Smart Auditor 播放器执行搜索。满足搜索条件的录制的会话将显示在搜索结果区域中。
  • 直接从本地磁盘驱动器或共享驱动器访问录制的会话文件。
  • 从“收藏夹”文件夹访问录制的会话文件。

打开未使用数字签名录制的文件时,系统会显示一条警告消息,指出未验证该文件的来源和完整性。如果您确信该文件的完整性,请在警告弹出窗口中单击以打开该文件。

打开和播放搜索结果区域中的录制件

  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 开始菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 执行搜索。
  4. 如果未显示搜索结果区域,请在“工作区”窗格中选择搜索结果
  5. 在搜索结果区域中,选择要播放的会话。
  6. 执行以下任何操作:
    • 双击会话
    • 单击鼠标右键并选择播放
    • 在 SmartAuditor 播放器菜单栏中,依次选择播放 > 播放

通过访问文件打开和播放录制件

录制的会话文件名以 i_ 开头,后面依次是唯一的字母数字文件 ID、.icl 和 .icle 文件扩展名:.icl 是未应用播放保护的录制件,而 .icle 是应用了播放保护的录制件。SmartAuditor 以包含会话录制日期的目录结构保存录制的会话文件。例如,在 2008 年 5 月 22 日录制的会话文件,保存在文件夹路径 2008\05\22 下。
  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 开始菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 执行以下任何操作:
    • 在 SmartAuditor 播放器菜单栏中,依次选择文件 > 打开,并浏览文件
    • 使用 Windows 资源管理器,导航至文件,并将文件拖动到播放器窗口中
    • 使用 Windows 资源管理器,导航至文件,并双击该文件
    • 如果在“工作区”窗格中创建了“收藏夹”,请选择收藏夹,并通过与在搜索结果区域中打开文件相同的方法从“收藏夹”区域打开该文件

使用收藏夹

通过创建“收藏夹”文件夹,您可以快速访问经常查看的录制件。这些“收藏夹”文件夹引用存储在工作站或网络驱动器上的录制的会话文件。可以将这些文件导入到其他工作站,也可以从其他工作站导出这些文件,并且可以与其他 SmartAuditor 播放器用户共享这些文件夹。

注意:只有具有对 SmartAuditor 播放器的访问权限的用户才能下载与“收藏夹”文件夹相关联的录制的会话文件。要获取访问权限,请与您的 SmartAuditor 管理员联系。

创建“收藏夹”子文件夹:

  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 开始菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 在 SmartAuditor 播放器中,选择“工作区”窗格中的收藏夹文件夹。
  4. 从菜单栏中,依次选择文件 > 文件夹 > 新建文件夹收藏夹文件夹下将显示一个新文件夹。
  5. 键入文件夹名称,然后按 Enter 或单击任意位置以接受新名称。
使用文件 > 文件夹菜单中显示的其他选项可删除、重命名、移动、复制、导入和导出文件夹。

搜索录制的会话

SmartAuditor 播放器允许您执行快速搜索、执行高级搜索,以及指定应用到所有搜索的选项。搜索结果显示在 SmartAuditor 播放器的搜索结果区域。

注意:要显示所有可用的录制会话(搜索中可以显示的会话的最大数量),在执行搜索时请不要指定任何搜索参数。
  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 开始菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 定义搜索条件:
    • 搜索字段中输入搜索条件。有助于您实现以下操作:
    • 将鼠标指针移动到搜索标签上以显示要用作指导的参数列表
    • 单击搜索字段右侧的箭头以显示最近执行的 64 次搜索的文本
    • 使用搜索字段右侧的下拉列表以选择用于指定会话录制时间的时段或持续时间
  4. 单击下拉列表右侧的望远镜图标以启动搜索。

执行高级搜索

  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 开始菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 在 SmartAuditor 播放器窗口中,单击工具栏上的高级搜索,或者依次选择工具 > 高级搜索
  4. 高级搜索对话框的选项卡中定义搜索条件。
    • 公用允许您按域或帐户授权、服务器场、组、区域、服务器、应用程序或文件 ID 进行搜索。
    • 日期/时间允许您搜索日期、星期和一天中的时间。
    • 事件允许您搜索 SmartAuditor 管理员插入到会话中的自定义事件。
    • 其他允许您按会话名称、客户端名称、客户端地址以及录制持续时间进行搜索。它还允许您为此搜索指定搜索结果的最大显示数目以及搜索中是否包含存档文件。
    指定搜索条件时,您正在创建的查询将显示在对话框底部的窗格中。
  5. 单击搜索以启动搜索。

设置搜索选项

SmartAuditor 播放器搜索选项允许您限制搜索结果中显示的会话录制件的最大数量,以及指定搜索结果中是否包含存档会话文件。
  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 开始菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 在 SmartAuditor 播放器菜单栏中,依次选择工具 > 选项 > 搜索
  4. 要显示的最大结果数量字段中,键入要显示的搜索结果数量。 最多可显示 500 条结果。
  5. 要设置搜索中是否包含存档文件,请选择或清除包括存档文件

播放录制的会话

在 SmartAuditor 播放器中打开录制的会话之后,可以使用以下方法浏览录制的会话:

  • 使用播放器控件播放、停止、暂停以及提高或降低播放速度
  • 使用搜寻滑块快进或快退

如果您在录制件中插入了标记,或者录制的会话中包含自定义事件,也可以通过转到这些标记和事件来浏览录制的会话。

注意:在播放录制的会话期间,可能会显示第二个鼠标指针。如果用户在 Internet Explorer 7.0 中浏览并单击了原本比屏幕大但 Internet Explorer 7.0 自动将其缩小了的图像,录制件中的该点处将显示第二个指针。虽然会话期间仅显示一个指针,但播放过程中可能会显示两个。
注意:此版本的 SmartAuditor 不支持 Citrix Presentation Server 的 SpeedScreen Multimedia Acceleration 或 Citrix XenApp 的 Flash 质量调整策略。如果启用了此选项,播放将显示一个黑色方块。

使用搜寻滑块

使用播放器窗口下方的搜寻滑块可跳至录制的会话中的不同位置。可以将搜寻滑块拖动到录制件中要查看的点,也可以单击滚动条的任意位置以移动到该位置。

还可以使用以下键盘快捷键来控制搜寻滑块:

键: 搜寻操作:
主页 搜寻到开头。
End 搜寻到结尾。
向右键 向前搜寻 5 秒。
向左键 向后搜寻 5 秒。
将鼠标滚轮向下滚动一格 向前搜寻 15 秒。
将鼠标滚轮向上滚动一格 向后搜寻 15 秒。
Ctrl + 向右键 向前搜寻 30 秒。
Ctrl + 向左键 向后搜寻 30 秒。
Page Down 向前搜寻 1 分钟。
Page Up 向后搜寻 1 分钟。
Ctrl + 将鼠标滚轮向下滚动一格 向前搜寻 90 秒。
Ctrl + 将鼠标滚轮向上滚动一格 向后搜寻 90 秒。
Ctrl + Page Down 向前搜寻 6 分钟。
Ctrl + Page Up 向后搜寻 6 分钟。
注意:调整搜寻滑块的速度:从 SmartAuditor 播放器菜单栏中,依次选择工具 > 选项 > 播放器,并拖动滑块以增加或降低搜寻响应时间。响应时间越快,所需内存越多。

更改播放速度

可以将 SmartAuditor 播放器设置为以从正常播放速度的四分之一到 32 倍的指数增量来播放录制的会话。

  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 开始菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 从 SmartAuditor 播放器菜单栏中,依次选择播放 > 播放速度
  4. 选择一个速度选项。 速度会立即调整。在播放器窗口控件的下方将显示一个数字,指示增加或减少的速度。指示指数率的文本在播放器窗口中会暂时显示为绿色。

跳过没有操作的空白部分

在快速查看模式下,可以将 SmartAuditor 播放器设置为跳过录制的会话中没有发生操作的部分。此设置可节省观看播放的时间;但是,它不会跳过连续动画,例如连续移动的鼠标指针、闪烁的光标或显示的包含秒针移动的时钟。

  1. 登录到安装了 SmartAuditor 播放器的工作站。
  2. 从“开始”菜单中,依次选择所有程序 > Citrix > SmartAuditor > SmartAuditor 播放器
  3. 从 SmartAuditor 播放器菜单栏中,依次选择播放 > 快速查看模式该选项将打开或关闭。每次选择该选项时,其状态在播放器窗口中会暂时显示为绿色。