Product Documentation

To open and play recordings

Oct 09, 2015

You can open session recordings in SmartAuditor Player in two ways:

  • Perform a search using the Smart Auditor Player. Recorded sessions that meet the search criteria appear in the search results area.
  • Access recorded session files directly from your local disk drive or a share drive.
  • Access recorded session files from a Favorites folder

When you open a file that was recorded without a digital signature, a warning appears telling you that the origin and integrity of the file was not verified. If you are confident of the integrity of the file, click Yes in the warning pop-up window to open the file.

To open and play a recording in the search results area

  1. Log on to the workstation where SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. Perform a search.
  4. If the search results area is not visible, select Search Results in the Workspace pane.
  5. In the search results area, select the session you want to play.
  6. Do any of the following:
    • Double-click the session
    • Right-click and select Play
    • From the SmartAuditor Player menu bar, select Play > Play

To open and play a recording by accessing the file

Recorded session file names begin with an i_, followed by a unique alphanumeric file ID, followed by the .icl and .icle file extension: .icl for recordings without playback protection applied, .icle for recordings with playback protection applied. SmartAuditor saves recorded session files in a directory structure that incorporates the date the session was recorded. For example, the file for a session recorded on May 22, 2008, is saved in folder path 2008\05\22.
  1. Log on to the workstation where SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. Do any of the following:
    • From the SmartAuditor Player menu bar, select File > Open and browse for the file
    • Using Windows Explorer, navigate to the file and drag the file into the Player window
    • Using Windows Explorer, navigate to and double-click the file
    • If you created Favorites in the Workspace pane, select Favorites and open the file from the Favorites area in the same way you open files from the search results area

Using Favorites

Creating Favorites folders allows you to quickly access recordings that you view frequently. These Favorites folders reference recorded session files that are stored on your workstation or on a network drive. You can import and export these files to other workstations and share these folders with other SmartAuditor Player users.

Note: Only users with access rights to SmartAuditor Player can download the recorded session files associated with Favorites folders. Contact your SmartAuditor administrator for access rights.

To create a Favorites subfolder:

  1. Log on to the workstation where SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. In the SmartAuditor Player, select the Favorites folder in your Workspace pane.
  4. From the menu bar, choose File > Folder > New Folder. A new folder appears under the Favorites folder.
  5. Type the folder name, then press Enter or click anywhere to accept the new name.
Use the other options that appear in the File > Folder menu to delete, rename, move, copy, import, and export the folders.

To search for recorded sessions

Updated: 2015-05-05

SmartAuditor Player allows you to perform quick searches, perform advanced searches, and specify options that apply to all searches. Results of searches appear in the search results area of the SmartAuditor Player.

Note: To display all available recorded sessions, up to the maximum number of sessions that may appear in a search, perform a search without specifying any search parameters.

To perform a quick search

  1. Log on to the workstation where SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. Define your search criteria:
    • Enter a search criterion in the Search field. To assist you:
    • Move the mouse pointer over the Search label to display a list of parameters to use as a guideline
    • Click the arrow to the right of the Search field to display the text for the last 64 searches you performed
    • Use the drop-down list to the right of the Search field to select a period or duration specifying when the session was recorded.
  4. Click the binocular icon to the right of the drop-down list to start the search.

To perform an advanced search

  1. Log on to the workstation where SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. In the SmartAuditor Player window, click Advanced Search on the tool bar or choose Tools > Advanced Search.
  4. Define your search criteria in the tabs of the Advanced Search dialog box:
    • Common allows you to search by domain or account authority, server farm, group, zone, server, application, or file ID.
    • Date/Time allows you to search date, day of week, and time of day.
    • Events allows you to search on custom events that your SmartAuditor administrator inserted to the sessions.
    • Other allows you to search by session name, client name, client address, and recording duration. It also allows you to specify, for this search, the maximum number of search results displayed and whether or not archived files are included in the search.
    As you specify search criteria, the query you are creating appears in the pane at the bottom of the dialog box.
  5. Click Search to start the search.
Tip: You can save and retrieve advanced search queries. Click Save within the Advanced Search dialog box to save the current query. Click Open within the Advanced Search dialog box to retrieve a saved query. Queries are saved as files with an .isq extension.

To set search options

SmartAuditor Player search options allow you to limit maximum number of session recordings that appear in search results and to specify whether or not search results include archived session files.
  1. Log on to the workstation where SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. From the SmartAuditor Player menu bar, choose Tools > Options > Search.
  4. In the Maximum result to display field, type the number of search results you want to display. A maximum of 500 results can be displayed.
  5. To set whether or not archived files are included in searches, select or clear Include archived files.

To play recorded sessions

After you open a recorded session in the SmartAuditor Player, you can navigate through the recorded sessions using these methods:

  • Use the player controls to play, stop, pause, and increase or decrease playback speed
  • Use the seek slider to move forward or backward

If you have inserted markers into the recording or if the recorded session contains custom events, you can also navigate through the recorded session by going to those markers and events.

Note: During playback of a recorded session, a second mouse pointer may appear. The second pointer appears at the point in the recording when the user navigated within Internet Explorer 7.0 and clicked an image that was originally larger than the screen but was scaled down automatically by Internet Explorer 7.0. While only one pointer appears during the session, two may appear during playback.
Note: This version of SmartAuditor does not support SpeedScreen Multimedia Acceleration for Citrix Presentation Server or the Flash quality adjustment policy setting for Citrix XenApp. When this option is enabled, playback displays a black square.

Using Player Controls

You can click the player controls under the Player window or access them by choosing Play from the SmartAuditor Player menu bar. Use Player controls to:



Play the selected session file.


Pause playback.


Stop playback. If you click Stop, then Play, the recording restarts at the beginning of the file.


Halve the current playback speed down to a minimum of one-quarter normal speed.


Double the current playback speed up to a maximum of 32 times normal speed.

Using the Seek Slider

Use the seek slider below the Player window to jump to a different position within the recorded session. You can drag the seek slider to the point in the recording you want to view or click anywhere on the slider bar to move to that location.

You can also use the following keyboard keys to control the seek slider:

Key: Seek action:
Home Seek to the beginning.
End Seek to the end.
Right Arrow Seek forward five seconds.
Left Arrow Seek backward five seconds.
Move mouse wheel one notch down Seek forward 15 seconds.
Move mouse wheel one notch up Seek backward 15 seconds.
Ctrl + Right Arrow Seek forward 30 seconds.
Ctrl + Left Arrow Seek backward 30 seconds.
Page Down Seek forward one minute.
Page Up Seek backward one minute.
Ctrl + Move mouse wheel one notch down Seek forward 90 seconds.
Ctrl + Move mouse wheel one notch up Seek backward 90 seconds.
Ctrl + Page Down Seek forward six minutes.
Ctrl + Page Up Seek backward six minutes.
Note: To adjust the speed of the seeks slider: From the SmartAuditor Player menu bar, choose Tools > Options > Player and drag the slider to increase or decrease the seek response time. A faster response time requires more memory.

To change the playback speed

You can set SmartAuditor Player to play recorded sessions in exponential increments from one-quarter normal playback speed to 32 times normal playback speed.
  1. Log on to the workstation where the SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. From the SmartAuditor Player menu bar, choose Play > Play Speed.
  4. Choose a speed option.
The speed adjusts immediately. A number indicating the increased or decreased speed appears below the Player window controls. Text indicating the exponential rate appears briefly in green in the Player window.

To skip over spaces where no action occurred

Fast review mode allows you to set SmartAuditor Player to skip the portions of recorded sessions in which no action takes place. This setting saves time for playback viewing; however, it does not skip animated sequences such as animated mouse pointers, flashing cursors, or displayed clocks with second hand movements.
  1. Log on to the workstation where SmartAuditor Player is installed.
  2. From the Start menu, choose All Programs > Citrix > SmartAuditor > SmartAuditor Player.
  3. From the SmartAuditor Player menu bar, choose Play > Fast Review Mode.
The option toggles on and off. Each time you choose it, its status appears briefly in green in the Player window.