Product Documentation

Supported Browsers

Jun 24, 2014

To access the configuration utility and Dashboard, your workstation must have a supported web browser and version 1.6 or above of the Java applet plug-in installed.

Operating System Browser Versions
Windows 7 Internet Explorer 8, 9, and 10
Mozilla Firefox 3.6.25 and above
Google Chrome 15 and above
Windows 64 bit Internet Explorer 8 and 9
Google Chrome 15 and above
MAC Mozilla Firefox 12 and above
Safari 5.1.3
Google Chrome 15 and above