Product Documentation

Dynamic Cluster Link Aggregation

Apr 29, 2015

Dynamic cluster LA channel uses Link Aggregation Control Protocol (LACP). 

You must perform similar configurations on the cluster IP address and on the external connecting device. If possible, configure the upstream switch to distribute traffic based on IP address or port instead of MAC address.

Points to remember:

  • Enable LACP (by specifying the LACP mode as either ACTIVE or PASSIVE).

    Note: Make sure the LACP mode is not set as PASSIVE on both the NetScaler cluster and the external connecting device.
  • Specify the same LACP key on each interface that you want to be the part of the channel. For creating a cluster LA channel, the LACP key can have a value from 5 through 8. For example, if you set the LACP key on interfaces 0/1/2, 1/1/2, and 2/1/2 to 5, CLA/1 is created. The interfaces 0/1/2, 1/1/2, and 2/1/2 are automatically bound to CLA/1. Similarly, if you set the LACP key to 6, CLA/2 channel is created.

  • Specify the LAG type as Cluster.

To configure a dynamic cluster LA channel by using the command line interface

On the cluster IP address, for each interface that you want to add to the cluster LA channel, type:

set interface <id> -lacpMode <lacpMode> -lacpKey <positive_integer> -lagType CLUSTER

Example: To configure a cluster LA channel CLA/1 of 3 interfaces.

> set interface 0/1/2 -lacpMode active -lacpKey 5 -lagType Cluster 
> set interface 1/1/2 -lacpMode active -lacpKey 5 -lagType Cluster 
> set interface 2/1/2 -lacpMode active -lacpKey 5 -lagType Cluster
Note: Optionally, you can enable Link Redundancy in a Cluster with LACP.

Similarly, configure dynamic LA on the external switch. The following sample configurations are provided for the Cisco® Nexus 7000 C7010 Release 5.2(1). Similar configurations must be performed on other switches.

Global config: 
Configure terminal 
feature lacp 
Interface level config: 
 
interface Ethernet2/47 
    switchport 
    switchport access vlan 10 
    channel-group 7 mode active 
    no shutdown 
 
interface Ethernet2/48 
    switchport 
    switchport access vlan 10 
    channel-group 7 mode active 
    no shutdown